View Single Post
Old 29th December 2001, 19:57   #12
Gagarins
Junior Member
 
Join Date: Dec 2001
Location: Stockholm Sweden
Posts: 16
Winamps "error killing decode thread"

It must be a BUG in Winamp, but a rare BUG, under special circumstances.

In order to get the error message you must run Winamp 24 hours/day
in several days, and also mix MP3 and WAV-files in the playlist. After some days or sometime, 2-3 weeks, you gets "error killing decode thread" and the broadcast stopped.

I have tested different Winamp versions at several different computers running Win95 & Win98 with the same result.

But, here you have answer at your questions:

1) Provide full system specs (CPU, OS, soundcard, DirectX, etc etc)

CPU from Pentium 120, AMD 400 to Celeron 700.
OS from Win95 to Win98.
Soundcard from SB16, SB Live to Turtle Beach.

2) Tell us what version of Winamp you're using

From version 2.091 to 2.72. Version 2.091 was the first version
who could play WAV-files.

3) What version of the ShoutCast DSP you're using

Don't use Shoutcast.

4) Whether you are using any extra 3rd-party Winamp plugins

Don't use any 3rd-party Winamp plugins.

5) Do you have the correct & latest drivers for soundcard?

Yes.

6) Which Output plugin you are.

From Output plugin v1.1 to v2.3.

I don't think so much people are running Winmap 24 hours day in several weeks and have mixed MP3 and WAV-files.

So, do you have any suggestions?

To test any suggestion should take several days or weeks. :-(
Possible Peter's "replacement for standard Winamp2's waveOut plugin".

thanks

Gagarin
Gagarins is offline   Reply With Quote