View Single Post
Old 12th April 2020, 01:28   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,867
If you used the support system or sent an email to support@ then please bump your ticket.

Make sure you include the email address associated with your RadioManager account, and the exact name of the station.

A working public stream url would also help
plus confirmation you are using the authhash from the RadioManager.


Most common causes for this particular problem (with DNAS stations)......


1. You are hosting the DNAS yourself but your IP is dynamic, not static.
i.e. your public ip address changes every time you either reboot the comp or restart the modem/router.

The YP caches stream url's for a certain length of time and is still using the old ip.
It will eventually update, but your ip# might change again in the meantime.

Solution?

Use a DynDNS service to bind your ip to a domain, e.g. mystream.mysite.com or whatever.
Use the destip= and publicip= lines in sc_serv.conf to link to said dynamic DNS,
then your stream url will always work, regardless of the changing ip#


2. Your stream is http not https, but you're trying to play it via https://directory.shoutcast.com on latest Chrome browser.

Solutions?

- Use http://directory.shoutcast.com instead.
- Don't use Chrome
- Get an ssl cert for a dns to make your stream https


(native support in 2.6 premium, 3rd-party hosting providers might also provide an ssl solution, or for older DNAS versions use stunnel.org)
DJ Egg is offline   Reply With Quote