View Single Post
Old 6th February 2013, 03:43   #17
anderci
Junior Member
 
Join Date: Nov 2012
Location: Colorado
Posts: 41
SxStrace is not on my developement WinXP PC. After reading over the link you provided, I modified the manifest file:

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<assembly manifestVersion="1.0" xmlns="urn:schemas-microsoft-com:asm.v1">
<assemblyIdentity type="win32" name="QueryMgr.exe" version="2.04" />
<dependency>
<dependentAssembly>
<assemblyIdentity type="win32" name="MSCOMCTL.OCX" version="6.1.97.82" />
<assemblyIdentity type="win32" name="MSCOMCT2.OCX" version="6.1.97.82" />
<!-- <assemblyIdentity type="win32" name="COMCT332.OCX" version="1.1" /> -->
<assemblyIdentity type="win32" name="RICHTX32.OCX" version="6.1.97.82" />
<assemblyIdentity type="win32" name="COMDLG32.OCX" version="6.1.97.82" />
<assemblyIdentity type="win32" name="stdole2.tlb" version="5.1.2600.5512" />
<assemblyIdentity type="win32" name="MSACC9.OLB" version="9.0.0.2719" />
<assemblyIdentity type="win32" name="EXCEL9.OLB" version="9.0.0.2719" />
<assemblyIdentity type="win32" name="VB6EXT.OLB" version="5.0.81.69" />
<assemblyIdentity type="win32" name="Comcat.dll" version="4.71.1441.1" />
<assemblyIdentity type="win32" name="dao360.dll" version="3.60.9512.0" />
<assemblyIdentity type="win32" name="MSVCRT40.DLL" version="4.10.0.6038" />
<assemblyIdentity type="win32" name="Riched32.dll" version="4.0.993.4" />
<assemblyIdentity type="win32" name="MSSTDFMT.DLL" version="6.1.97.82" />
</dependentAssembly>
</dependency>
</assembly>

I listed all of the support files included in the install .nis file. I also used the version numbers displayed by Windows Explorer file properties for each support file.

After installing with the updated manifest on a borrowed WinVista laptop PC, I tried starting the program from its Desktop shortcut. It failed (RICHTX32.OCX not registered).

1) I opened cmd window as Administrator and changed directory to $INSTDIR
2) I attempted to start sxstrace trace -logfile:sxstrace.etl (it displayed usage information?)
3) I ran querymgr from this command line: It worked! querymgr started up and ran
4) I attempted to parse: sxstrace parse -logfile:sxstrace.etl -outfile:sxstrace.txt (it, again, displayed usage information)
5) I successfully started querymgr from its desktop shortcut: Success!

This behavior is puzzling. The sxstrace program seemed not to be working. Usually when a command line program displays usage information, it is because it failed to start. I could find none of the 'log' files.
anderci is offline   Reply With Quote