View Single Post
Old 8th November 2015, 16:30   #101
returnofthem
Junior Member
 
Join Date: Nov 2015
Posts: 1
Hi guys,

I'm trying out this plugin and can't get it to work in exclusive mode at the moment. I'm on Windows 7 and if I set it to exclusive then no audio plays. I've installed the debug version of the plugin and have pasted the log below - any ideas? Is it just an incompatibility with my sound card maybe?

The "Warning: underflow" just repeats over and over until I pause or stop the playback. I've fiddled around with buffer settings a bit to see if that made any difference, but it hasn't.

I'm playing back via the "Speakers (ASUS Xonar DX Audio Device)" device.

code:
init
critical section created
waitable timer created
device enumerator created
device collection created
got number of audio devices: 3
device 1:
got item from device collection
id: "{0.0.0.00000000}.{439698c0-d913-4048-9df0-c7fa7d3d9018}"
got interface to property store
PKEY_Device_FriendlyName: "S/PDIF Pass-through Device (ASUS Xonar DX Audio Device)"
device 2:
got item from device collection
id: "{0.0.0.00000000}.{9d072249-200d-4721-9f44-c37a21f04bd3}"
got interface to property store
PKEY_Device_FriendlyName: "Speakers (ASUS Xonar DX Audio Device)"
device 3:
got item from device collection
id: "{0.0.0.00000000}.{f75950a2-3db1-461a-8173-c96056e800dd}"
got interface to property store
PKEY_Device_FriendlyName: "Realtek Digital Output (Realtek High Definition Audio)"
architecture: 0
options: "C:\Users\<profile>\AppData\Roaming\Winamp\Plugins\out_yasapid.ini"
mode: EXCLUSIVE
startegy: push
ring size: 8.0
ring filled: 8.0
shared size: 8.0
init successful
setvolume
volume: 1.00
open
bufferlenms: -1
video: 0
initializing for push mode
audio client activated
got device period (device period: 30000)
device period scaled by 8.00 (device period: 240000)
setting device period to 240000
audio client initialized (mode: EXCLUSIVE, channels: 2, rate: 44100, bps: 24)
got buffer size (frames: 3528)
got render audio client
sync created
ring buffer created (scale 8.5, size: 169344)
got audio clock
render audio thread created
open successful
setvolume
start playing
Warning: underflow
Warning: underflow
Warning: underflow
Warning: underflow
Warning: underflow
Warning: underflow
[...]
Warning: underflow
Warning: underflow
pause
Warning: underflow
close
stop playing
player shut down
render audio thread destroyed
render audio clock destroyed
ring buffer destroyed
sync destroyed
render audio client destroyed
audio client destroyed
close successful

returnofthem is offline