View Single Post
Old 31st March 2015, 22:28   #1
twbrown
Junior Member
 
Join Date: Mar 2015
Posts: 2
Question Help with elevated installer

I have been using v2.42.4-Unicode but wanted to try upgrading to v3 to avoid the extra work I've been having to regarding the manifest and working correctly with UAC.

I'm trying v3.0a2

I'm trying to build an installer that will require Admin elevation (it accesses HKLM and installs to "Program Files (x86)".

I've set RequestExecutionLevel to "admin"

I've set ManifestSupportedOS to "all"

If I run the installer a command shell, either running in Admin mode or not, I get the error:

The current user is not allowed to install or update applications.

From a non-Admin shell, I get the UAC prompt asking if it's OK to proceed. From an Admin shell, the UAC prompt is not displayed.

I tried all variations of RequestExecutionLevel, including "user" and get the same error.

I am an Admin on my own machine. I have my system setup with:
ConsentPromptBehaviorAdmin = 2
ConsentPromptBehaviorUser = 1
EnableLUA = 1

I've written a dirt simple NSIS installer that does effectively nothing and it works correctly using v3.0a2 so there is something specific that my .nsi script is doing to cause this problem, but I'm at a loss as to what to look for. Are there other attributes I'm missing?
twbrown is offline   Reply With Quote