View Single Post
Old 7th March 2020, 02:45   #4
Anders
Moderator
 
Anders's Avatar
 
Join Date: Jun 2002
Location: ${NSISDIR}
Posts: 5,321
You can't use "RequestExecutionLevel admin" if you want non-admins to be able to install, use highest or user.

You should not mix HKCU with HKLM & $PROGRAMFILES.

And your version check is strange. Non-admin programs should work on 2000 & XP. And even if not, you forgot about 2003. Your check should be for AtLeastVista if you are thinking about UAC.

IntOp $PostCount $PostCount + 1
Anders is offline   Reply With Quote