View Single Post
Old 12th January 2012, 10:55   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by jerboa-dumont View Post
When i open the DNAS, it is not the same, it askes to chose 0 1 2 3 or 4.
Whatever i chose, it close down the DNAS. No data is sending.
I lost my time all the night to try to uninstall this, open ports of router etc... réinstall. It changes nothing.
no config file is being passed which is a requirement of using the current build of the DNAS (either by specifying it on the command-line or by drag+dropping the file onto sc_serv.exe). this is all covered in the documentation -> http://wiki.winamp.com/wiki/SHOUTcas...in_the_Console

Quote:
Originally Posted by jerboa-dumont View Post
Why this DNAS is more complicated than the other one ?
Quote:
Originally Posted by jerboa-dumont View Post
It is complicated for me. I'm dumb and i'm not a programmer.
it only seems more complicated as we've naively assumed the level of computer skills which people trying to use the DNAS have and is something that will be improved with the next release (no eta) as manually specifying the config file seems to be alien to most Windows users (as we tried to make the DNAS more consistent in behaviour over all OS versions).

Quote:
Originally Posted by jerboa-dumont View Post
The 8000 to 8010 is open in TCP for the radio.
only port 8000 (or what has been set for portbase) and if you want to allow remote (non-network) v1 based source connections then port 8001 (or portbase+1) needs to be open. opening the additional 8002-8010 ports is not needed.

Quote:
Originally Posted by jerboa-dumont View Post
I get this:
Quote:
2012-01-12 00:48:10 I msg:[MAIN] Logger updating log file to use
2012-01-12 00:48:10 I msg:[MAIN] Loaded config from my_sc_serv.conf
2012-01-12 00:48:10 I msg:[MAIN] Calculated CPU count is 2
2012-01-12 00:48:10 I msg:[MAIN] Starting 2 network threads
2012-01-12 00:48:10 I msg:[MICROSERVER] Listening for connection on port 8000
2012-01-12 00:48:10 E msg:Error opening port 8000 because Could not bind to :8000 because Address already in use.
2012-01-12 00:48:10 I msg:[MAIN] Runner shutdown
2012-01-12 00:48:10 I msg:<***> Logger shutdown
the log clearly shows why it is not able to run as something is already running on port 8000 e.g. could be another DNAS instance or some other program. if not, change portbase to something else in the config file and then edit the port forwarding rules as applicable.

-daz
DrO is offline   Reply With Quote