View Single Post
Old 23rd April 2011, 12:38   #7
2072
Junior Member
 
Join Date: Apr 2011
Posts: 6
corrupted podcasts.dat and pocasts.idx

It happened again this morning

Here are the damaged pod-casts 'databases' (if it's what they are)

http://www.j2072.teaser-hosting.com/...dcasts-idx.zip

and feeds.xml + rss.xml:
http://www.j2072.teaser-hosting.com/...ml_rss-xml.zip

I had to put back those (podcasts.dat and podcasts.idx) of yesterday morning, the file in place were dated from yesterday 8p.m. so they got damaged after downloading podcasts, the problem appears when Winamp wants to update.
(If I block Winamp from accessing the network, the 50% CPU bug doesn't happen until I let it access to the network again).

@Batter Pudding: I've just tried to replace feeds.xml and rss.xml by an older backup but the podcasts.idx and .dat still gets corrupted once all podcasts have been re-downloaded.
Today I've tried with different backups up to the day before yesterday but once winamp re-re-re-downloaded the files already on the disk the podcasts.dat and podcasts.idx were corrupted and Winamp was using 50% of CPU doing nothing...

The only way to fix this was to set all already downloaded files to read-only so Winamp couln't re-download them again (This is another bug in my opinion: failing to detect the file was already downloaded...)

I do not use the default windows7 download folder and index is disabled on the target disk.

I think that the problem lies in the podcast plugin which fails to write to its database in certain conditions... I didn't have this problem before and it's been several years now, my system did not change, I'm still using Comodo as security software.
The only thing that changed is the size of the podcasts' database...

Next time I will trace what happens to those podcats db usin process monitor.
I've already noticed that Comodo is also accessing to the podcast db (probably because Winamp is accessing it). Maybe it's a race condition that Winamp fails to handle (ie: a write fails because the file is opened by comodo but Winamp doesn't test if the write succeeded and thus corrupt its own files...).

I found this: http://stackoverflow.com/questions/3...te-to-complete Maybe Winamp suffers from the same issue.
2072 is offline   Reply With Quote