View Single Post
Old 20th January 2010, 14:34   #131
ChocJunkie
Senior Member
 
Join Date: Oct 2009
Location: Germany
Posts: 120
Exclamation NSISArray and "0xC0000005 - access violation" error

Hi,

I'm using the NSISArray plugin for quite some time now. Until today it worked perfectly for me.
Today, I've added another array to my installer. Now I get the system error '0xc0000005' (access violation of the memory) after I did differnt actions on my different arrays.

I've got absolutely no hint whats the problem - beside its a memory error. I've tried several differnt combinations of active (-> initialized and not deleted) arrays and sizes of the arrays.

I did several test to get a hint.

Test (#1):
I've got 8 active arrays. When I'm trying to init the 9th one, the initialization fails. After that I trie to delete all initialized arrays befor the installer ends. The first three deletion commands succeed. Deleting the fourth array fails and I get the '0xc0000005' exception.

Test #2:
I'm using only 8 active arrays. Everything works fine until I want to delete the arrays when the installer finishes. Like at test #1, the first three deleting commands succed - yes, that are the same as in #1. The fourth deletion command fails. Result: The same error for the SAME! memory address.

Test #3:
It's the same installer as in #2.
I cancel the installation process early when I've got only 2 initialized arrays. Everything works fine.

I'm kind of helpless about determing and solving the problem.
Any ideas what the reason could be or what I can text explicitly?

Thanks!

CJ

[moderator - 2 post thread merged into plug-in discussion)
ChocJunkie is offline   Reply With Quote