View Single Post
Old 31st August 2013, 10:57   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
so you're not using Winamp for broadcasting and just for playback / passing on to the FM broadcast?? as your first post implied you're using Winamp as the source and not SAM Broadcaster as now mentioned.

setting Winamp to realtime is not going to help if the most likely point of the buffering is the source -> DNAS aspect so i'd drop it back to it's default value than leaving it on that (and wouldn't be surprised if that's causing issues as it'll take time from the DNAS and other aspects of the system).

and something sitting at 25% implies a maxed out CPU core on a quad-core CPU... so there potentially is an issue with resources which would also be able to cause buffering.


the only real option is to try a v2 DNAS using buffertype=1 and adaptivebuffersize=5 in the configuration file and see how that goes. as the v1 DNAS has fixed buffer sizes and from what i've been testing internally, the adaptive option is generally better in cases which come close to what you seem to be experiencing (though no guarantees).

it's not clear if you're allowing the DNAS to be accessible, so you may need to set publicserver=never in the config file as well (if it's meant to be publically listed then http://wiki.winamp.com/wiki/SHOUTcas...ash_Management would need to be followed otherwise even the localhost connection will not be able to connect).

you can replace the sc_serv.exe (though probably best to keep a copy of the old DNAS file just incase of issues) and will need to run sc_serv.exe sc_serv.ini (can just put that in a text file and name it start.bat to run it) as the current build of the v2 DNAS which you can get won't auto-load config files like the v1 DNAS did.
DrO is offline   Reply With Quote