View Single Post
Old 7th September 2013, 04:50   #3
ryerman
Major Dude
 
ryerman's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 672
Quote:
Originally Posted by MrSinatra View Post
.......now, some of the flacs are weird, b/c they were made from weird wavs years ago, in the sense that the sample rates, bit rates, etc are odd, low, whatever. but nevertheless they play just fine.......
They play in Winamp, but there might be something funky with them besides unusual bit rates and sample rates.
All except "greetings.flac" and "fine.flac" crash VLC.
All except "greetings.flac" are silent in Audacity.
"greetings.flac" is played only partially in VLC.

After re-encoding with ffmpeg, all those problems disappear.

But does that have anything to do with what you observe when playing the .m4a files?
I can't answer.

I see the weird bit rates of your.mp4 files. Mp3tag shows different bit rates, compared with the .flac files, but not even close to what Winamp shows.

I didn't notice any glaring difference in sound quality at first but while I was doing some testing, all kinds of weird shit happened when playing those short .m4a files.
Extreme static, an unchanging bit rate shown as each file was played, and then sometimes normal playback again, without any obvious pattern.
Maybe that's a result of the "rough" ALAC handling you describe.

Transcoding these "corrected" .flac files to .m4a, again with ffmpeg, did not change their behaviour in Winamp.

So I guess the next step will be to find or create some pristine, short .m4a files and play around with them in Winamp.
I think it's best to remove the possibility that the original .flac files are the origen of any problems.

Just in case it matters, the decoder used is Nullsoft MP4 Demuxer v2.62 (in_mp4.dll)

And just to be clear;
"After very careful consideration sir, I've come to the conclusion that yer new defence system sucks."

Windows 10 Home, 64 bit, Winamp 5.666, Bento Skin
ryerman is offline   Reply With Quote