View Single Post
Old 30th October 2015, 20:58   #94
chros
Member
 
chros's Avatar
 
Join Date: Nov 2003
Posts: 77
Hi Peter!

Thanks for the new versions, the plugin gets better and better! Shared mode is working fine for me as well (previously it wasn't). I could listen to music in shared mode when doing a skype call in the meantime
However I found couple of bugs and I have 2 new feature request as well.

I. Bugs in v7.1-v8.1 (detailed bug report is here: http://pastebin.com/c2TW1E4z ) :
- 1. Exclusive + Pull crashes Winamp (normal and sse version):
- 2. audio clipping/distorsion when playing 48KHz aac 2/6 channel file (normal and sse version)

II. Feature requests (probably the first isn't a big deal):

1. add "System Default" device at the top of the list under Devices tab (as you can see in MPC-HC nightly https://nightly.mpc-hc.org/ )
Reason behind this:
- my setup: laptop -> hdmi -> AVReceiver -> hdmi -> TV
- all the other audio devices are disabled or removed in the Sound preferences in Windows, only this HDMI audio is enabled
- when avreceiver is On/Standby AND tv is Off Windows sees the avreceiver as "RX-A830" audio device (and not just audio device, as it turned out, but as a display as well!!! but it's a different story)
- when avreceiver is On/Standby AND tv is On Windows sees the tv as "LG" audio device! That means yasapi crashes winamp since the set audio device can't be found.
- this is working like this with HDMI audio (devices vanishes and reappears all the time)
- only solution is adding a System Default device at the top of the list: in this way yasapi always use the system default and Windows is selecting the appropriate audio device.

2. add an option for channel matrixing in shared mode (as in Maiko's plugin)
- if it's set then it would use the default speaker setup in Sound preferences in Windows
- e.g. I could select Quadraphonic to mirror the 2 channel fronts to the back (right now I'm using the 7ch sound of my avreceiver , but it uses the center channel as well that I don't like at all)
- this is the only feature that I miss from your plugin (and I can't use Maiko since it's crashes Winamp all the time)


Thank you for your work!
(OS: Windows 8.1 64 bit, HDMI Intel Display Audio driver: 6.16.0.3154)
chros is offline