View Single Post
Old 30th November 2013, 07:39   #128
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Quote:
Originally Posted by Aminifu View Post
As to the 2nd issue, I also see that the 2nd illegal filename is not removed from the list of playlists after a command to delete until Winamp is restarted, but the filenames in the 2nd list are deleted before the restart. The filename of the playlist should have been removed, but at least the filenames in the list were. It is probably to late for this cosmetic error, imo, to be fixed.
Hi Dro Chilla,

Short Version:
Upon further examination this is not a cosmetic bug. On my system attempting to delete the last remaining 'illegal' playlist name appears to do nothing, but it really causes the playlist at the top of the library listing to be deleted. If I keep trying to delete the 'illegal' name, I'm actually deleting other playlists (from the top down)!

I have a long list of playlists and the top of the listing was not visible, so I didn't notice this until today. Luckily the deleted playlists were put in the Recycle Bin, so I was able to retrieve them without having to use my backup files.

Thank you for reporting this bug! I now know not to keep trying if I delete something with Winamp and it appears to not have been deleted.

More Info:
I've always made separate playlists and then imported them to the media library. This is why my playlist names do not have 'illegal' characters in them. Anyway, until the last few Winamp versions, importing only made media library copies of the source lists. So if I deleted the media library copy, I still had the source list. The recently added feature allows linking to the source lists instead of copying them. Since Winamp does not automatically keep the library copy in sync with the source, linking removes the need for making new copies when the source list is changed. The downside of linking is that deleting the list in the library also deletes the source.

A few weeks ago, I deleted all my media library playlist copies and re-imported my playlists using this linking feature. When testing for the bug you reported, I used the "Send to:" context menu command to create media library playlists (with 'illegal' characters in their names) from an active list in the playlist editor. These playlist copies where added to the library listing of my linked to playlists, so the playlists that were inadvertently deleted were my source lists.

Bottom line, I don't know it this bug you discovered is related to the new linking feature or not. With the noble attempt to add so many fixes and improvements to the last AOL supported Winamp version (and the relatively short time for testing), some unintended consequences have occurred. Going forward we need to careful and maintain current backups of anything that could otherwise be irretrievably lost.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote