View Single Post
Old 14th April 2010, 13:11   #122
zord_majka
Junior Member
 
Join Date: Apr 2010
Posts: 3
Winamp 5.572 (build 2830)
Clean install, no 3rd-party skins or plugins
Language Pack: None (default English US)
Skin: Bug occurs with all of Bento, Winamp Modern and Classic skins

OS: Windows 7 Professional 64
Locale: Czech
CPU: Intel(R) Core(TM)2 Duo CPU P7350 @ 2.00GHz
Memory: 4,00 GB
Graphics: NVIDIA GeForce 9200M GS
Sound: on board Realtek card
DirectX 10

Problem:
Media Library can't read properly album year information from the metadata. This occurs if you edit tags (for example adding picture in the tag) in MediaMonkey. However, all other players/metadata editors i tried (Windows Media Player, Media Player Classic, VLC, MediaTagger, MediaMonkey, windows explorer and even built-in media player on Nokia 5800) had no problem reading from the metadata. I also tried older versions of Winamp, but with same result.

In my case Winamp Media Library seems to read year data only from ID3v1 (and correctly) and ignores the year field from ID3v2 (leaves it empty), so the year field in basic overview is empty. This basically means album year information is nowhere shown.

I guess there wouldn't be this problem if the basic overview would complete the data from both ID3v1 and ID3v2 tags.

Method of Reproduction:
1. edit metadata in MediaMonkey
2. add edited mp3s into Winamp Media Library
3. see it's without year
4. view File info (Alt+3)
5. basic overview lacks the year data
6. ID3v1 contains the year data, ID3v2 doesn't (even these data are physicaly in the tag)
zord_majka is offline