View Single Post
Old 19th April 2015, 00:12   #1
iburnthings
Junior Member
 
Join Date: Apr 2015
Posts: 2
Start everything on system startup (not login)

I've searched through these forums quite a bit and have either not found or not understood the solutions presented.

I'm running a christmas themed website for my family and I have a wordpress plugin that is streaming the music to the site.

I've been able to get the stream to restart on login using a batch file that just runs the playlist from the startup folder. Then winamp starts, plays the list, and the DSP plugin auto connects to port 8007.

I'm trying to get the audio stream going again any time the server machine reboots WITHOUT logging in. I've setup a windows task and it works when I run it manually but not when the computer restarts.

I assume I don't have sc_trans because I can't find it anywhere so I don't think I need it but I may be wrong.

I have winamp v5.666 Build 3516 (x86) - Dec 12 2013
SHOUTcast Source DSP v2.3.5

Here are the edited contents of my conf file

adminpassword=deleted
password=deleted
portbase=8007
requirestreamconfigs=1
streamadminpassword_1=deleted
streamauthhash_1=deleted
streamid_1=1
streampassword_1=deleted
streampath_1=/christmas.m3u

Here is the windows task exported as an XML file.

<?xml version="1.0" encoding="UTF-16"?>

-<Task xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task" version="1.2">


-<RegistrationInfo>

<Date>2015-04-08T13:12:34.1561507</Date>

<Author>IREMOVE\THIS</Author>

</RegistrationInfo>


-<Triggers>


-<BootTrigger>


-<Repetition>

<Interval>PT15M</Interval>

<StopAtDurationEnd>false</StopAtDurationEnd>

</Repetition>

<Enabled>true</Enabled>

</BootTrigger>

</Triggers>


-<Principals>


-<Principal id="Author">

<UserId>IREMOVED\THIS</UserId>

<LogonType>Password</LogonType>

<RunLevel>HighestAvailable</RunLevel>

</Principal>

</Principals>


-<Settings>

<MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>

<DisallowStartIfOnBatteries>false</DisallowStartIfOnBatteries>

<StopIfGoingOnBatteries>false</StopIfGoingOnBatteries>

<AllowHardTerminate>true</AllowHardTerminate>

<StartWhenAvailable>false</StartWhenAvailable>

<RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>


-<IdleSettings>

<StopOnIdleEnd>true</StopOnIdleEnd>

<RestartOnIdle>false</RestartOnIdle>

</IdleSettings>

<AllowStartOnDemand>true</AllowStartOnDemand>

<Enabled>true</Enabled>

<Hidden>false</Hidden>

<RunOnlyIfIdle>false</RunOnlyIfIdle>

<WakeToRun>false</WakeToRun>

<ExecutionTimeLimit>PT0S</ExecutionTimeLimit>

<Priority>7</Priority>

</Settings>


-<Actions Context="Author">


-<Exec>

<Command>E:\SHOUTcast\sc_serv.exe</Command>

<Arguments>sc_serv.conf</Arguments>

</Exec>


-<Exec>

<Command>E:\Winamp\winamp.exe</Command>

<Arguments>C:\christmas.m3u</Arguments>

</Exec>

</Actions>

</Task>
iburnthings is offline   Reply With Quote