View Single Post
Old 21st October 2016, 08:37   #1
Quinto Black CT Developer
Join Date: Sep 2016
Posts: 580
Milkdrop doesn't work on Win10 (1607)


during the installation routine of our beloved program an error message pops up saying that DirectX9 (?!) components are missing. The installation is finished properly but as soon as I hit CTRL+K (to start MilkDrop) I again see an error message complaining about missing d3dx9_31.dll file.

All this happened on a clean Windows 10 (1607) installation with its newest drivers from Intel, Creative and nVidia.

Searching the forum for a plausible solution of that problem led me to a thread, in which one of the developer claims to have broken the Plug-In in order to get another problem solved. The post is dated from Nov 2011.

Some user claim to have no problems whatsoever on Windows 10 machines so I would not know spontaneously if the Plug-In is still broken or the fresh Windows 10 installation indeed is missing a file. (what I really doubt)

I also copied and pasted those missing files from DirectX 9.0c (XP) and downloaded an old MilkDop version (1.9) which was not recognized by Winamp. None of these helped.

Do any of you know a workaround to get Milddrop worked?

Last edited by PeterK.; 21st October 2016 at 11:13.
PeterK. is offline   Reply With Quote