View Single Post
Old 24th February 2011, 15:47   #10
MADxHAWK
Senior Member
 
Join Date: Jan 2010
Posts: 181
Hi DrO,

first of all, thanks for the new release

I just installed the new build 18 of DNAS, but im sorry, ther's still no titleupdate on the DNAS statuspage and in winamp when im straming with SAM 4
The statuspage doesnt show anything and winamp only show something like
http://213.239.***.***:8000/stream/1

With shoutcastsourcedebug=1 the logfile only shows the folowing entries:
Quote:
2011-02-24 17:11:02 I msg:[SRC 78.34.***.***:57173 sid=1] SHOUTcast source connection.
2011-02-24 17:11:02 D msg:[SRC 78.34.***.***:57173 sid=1] icy header [content-type:audio/mpeg]
2011-02-24 17:11:02 D msg:[SRC 78.34.***.***:57173 sid=1] icy header [icy-aim:NA]
2011-02-24 17:11:02 D msg:[SRC 78.34.***.***:57173 sid=1] icy header [icy-br:192]
2011-02-24 17:11:02 D msg:[SRC 78.34.***.***:57173 sid=1] icy header [icy-genre:Various]
2011-02-24 17:11:02 D msg:[SRC 78.34.***.***:57173 sid=1] icy header [icy-icq:NA]
2011-02-24 17:11:02 D msg:[SRC 78.34.***.***:57173 sid=1] icy header [icy-irc:#********]
2011-02-24 17:11:02 D msg:[SRC 78.34.***.***:57173 sid=1] icy header [icy-name:*******]
2011-02-24 17:11:02 D msg:[SRC 78.34.***.***:57173 sid=1] icy header [icy-pub:0]
2011-02-24 17:11:02 D msg:[SRC 78.34.***.***:57173 sid=1] icy header [icy-url:http://www.*****.de]
But there are no metatag updates, even if a new title is played.

Im using the same config like on build 14 where everything works fine with SAM.

Config:
Quote:
log=1
shoutcastsourcedebug=1
screenlog=0
logfile=/home/stream/shoutcast/logs/dsl.log
w3clog=/home/stream/shoutcast/logs/dsl_w3c.log

banfile=/home/stream/shoutcast/control/sc_serv.ban
ripfile=/home/stream/shoutcast/control/sc_serv.rip
saveriplistonexit=1

maxuser=500
listenertime=0
autodumpusers=1

portbase=8000

;streamid=1
;streampath_1=/dsl

password=*****
adminpassword=*****
publicserver=never

yp2=0
Also i still got those mysterious source connections comming from my own server-ip
Quote:
2011-02-24 17:32:06 I msg:[SRC 213.239.***.***:37051 sid=1] SHOUTcast source connection.
2011-02-24 17:32:06 E msg:[SRC 213.239.***.***:37051 sid=1] connection denied. Bad password.
2011-02-24 17:32:14 I msg:[SRC 213.239.***.***:37052 sid=1] SHOUTcast source connection.
2011-02-24 17:32:14 E msg:[SRC 213.239.***.***:37052 sid=1] connection denied. Bad password.
2011-02-24 17:32:33 I msg:[SRC 213.239.***.***:37053 sid=1] SHOUTcast source connection.
2011-02-24 17:32:33 E msg:[SRC 213.239.***.***:37053 sid=1] connection denied. Bad password.
I have started 3 instance of sc_serv with 3 different config files that are identicaly, only the portbase is different.

1. 192kbps DSL-stream Port 8000
2. 32kbps Modem-stream port 8010
3. Teststream Port 8050

There is no instance of sc_trans or streamtranscoder or anything else running, that might connect to DNAS as source.
What i mentioned is that these connectiontries only appear on the first instance running on Port 8000.
The other 2 instance on port 8010 and 8050 doesnt showing up those lines in their logfiles.


System: Debian Lenny 2.6.26-2-amd64 64bit
DNAS: Version 0.2.0.0 0.0.18.0/posix(linux x64)




Greetings
Martin
MADxHAWK is offline