View Single Post
Old 9th May 2013, 14:02   #27
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
Quote:
Originally Posted by Aminifu View Post
Not trying to be clever, just an observation. Are you saying that Winamp's particular SOP is a worthy universal truth or all SOPs are?
all i'm saying is that winamp recognizes the worthiness of employing a sensible SOP for bug reporting. they do so b/c that method is effective. that effectiveness is a universal truth.

Quote:
Originally Posted by Aminifu View Post
Since post #11 we have been discussing the pros and cons of using Winamp's troubleshooting SOP in this case and related points (at least that's what I thought). Back in January, I stated what I was seeing (in post #20 restated a real short version), I did not follow the SOP (nobody objected). I have not presented conclusions on what the problem of this thread is or is not.
I didn't object b/c I wasn't testing it. but now I am. so there u r.

and you have drawn all sorts of conclusions saying this or that. they may be true, but I see no proof they are. its interesting to me that the latest build, and the next build, have some kinds of changes in them provided by DrO. that's a great thing, for both id3 and FLAC. hopefully he will let us behind the curtain and say what he changed so we can further our understanding of winamp.

Quote:
Originally Posted by Aminifu View Post
And you brought up the m4a issue in jph6t's thread (with your link), not me.
I know, I did not say otherwise. I did say you brought up your v1 issue in his FLAC issue, and you did. in either case, I see no harm, it can be instructive to point to related things.

Quote:
Originally Posted by Aminifu View Post
Anyway, the latest beta build 3381 partly fixes this thread's stated problem. The part that was causing me extra work is fixed.


Quote:
Originally Posted by Aminifu View Post
The Alt+3 ID3v1 tab still shows the last genre value used instead of the value in the file, but unless the genre tag is also changed when 1 or more of the other tags are changed, the genre tag value in the file is no longer changed to the value that is being displayed.

So now it is just a visual discrepancy between what is in the file and what is being shown. I can live with that, since what is shown for genre on the basic info and the v2 tabs is what is actually in the v1 genre tag.
...unless of course, what is in the v2 tag is not part of the finite, default, v1 list.

my guess all along has been that the alt+3 window needed to parse fresh the file in question on invocation, be it mp3 or flac, and I said so earlier in this thread. its very similar to a ratings issue where the rating did not show even when in the file, if it wasn't in the ML. parsing the file on playback instead of going to the ML fixed it. so if I am right, same thing would apply; only "alt+3" substitutes for playback. and care would need to be taken to be sure the left/right arrows (from jtfe?) caused a parsing as well, when alt+3 is invoked via double-clicking the playback scroller.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline