View Single Post
Old 2nd March 2011, 21:34   #61
mishagale
Junior Member
 
Join Date: Jul 2001
Posts: 5
Format Converter: Error when attempting to convert mono MP3 to Stereo AAC

Hello,
I've been experiencing an odd bug when using the format converter to convert large numbers of files (my whole library) to AAC, and I think I've now tracked down the cause.

Steps to reproduce: (tested in Winamp v5.6.01)
1. Select a *mono* audio file (tested with MP3s, may apply to other formats)
2. Right click, "Send to":, "Format Converter"
3. Set encoding format to any AAC, e.g. aacPlus, MP4/LC-AAC (tested with v1.31)
4. Set channel mode to stereo
5. Click OK
Results in a pop-up error, titled "Transcoding fail...", error text "Cannot open encoder." If at step 4 you set channel mode to mono, it encodes normally.

I performed a clean install by installing to an alternate folder, but without uninstalling my normal winamp installation. Hope this suffices, if not let me know and I'll try to reproduce it with a really clean install. Install options were "Full" minus the Winamp Agent and with no file associations, shell extensions or online services selected.

My computer specs:
Windows 7 Pro x64, no service pack installed but otherwise up-to-date
Locale: UK
AMD Athlon X2 6000+ (3ghz dual-core)
Asus M2N32-SLI motherboard
6GB RAM
NVidia GeForce 9800 GT
Analogue Deviced SoundMax Integrated Digital HD (on-motherboard sound chip)

I've run into this while trying to transcode a large number of files, most files work fine, but I seem to hit errors with mono files. I can't find any way in the media library to search for mono/stereo files so I can encode them separately, if anyone knows of such a way it would be a big help.
mishagale is offline