View Single Post
Old 29th October 2015, 18:31   #87
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by djnforce9 View Post
I now only see the error when playing files with odd sampling rates. For example, 32Khz files won't play in exclusive mode such as this one:
https://www.dropbox.com/s/tu4bjvqh6z...on%29.mp3?dl=0
For now I don't see any means to make this happen. To my understanding exclusive mode is exclusive mode, i.e. the audio is not touched. Even if you uncheck "Auto Convert PCM", a sample rate different from the system setting will not play in shared mode.

Your observation from yesterday gave me the impression that a call to IAudioClient::IsFormatSupported() don't give the result I'm expecting. So I simply dropped it and let IAudioClient::Initialize() decide whether it can deal with a certain format or not.

Quote:
Originally Posted by djnforce9 View Post
I also use an input plugin called "64th Note" which plays the Nintendo 64 music format usf/miniusf. Those also have a sampling rate of 32Khz and won't play in exclusive mode. Even MAIKO's plugin struggles with some of these such as the "Banjo Kazooie" soundtrack.
For those files you should use shared mode.
pbelkner is offline   Reply With Quote