Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 15th July 2014, 10:17   #1
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Winamp crashing lately only when playing Shoutcast streams.

I've been listening to Shoutcast stations a lot more lately and after some amount of time, Winamp will crash:

Log Name: Application
Source: Application Error
Date: 7/15/2014 3:57:21 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Description:
Faulting application name: winamp.exe, version: 5.6.6.3516, time stamp: 0x52aa753e
Faulting module name: gen_crasher.dll, version: 1.12.0.0, time stamp: 0x52aa755d
Exception code: 0xc0000005
Fault offset: 0x0000267d
Faulting process id: 0x193c
Faulting application start time: 0x01cf9ff0934cc9b4
Faulting application path: C:\Program Files (x86)\Winamp\winamp.exe
Faulting module path: C:\Program Files (x86)\Winamp\Plugins\gen_crasher.dll
Report Id: 07826aaf-0bfe-11e4-8a8e-8c89a5bf3e81


I can listen for an hour or more so it's not an immediate thing and it doesn't seem to matter the station. Last one was: http://www.977music.com/977hi.pls

Playing local music.. never seen it crash.

Here's my Winamp info: http://www.markheadrick.com/winamp-info.shtml

Not that big a deal but if there's something I can check I will. More of a FYI thing and to see if anyone else has been experiencing it?
MarkRH is offline   Reply With Quote
Old 15th July 2014, 10:24   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
you've not provided the crash report.
DrO is offline   Reply With Quote
Old 15th July 2014, 10:36   #3
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Well, I would, but, looks like the newest one is dated April 3, 2014 (report.zip in C:\Users\(my username)\AppData\Roaming\Winamp\Plugins ). Maybe it crashed while trying to create the report. Everything still seems enabled in the Error Feedback options. Hrmm...

Oh well..
MarkRH is offline   Reply With Quote
Old 15th July 2014, 10:57   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
you could always try the procdump method instead of the native reporter- > http://forums.winamp.com/showthread....mp#post2945094
DrO is offline   Reply With Quote
Old 16th July 2014, 12:25   #5
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
FYI, I've been playing the same stream for 190 minutes without issue while doing all kinds of other stuff. So... who knows. Been playing the one I linked to above.
MarkRH is offline   Reply With Quote
Old 16th July 2014, 12:50   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
without a crash dump its hard to say. I know I fixed a very odd quirk with steam handling a few months back due to a few internal values not being initialised correctly which could cause an odd stream crash. so maybe that's what is going on (as it depended on the value of the memory allocated as to whether it'd crash or not). that's the best I can think off especially if its generally working ok most of the time.
DrO is offline   Reply With Quote
Old 18th July 2014, 08:49   #7
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Well, it crashed again playing a stream (over an hour into it). No reports generated again but I think I know why. For some reason it was set to send data using the default email program (which never did launch if it was supposed to).

Anyway, does this configuration look like it should work:



Guess I can try that proc method that was linked to.

LOL, must have saved that PNG file with transparency color enabled. Forgot I saved the last PNG with that option selected. Anyway.. good enough.
MarkRH is offline   Reply With Quote
Old 18th July 2014, 11:04   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
the attempt to send happens after trying to generate the report so if a report isn't being made then that setting isn't going to have any effect. is why procdump in general is better as it's external of Winamp and so can often catch things which the internal version cannot due to some of the crashes badly mangling things.
DrO is offline   Reply With Quote
Old 18th July 2014, 21:24   #9
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Well.. been going 72 minutes so far with procdump monitoring it. Wait and see. Probably should make a batch file and just start Winamp all the time that way so if and when it happens again, procdump will catch it.
MarkRH is offline   Reply With Quote
Old 18th July 2014, 21:53   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by MarkRH View Post
Probably should make a batch file and just start Winamp all the time that way so if and when it happens again, procdump will catch it.
yup
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump