Old 13th November 2014, 22:46   #1
RichyCapy
Junior Member
 
Join Date: Sep 2014
Posts: 8
Multiple streams on a server mixing among them

Hi

I have 9 streams on my server using SHOUTcast Server v2.4.0.147, but sometimes they start mixing the audio among them...

Example...

Stream 4 begins hearing on Stream 1

What could be causing this?
RichyCapy is offline   Reply With Quote
Old 13th November 2014, 22:50   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
From the 2.4.1 changelog (which is a version behind the current release at the time of this reply - did the new version notice not appear on the DNAS pages for you ?):
Quote:
Fixed handling of custom streampaths with parameters (starting with /; or ; ) always providing stream #1 (using /stream/x/ did not experience this issue)
that is the best i can assume is the issue you are seeing without knowing exactly what urls the clients are connecting to and if you're using custom streampath / mountpoint, etc.

and i've moved your post to the correct part of the forum (the Winamp Tech Support sub-forum was not the correct place).
DrO is offline   Reply With Quote
Old 14th November 2014, 16:23   #3
RichyCapy
Junior Member
 
Join Date: Sep 2014
Posts: 8
I dont think this is the problem

All streams are configure correctly, but after a few hours, the stream 5 starts to mix itself with the stream 1.

I have to do a Forced Reload Stream Configuration in order for the streams stop mixing

The ShoutCast server was installed for me since the files were getting corrupted when I upload them via FTP, can you tell me the best way to upload the files so I can update my ShoutCast? probably via WGET or something
RichyCapy is offline   Reply With Quote
Old 14th November 2014, 21:29   #4
RichyCapy
Junior Member
 
Join Date: Sep 2014
Posts: 8
Ok, I just updated the Shoutcast to the latest version... hope this helps
RichyCapy is offline   Reply With Quote
Old 14th November 2014, 22:21   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
sorry i should have recognised the username. yes a wget is the best approach for the issue seen with your install.

though there's nothing in the code that would allow for the actual stream data to mixed so there must be either a dropping of the streams (as the only stream remaining would then be used) or it's a weird memory corruption issue we've never seen before.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
mixing, stream

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump