Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 27th September 2011, 17:33   #1
Dead-i
Junior Member
 
Join Date: Sep 2011
Posts: 2
Setting up SHOUTcast for the first time: HTTP/1.1 404 Not Found

Hello,

Recently I have attempted to setup my own SHOUTcast server on my new Virtual Private Server, and I believe I have set it up correctly; however clients are unable to listen to my stream.

When the client goes to :8080 (the port I set in sc_serv_basic.conf) in my browser, my stream appears in the list and the client then clicks on the stream. When the client clicks the Listen button, it downloads listen.pls, which the client then opes in XAMPP. However, the track name in WinAmp then alternates between these two, with a few milliseconds in between (replacing 123.456.789 with my server IP).

Quote:
[Connecting] http://123.456.789:8080/test.aac
[HTTP/1.1 404 Not Found] http://184.154.20.199:8080/test.aac
Then at my server's end, Shoutcast outputs this (replacing **** with some random port number):

Quote:
E msg:[DST 123.456.789:**** sid=1] SHOUTcast 2 client connection rejected. Stream not available. WinampMPEG/5.62, Ultravox/2.1
I msg:[DST 123.456.789:**** sid=1] SHOUTcast 2 client connection closed (0 seconds) [Bytes: 0] Agent: 'WinampMPEG/5.62, Ultravox/2.1'
Any help appreciated; Thanks!
Dead-i is offline   Reply With Quote
Old 27th September 2011, 17:56   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
have you obtained an authhash for the stream? see http://wiki.winamp.com/wiki/SHOUTcas...ash_Management as running a v2 DNAS publically (as seems to be the case) requires an authhash for it to be able to list correctly. if you don't want the stream(s) listed in the SHOUTcast Directory then you need to change the source to indicate it is a private stream.

-daz
DrO is offline   Reply With Quote
Old 27th September 2011, 18:01   #3
p0rt
Senior Member
 
Join Date: Nov 2010
Posts: 152
you need to create a default playlist for sc_trans to load up and use, then switches to calendar playlists if the calender is being used
p0rt is offline   Reply With Quote
Old 27th September 2011, 18:05   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
p0rt: what on earth are you smoking - no where is sc_trans mentioned and if you bothered to look at the log messages provided then it is clear that client connections are being purposefully blocked - which points towards a lack of an authhash on the stream(s).

-daz
DrO is offline   Reply With Quote
Old 27th September 2011, 18:32   #5
p0rt
Senior Member
 
Join Date: Nov 2010
Posts: 152
you get the same error if a source isnt connected
p0rt is offline   Reply With Quote
Old 2nd October 2011, 14:43   #6
Dead-i
Junior Member
 
Join Date: Sep 2011
Posts: 2
Thanks, it seems to have worked
Dead-i is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
404, error, shoutcast, vps, winamp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump