Old 3rd December 2011, 00:46   #1
mihaidragoman
Junior Member
 
Join Date: Dec 2011
Posts: 1
Using listen from server web page

Hi,
After i have installed the shoutcast 2 + dsp , server is running well, but if I go on the client pc and open http://radioserver:8000 and chose listen instead of sending me a playlist with the external ip like http://radioserver:8000 it try to open the internal ip of the server like htt://192.168.1.100:8000 and of course is not working. The server is behing an router and on this router I have forward the ports (8000 -8010) to the radioserver ip addres ( 192.168.1.100) and also I have put the radioserver in DMZ.
So please tell me what I can set in the src_config_file so the clients get the correct ip address not the local ip address of the server.
Manny thanks for your support,
mihaidragoman is offline   Reply With Quote
Old 4th December 2011, 21:23   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
for some people, the /listen.pls?sid=# option isn't correctly resolving the address the client accessed to determine the address to use or something on the network setup is causing it to be changed. you could try changing 'destip' to be the IP / address you want which should work (though if that cannot be resolved / bound to then it'll prevent the DNAS from running).

i've got it logged as something to look into (have been given some complete debug enabled logs though i've failed to reproduce the issue despite trying a number of times / ways).

also you really only need port 8000 to be open (and optionally 8001 if you're accepting remote v1 source connections).

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
listen, local ip

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump