Old 4th April 2015, 03:20   #1
mattauckland
Junior Member
 
Join Date: Mar 2015
Posts: 39
Email= config value throwing a warning

Hi,

In my old 2.4.2.167 server I use the email=somename@somedomain.com value.

ut in a new server I'm launching, version 2.4.7.256 I get the following error:

Quote:
2015-04-03 23:15:46 WARN [CONFIG] Invalid item on line 19 of sc_serv.conf -> `email'
Has support for that config value been pulled, or has it changed?

Thanks.
mattauckland is offline   Reply With Quote
Old 5th April 2015, 20:25   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
it was removed as per the changelog entry a few lines from the bottom of the list -> http://yp.shoutcast.com/v/2_4_7 (as is also included with the DNAS installer / archive file).
DrO is offline   Reply With Quote
Old 5th April 2015, 22:09   #3
mattauckland
Junior Member
 
Join Date: Mar 2015
Posts: 39
Thanks for the reply DrO.

One last thing, has the fetching listener data also changed? mAirList suddenly can't fetch the listener count any more, even though all I've done is launch a new server with the latest shoutcast build on it.
mattauckland is offline   Reply With Quote
Old 5th April 2015, 22:31   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
all of the existing methods of getting information from the DNAS are still there so as long as it's using a correctly documented implementation then it should still be working.

it'd only be if it's using some undocumented / version-specific method that I can even think off causing it to stop working with the update (as there were a few loopholes for getting stats that were closed down for improved DNAS security - maybe it was using one of those).

so it might be something to report to them to determine if we've broken what they're trying to use and either report it to us directly via support @ shoutcast dot com or they'll need to update to use a supported way of doing things (as per the public and admin only methods as detailed in the docs provided with the DNAS release).
DrO is offline   Reply With Quote
Old 5th April 2015, 22:44   #5
mattauckland
Junior Member
 
Join Date: Mar 2015
Posts: 39
Thanks for the support DrO. Awesome work.

The error I got from mAirList is "livehd.sumoradio.uk:8000,1: HTTP/1.0 401 Unauthorized", so possibly not using a correct implementation I guess.

Stream isn't live currently, as the station launches late this month. I'm just in testing, and tweaking the audio processor in the studio at the moment.

I'll report these details to mAirList, and let them take it from there.

Thanks again!
mattauckland is offline   Reply With Quote
Old 5th April 2015, 22:55   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's probably not sending the password to a /admin.cgi method for getting stats (that's the normal cause of a "HTTP/1.0 401 Unauthorized" response).

as a number of the /admin.cgi stats methods have a public version with the 2.x DNAS e.g. /stats maps to the /admin.cgi?mode=viewxml&page=1 option iirc. those aren't present with the 1.x DNAS and the 2.x DNAS provides these duplicate password restricted /admin.cgi methods in-order to maintain 1.x compatibility.
DrO is offline   Reply With Quote
Old 5th April 2015, 23:00   #7
mattauckland
Junior Member
 
Join Date: Mar 2015
Posts: 39
Thanks DrO, I'll pass that on.
mattauckland is offline   Reply With Quote
Old 6th April 2015, 13:36   #8
mattauckland
Junior Member
 
Join Date: Mar 2015
Posts: 39
Hi DrO.

I've had a response from Torben, the developer of mAirList, and he asked me to pass this on:-

Quote:
mAirList uses the following URL to fetch the listener info from a Shoutcast server:

http:// host : port /admin.cgi? pass=secret & mode=viewxml &sid=1

The sid parameter is omitted for SCv1 protocol.
Is that method now no-longer supported?

Note: I broke it up with spaces to prevent the automatic URL, and smiles rewriter from kicking in.
mattauckland is offline   Reply With Quote
Old 7th April 2015, 14:08   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
that method should be working without issue as long as the password is correct for that stream.

please enable the HTTP debugging option via the server admin page (towards the bottom of the left-hand list) and send a copy of the log support @ shoutcast dot com (referencing to this thread) once mAirList has tried to access it a few times and it'll be looked into.
DrO is offline   Reply With Quote
Old 8th April 2015, 14:12   #10
mattauckland
Junior Member
 
Join Date: Mar 2015
Posts: 39
Emailed it over DrO. Thanks again!
mattauckland is offline   Reply With Quote
Old 8th April 2015, 14:35   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
ok, will look through things at some point tomorrow.
DrO is offline   Reply With Quote
Old 4th June 2015, 15:38   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
an email has now been sent with a link to a test build to try out regarding a fix for this issue.
DrO is offline   Reply With Quote
Old 7th June 2015, 23:56   #13
mattauckland
Junior Member
 
Join Date: Mar 2015
Posts: 39
Thanks for all your support DrO, and for resolving the issue in this latest build.
mattauckland is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
email, warn, warning

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump