Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 7th May 2020, 19:43   #1
ant
Senior Member
 
Join Date: Jul 2000
Location: An Ant Farm
Posts: 111
Playing *.MID/MIDI files changes my 64-bit W7 HPE SP1's volume mixer's Winamp.

Every time, my Winamp v5.666 plays an old school *.MID/MIDI file, my decade old 64-bit W7 HPE SP1's volume mixer lowers Winamp's audio volume. How can I tell it not to do that? Changing settings in Winamp's Nullsoft MIDI Player v3.55 (in_midi.dll)'s Device's Volume Control doesn't seem to help. I don't have this issue with other audio formats (MP3, OGG, XM, IT, S3M, 669, etc.).

Thank you for reading and hopefully answering soon.

--Ant @ Ant's Quality Foraged Links (http://aqfl.net) and The Ant Farm (http://antfarm.ma.cx).
ant is offline   Reply With Quote
Old 7th May 2020, 20:03   #2
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,752
That is a very old bug that has never been fixed. The default configuration for the Nullsoft MIDI Player input plug-in (in_midi.dll) can internally affect Winamp's volume level when playing other file formats after playing a midi file. There are no visible indications that the volume level was changed.

Use the information below (copied from an old post) to check your in_midi.dll configuration. Hopefully it will help.

"To change the configuration of the Nullsoft MIDI Player input plug-in use the Ctrl + P keyboard shortcut to open the Winamp Preferences window. Click on "Input" in the "Plug-ins" section on the left-hand side. On the right-hand side click on "Nullsoft MIDI Player" and then click the "Configure" button at the bottom. On the right-hand side of the "Device" tab of the Nullsoft MIDI Player Preferences window you should see the "Volume Control" options. Chose "None" in the selection box and clear the check-mark for the "Use as logarithmic" option. Click the "OK" button at the bottom to close this window and click the "Close" button (bottom left-hand side) to close the Winamp Preferences window. Restart Winamp and try playing a song."

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.1 skin
Windows 10 Home 64-bit v2004 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 7th May 2020, 20:10   #3
ant
Senior Member
 
Join Date: Jul 2000
Location: An Ant Farm
Posts: 111
Quote:
Originally Posted by Aminifu View Post
That is a very old bug that has never been fixed. The default configuration for the Nullsoft MIDI Player input plug-in (in_midi.dll) can internally affect Winamp's volume level when playing other file formats after playing a midi file. There are no visible indications that the volume level was changed.

To change the configuration of the Nullsoft MIDI Player input plug-in use the Ctrl + P keyboard shortcut to open the Winamp Preferences window. Click on "Input" in the "Plug-ins" section on the left-hand side. On the right-hand side click on "Nullsoft MIDI Player" and then click the "Configure" button at the bottom. On the right-hand side of the "Device" tab of the Nullsoft MIDI Player Preferences window you should see the "Volume Control" options. Chose "None" in the selection box and clear the check-mark for the "Use as logarithmic" option. Click the "OK" button at the bottom to close this window and click the "Close" button (bottom left-hand side) to close the Winamp Preferences window. Restart Winamp and try playing a song.
Thank you for the quick answer. However, that did not fix the issue. I still see and hear the lower audio volume from Winamp with MIDI files. Do the newer Winamp prereleases and/or plugins have this MIDI audio volume fix? If it helps at all, my onboard audio from RealTek.

--Ant @ Ant's Quality Foraged Links (http://aqfl.net) and The Ant Farm (http://antfarm.ma.cx).
ant is offline   Reply With Quote
Old 7th May 2020, 20:15   #4
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,752
Sorry, I read your 1st post too quickly. My reply is to another issue (volume lower for other files after playing a midi). Hopefully someone will have an answer for your actual issue soon.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.1 skin
Windows 10 Home 64-bit v2004 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 7th May 2020, 20:18   #5
ant
Senior Member
 
Join Date: Jul 2000
Location: An Ant Farm
Posts: 111
Quote:
Originally Posted by Aminifu View Post
Sorry, I read your 1st post too quickly. My reply is to another issue (volume lower for other files after playing a midi). Hopefully someone will have an answer for your actual issue soon.
Oh darn. Thanks. I'm glad my non-MIDI files' audio volumes aren't changing. I would go bonker.

--Ant @ Ant's Quality Foraged Links (http://aqfl.net) and The Ant Farm (http://antfarm.ma.cx).
ant is offline   Reply With Quote
Old 8th May 2020, 02:30   #6
ant
Senior Member
 
Join Date: Jul 2000
Location: An Ant Farm
Posts: 111
DrO answered my question in https://www.reddit.com/r/winamp/comm...chool/fpty572/. I had to use DirectMusic setting in MIDI input plugin.

--Ant @ Ant's Quality Foraged Links (http://aqfl.net) and The Ant Farm (http://antfarm.ma.cx).
ant is offline   Reply With Quote
Old 8th May 2020, 03:36   #7
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,752
That's great news!

DrO is a former Winamp developer. He worked on it for many years. Few people know more about Winamp than him. He is now working on another project (https://getwacup.com).

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.1 skin
Windows 10 Home 64-bit v2004 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Tags
audio, mid, midi, volume, winamp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump