Old 23rd April 2014, 14:11   #1
scyphe
Junior Member
 
Join Date: Oct 2001
Posts: 15
Always on Top - never ever sticks

For some reason disabling the "Always on top"-setting never sticks. Is there some ini-file setting or alternate way of disabling "always on top" in 5.666?

I have "Disable always on top while fullscreen applications are in focus" checked but that doesn't apply to the desktop, ie. Winamp still sits on top when I use Chrome, Photoshop or whatever, it seems to be specifically for games that creates their own screens.

A strange omission this. I don't know where this setting is stored (and why it resets each time) and even thought about hex-editing the .exe-file since it's such a nuisance that the settings but I have no idea where that particular byte is in the .exe-file.
scyphe is offline   Reply With Quote
Old 23rd April 2014, 21:51   #2
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
The setting is saved in your winamp.ini file

[Winamp]
aot=1

So setting it to 0, will disable Always on top.

Are you using a modern skin which is may docked on the desktop? Or does it happen with classic skins as well?

We could need an info report of your configuration as well.
Koopa is offline   Reply With Quote
Old 24th April 2014, 11:50   #3
scyphe
Junior Member
 
Join Date: Oct 2001
Posts: 15
Okay, I set aot=1 to aot=0. The only thing that happened was that when I started Winamp it opened in the background (ie. behind the current active window, in this case Chrome). When I clicked the Winamp-icon Winamp showed up and is stuck in front of any and all windows. I closed Winamp and checked the setting and it had changed back to aot=1.

Interestingly enough it doesn't matter that I made it read-only (and it still says aot=0), the setting in Winamp is still Always On Top - checked.

The Winamp Info Tool says Always On Top is disabled.

EDIT: Aaaaaahhhhh...

I always use the MMD3-skin in docked mode. When it's NOT docked the AOT-setting actually works. Very strange.

Is there a way to get AOT=0 working with a docked MMD3-skinned Winamp? Not sure why it works with the same skin when Winamp is in normal visual mode but not when in "docked" mode. Even the setting is shown as Always On Top - disabled (no checkmark) with skin at normal setting while it's shown as Always On Top - enabled (checkmarked) when the skin is in it's second mode, the thing horisontal form.

EDIT2: every time I start Winamp now the playlist has been replaced with
1. -aot
2. 0

(see screenshots)

This just started now for no reason. The only thing I changed was AOT=0 and I made the winamp.ini-file read-only (it's back to normal again).

How do I fix THAT????
Attached Thumbnails
Click image for larger version

Name:	winamp_pl1.JPG
Views:	186
Size:	121.1 KB
ID:	51120   Click image for larger version

Name:	winamp_pl2.JPG
Views:	181
Size:	73.9 KB
ID:	51121  
Attached Files
File Type: zip Winamp_Info_Report_04-24-2014.zip (19.0 KB, 128 views)

Last edited by scyphe; 24th April 2014 at 12:03. Reason: More info
scyphe is offline   Reply With Quote
Old 24th April 2014, 11:54   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
because 'docked' mode is a special mode which is why the AOT option doesn't really apply in that mode. as the point of docked mode is that it'll always be there and so will be on top of other windows (as is determined by the OSes handling of app bars - which is what docked mode).

that's why most docked mode implementations in modern skins allow for auto-hiding of the window(s) so it's there but not in the way of things.

so i don't see there being anything else you can really do to change the behaviour (since it's somewhat determined by using that mode and how the OS works for such things).
DrO is offline   Reply With Quote
Old 24th April 2014, 12:05   #5
scyphe
Junior Member
 
Join Date: Oct 2001
Posts: 15
Pity.. I prefer using it in mini-mode like that. I'd love to have an AOT-setting for docked mode as well in next version.

Anyway, I guess I'll better reinstall Winamp since the playlist-function has gone haywire.
scyphe is offline   Reply With Quote
Old 24th April 2014, 12:09   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
if you're re-installing, make sure you're using v5.666 build 3516 from http://forums.winamp.com/showthread....74929#download and that you apply the dll patches from http://forums.winamp.com/showthread.php?t=156839#known2

different skins do different things and due to the age of MMD3, unless you attempt to make some edits to it. there's probably not much that can be done to even attempt to work around things (since AOT is generally implied in a docked situation).

just seen the edits... maybe you've managed to set a value on the winamp shortcut as that's the only thing i can think off to cause the playlist to act like that on loading.
DrO is offline   Reply With Quote
Old 24th April 2014, 12:17   #7
scyphe
Junior Member
 
Join Date: Oct 2001
Posts: 15
Lol, you're absolutely right....

I tried this in a desperate attempt to force disabling of AOT (in the icon settings): C:\tools\Winamp\winamp.exe -aot 0.. totally forgot about it.

Thanks for the heads up, at least I don't have to reinstall Winamp again (I've already got 5.666 build 3516. I'll get those .dll patches though.

Thanks for the help

I guess this thread has turned into a feature request: ability to enable AOT when Winamp is in Winshade/Docked mode.

There's one bug in all of this that I managed to find (can't be a feature). When it's in Winshade/Docked format and I close Winamp, it changes the AOT-setting in the .ini-file from 0 to 1. I see no logical reason for that except that Winamp writes it's state into the .ini and unfortunately sets AOT=0 to AOT=1.

ps. disabling Always On Top in the options (ctrl+A doesn't work to toggle it on/off though) while in Winshade/dock-mode DOES work, it just won't remember it after closing winamp and starting it again.
scyphe is offline   Reply With Quote
Old 24th April 2014, 12:30   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's only writing it since something has toggled the state and i really suspect it's the old MMD3 skin just not doing things correctly (as from a quick try with the official skins i couldn't see such a behaviour).
DrO is offline   Reply With Quote
Old 24th April 2014, 12:47   #9
scyphe
Junior Member
 
Join Date: Oct 2001
Posts: 15
Also a pity. MMD3 may be old as my granny but it's always been the only skin I've used. I wonder if there's a way to edit/tweak the code/settings in the skin. I've never messed with Winamp plugin or skin-editing and it's been a while (years) since I did any programming. I'll check the files and see if there's anything intelligible.

EDIT: found several settings in the .xml files.

<togglebutton
id="aotdummy"
x="58" y="9"
w="1" h="1"
cfgattrib="{280876CF-48C0-40BC-8E86-73CE6BB462E5};Always on top"
/>


<togglebutton
id="playershade.button.aot"
x="32" y="24"
image="playershade2.button.cfg.aot"
downImage="playershade2.button.cfg.aot.down"
activeImage="playershade2.button.cfg.aot.active"
tooltip="Automatic Always on top in whinshade mode"
rectrgn="1"
/>

<togglebutton
id="s2aot"
x="7" y="24"
image="playershade2.button.cfg.aot"
downImage="playershade2.button.cfg.aot.down"
activeImage="playershade2.button.cfg.aot.active"
tooltip="Automatic Always on top in whinshade mode"
rectrgn="1"
/>

Any of those settings worth changing?

activeImage="playershade2.button.cfg.aot.active" change to .disabled?
scyphe is offline   Reply With Quote
Old 24th April 2014, 12:54   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
there was a modded version someone provided a few years back (can't find it currently) which made it more v5.x compatible (seeing as it was primarily a Winamp3 skin) but i cannot remember exactly what issues it fixed (or whether it'd be helpful for your issue).
DrO is offline   Reply With Quote
Old 24th April 2014, 13:04   #11
scyphe
Junior Member
 
Join Date: Oct 2001
Posts: 15
Oh, wait, I just found a setting (thanks to finding and seeing those xml-settings) in the UI with the toggle-button.

Problem solved... That button works and remembers when closed/opened, ie. it was there all along as a special setting when the skin is in Winshade/docked mode, hidden in a drop-down (as opposed to rightclicking and selecting Options which only affects normal mode).

Case closed, Winamp-user humbled and feeling a bit silly.. and grateful for the help I got from both of you.


/Daniel
scyphe is offline   Reply With Quote
Old 13th August 2015, 14:18   #12
scyphe
Junior Member
 
Join Date: Oct 2001
Posts: 15
Had the same issue again (completely forgotten how to fix it until I found this thread again). Here's a screenshot for those that have the same issue with MMD3 in "docked" mode, showing the CFG-button in the skin which opens up a drop-down menu where you can uncheck "always on top":

scyphe is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Tags
always on top, forgetting, not saved, setting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump