Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 31st October 2013, 15:15   #1
MrHoek
Junior Member
 
Join Date: Oct 2013
Posts: 2
When registering file types and one click 'audio only' also graphic file types are se

I use WinAmp only for playing audio files/streams.

So I recently wanted to update my file associoating in Windows (XP) because some file types were not correctly associated with Winamp.

So I selected the 'Audio only' button in the configuration and to my supprise also all picture/graphics file type (like JPG/GIF/BMP/PNG/TIF) we're selected in the process (and sadly registered to WinAmp to )

Please correct the incorrect selection method.

Regards!
MrHoek is offline   Reply With Quote
Old 31st October 2013, 15:19   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
Winamp does not register image files with itself unless a 3rd party plug-in has been installed which indicates that those file extensions are to be associable (or they've been added to the options within one of the native plug-in preferences).

so you're saying that those extensions are being shown in the file types list? if so, then an info report would be needed (http://forums.winamp.com/showthread....161361#plugins) to determine what is adding them.

[edit]
we're going to add in some checks to prevent those extensions from being registered (with an opt-out option just to maintain compatibility).
DrO is offline   Reply With Quote
Old 1st December 2013, 12:23   #3
MrHoek
Junior Member
 
Join Date: Oct 2013
Posts: 2
Hmmm, as far as I knwo, I don't have any 'image' plgunins installed, beside the once that came with de default/plain installation of Winamp itself.

See attached WinAmp Info tool report!
Attached Files
File Type: txt Winamp_Info_Report_01.12.2013.txt (21.4 KB, 262 views)
MrHoek is offline   Reply With Quote
Old 1st December 2013, 12:51   #4
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
Quote:
Originally Posted by MrHoek View Post
Hmmm, as far as I knwo, I don't have any 'image' plgunins installed
You have!

in_imageamp.dll
Version: 1.0.0 | Size: 20 KB

Also your Winamp version is outdated, only 5.666 is supported here:
Winamp 5.666 Released, and is the only version supported here

As DrO said, they tweaked things in 5.666 which prevents images to be registered with Winamp. If you upgrade to latest version and uninstall that 3rd party plugin, your issue should be gone.

Also I highly recommend to delete gen_dropbox.dll, that plugin was an alpha version and isn't supported anymore.
Koopa is offline   Reply With Quote
Old 2nd December 2013, 16:13   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
well at least the cause (which was a plug-in as suspected) and a fix is now known for this one i.e. a 5.66x release.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Tags
association, extension, file type

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump