Old 4th February 2004, 19:03   #1
TakuSkan
Member
 
TakuSkan's Avatar
 
Join Date: Jan 2004
Posts: 73
v5.01 Title/Taps bug?

I can't get my modifications/additions of '- %3 - %e' to 'Winamp Preferences | Plug-ins | Input | Nullsoft MPeg Audio Decoder | Title/Tags | Title formatting' in v5.01 to show up in the playlist window. No matter how I edit those paramters, all I get displayed is '%1 - %2', or 'Artist - Title'. The '- %3 - %e', or '- Album - Encoder' don't show up.

Even with v2.91, it was frustating that the playlist window wouldn't display the added fields until the files were actually played. It'd be really nice if tracks would show up immediately in the playlist window showing all configured fields.

Shel
TakuSkan is offline   Reply With Quote
Old 4th February 2004, 19:11   #2
Sawg
Guest
 
Posts: n/a
Preferences > General preferences > Titles > Use or Disable advanced title formatting.

To refresh the list select all tracks (Ctrl-A) and select Misc > Misc Options > "Read extended info on selected track(s)"
  Reply With Quote
Old 4th February 2004, 20:26   #3
TakuSkan
Member
 
TakuSkan's Avatar
 
Join Date: Jan 2004
Posts: 73
Quote:
Originally posted by Sawg:
Preferences > General preferences > Titles > Use or Disable advanced title formatting.
This is already enabled by default, and seems only to effect the scroll in the main Winamp window, not the playlist window... unless I've got some other problem.

Quote:
To refresh the list select all tracks (Ctrl-A) and select Misc > Misc Options > "Read extended info on selected track(s)"
It doesn't seem to make any difference to the file info displayed in playlist windows.
TakuSkan is offline   Reply With Quote
Old 4th February 2004, 23:41   #4
TakuSkan
Member
 
TakuSkan's Avatar
 
Join Date: Jan 2004
Posts: 73
Quote:
Originally posted by Sawg
Preferences > General preferences > Titles > Use or Disable advanced title formatting.
Okay Sawg... I figured out how to write the code there. I've got %album% and %tracknumber% configured and displaying in the playlist window now.

But unlike the method I used to use to display these tags that I outlined above, I don't see any way to configure an %encoder% field.

It seems I actually >did< get modifications to 'Winamp Preferences | Plug-ins | Input | Nullsoft MPeg Audio Decoder | Title/Tags | Title formatting' to display when I 1st started playing with things. But at this point, no settings I configure there show up... even if I disable 'Preferences | General preferences | Titles | Use or Disable advanced title formatting'
TakuSkan is offline   Reply With Quote
Old 4th February 2004, 23:55   #5
TakuSkan
Member
 
TakuSkan's Avatar
 
Join Date: Jan 2004
Posts: 73
Quote:
Originally posted by TakuSkan
even if I disable 'Preferences | General preferences | Titles | Use or Disable advanced title formatting'
Correction:. If I disable the above and refresh the playlist as you explained, the Nullsoft MPeg Audio Decoder settings I decribed above >do< in fact appear.

But when titles are added to the playlist from the library, they only appear as playlist numbers 1, 2, 3, 4, ... until actually played. Then the configured fields are displayed, including the encoder field. But this isn't any good!
TakuSkan is offline   Reply With Quote
Old 5th February 2004, 02:44   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,894
Prefs > Media Library > Library Options:
Uncheck: Use library data for Winamp title-formatting
DJ Egg is offline   Reply With Quote
Old 5th February 2004, 19:00   #7
TakuSkan
Member
 
TakuSkan's Avatar
 
Join Date: Jan 2004
Posts: 73
Quote:
Originally posted by DJ Egg
Prefs > Media Library > Library Options:
Uncheck: Use library data for Winamp title-formatting
Okay... by disabling that together with disabling Advanced Title Formatting, the settings for the Nullsoft MPeg Audio Decoder finally show up.

But I found something else useful. Even with Advanced Title Formatting disabled, Winamp still uses the code there to display MP3 tag info when tracks are added to the playlist. By default, just the artist and track title appear when tracks are added to the playlist.

But when I add code in Advanced Title Formatting to include displaying album and track number tags, Winamp goes ahead and displays those additional tags too when adding a track to the playlist. That's great, as Winamp still refuses to display tag info set in the Nullsoft MPeg Audio Decoder settings until the MP3 is actually played.

Thanks for the feedback Sawg & DJ!
TakuSkan is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump