Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 22nd June 2011, 12:24   #1
Sathimas
Junior Member
 
Join Date: Jan 2011
Posts: 5
Winamp misreads tags from Cowon J3/D2 at second connection to the computer

Hi there,

thats my problem:

I sync my Cowon J3 and D2 with winamp - winamp just offers the best
possibilties and settings for precise syncing. But it works only once!

I sync my files by rating - everything rated above 4 goes to the player.
That works very well.

But as soon as I disconnect the player and reconnect it some other day,
winamp misreads the tags on the player. It sees all the files but does not
read the tags of most of them. So most of the files have no artist, album
and so on anymore.

The tags are still there for sure, since the mp3player reads them - windows does too.

This bug is very enerving since its absolutely impossible for me to autosync my library!

Is there a solution for that problem?
Sathimas is offline   Reply With Quote
Old 27th June 2011, 05:28   #2
Sathimas
Junior Member
 
Join Date: Jan 2011
Posts: 5
And up ...

Come on guys, is this a support forum or not? :-(
Sathimas is offline   Reply With Quote
Old 7th July 2011, 04:46   #3
Sathimas
Junior Member
 
Join Date: Jan 2011
Posts: 5
And up again ...

How do things work here?
Is there any "winamp-insider" in this board or is it just user-user-help here?
Sathimas is offline   Reply With Quote
Old 30th July 2011, 21:06   #4
Sathimas
Junior Member
 
Join Date: Jan 2011
Posts: 5
Another try - anybody any idea?
Sathimas is offline   Reply With Quote
Old 27th November 2011, 15:41   #5
elflaconeri
Junior Member
 
Join Date: Nov 2011
Posts: 1
I'm a new J3 owner. In the faint hope that OP sees this or it helps anyone else, this is what I've noticed -

When the J3 is set to USB mode = MSC, there is an additional Advanced tab under Preferences to manage your player (which shows up as "USB drive G:\" or something similar in Winamp, if you are seeing "COWON J3" you are in MTP mode). Here you can set the file structure on the J3. However, if your tags are only partially complete, or in the file name format you reference a field that is intentionally blank, your filepaths get messed up a little. I think winamp tries to retrieve metadata primarily by following the file name rules and maybe scanning the actual file as a secondary option. So let's say I have this mp3

filename: Ward 21 - Brown Eyes Bleed.mp3
artist: Ward 21
title:Brown Eyes Bleed
album: Genesis
track:7
year: 2009

and my file name format is set to "G:\Music\<Artist>\<Year>\<Album>\<track>. <title>"

so on my J3 I should get
"G:\Music\Ward 21\2009\Genesis\07. Brown Eyes Bleed.mp3"

Now, let's say I think the album, track and year might be wrong, so I delete them from the ID3 tag until I get the right info. This leaves

filename: Ward 21 - Brown Eyes Bleed.mp3
artist: Ward 21
title:Brown Eyes Bleed

What happens when I sync my J3 is that instead of doing this
"G:\Music\Ward 21\Unknown\Unknown\Unknown. Brown Eyes Bleed.mp3"

or something similar, Winamp does this
"G:\Music\Ward 21\\\. Brown Eyes Bleed.mp3"

Note the "\\\." in the filepath. I noticed this when I played a song from my J3 through Winamp's Playlist Editor.

So, you can still play the file, but the year and album info won't show up when winamp scans the player, I think because it's prioritizing the file name rules. Similarly, if your setup uses titles, albumartist, or whatever, the same probably happens.

If your tags are incomplete this may be the problem. Also, this may vary for different filetypes, tag versions, etc. I have no way of knowing for sure, just my 2 cents. Hopefully this helps someone somewhere, I re-registered just to post this...
elflaconeri is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump