Old 6th August 2012, 00:13   #1
zachbauer91
Junior Member
 
Join Date: Aug 2012
Posts: 1
Post Playlist Syncing

Before I begin, I’d like to say that I’m aware that this isn’t the first time someone has brought up the topic of playlist synchronization between PC and Android, whether it is to an MSC device, or an MTP device. I’d also like to add that yes, I have already searched all five pages of topics related to this in this forum, including the sticky of current known bugs and feature requests and I’m still not satisfied. With that Said, Let me detail the problem a little clearer incase I’m lucky enough to get noticed by a mod.


The Problem:

I have a Samsung Galaxy Nexus that I’m trying to sync using Wifi-sync n Windows 7. All of the music is not on the device; however the playlists always fail to sync. Let me add that all of the songs I wish to add to these playlists sync without fail and are present on the Android device.
In this instance, letting Winamp handle the syncing of the playlists results in either some playlists syncing the name of the playlist (meaning it comes up on the Android device) either some (under 15, regardless of size) or none of the sync make it.
When I manually drag a playlist from the windows client in into the portables section, the same problem occurs. Some of the songs may appear in the playlist, but not all of them


The Symptoms:

Typically, I’m used to seeing an error code when syncing songs that either have forbidden punctuation, are not in the directory Winamp expects them to be, or have been deleted outside the client. In this case, playlist synchronization throws no errors, and according to the windows client, everything seems fine.
At this point, I’d usually click on the playlist in the Android device portable view (windows client), and all of the music appears to be there. When I refresh the view, usually by moving to a different view (such as the desktop playlist), and then go back, the playlist will always show that only a few songs are present, and the Android device then confirms this (it will confirm regardless of refreshing Winamp).


Possible Fix:

I’m currently able to drag single files (that have already been synced) from the desktop playlist view into the Android devices playlist, which will then appear in the Android device 100% of the time.
This process is broken with I select any more than 1 files at a time. If I select 5, 10, or any number of files and drag them all over, only the first file syncs 100% of the time.


What I, and many other Android users want to see:

I’m sure I speak for a lot of us when we say that we’d like to see this issue get more visibility from both the moderators and the developers. I’ve seen some great advancements in Winamp pro, in the way of bundling useful applications, numerous bug fixes for newer versions of android, and of course, functions like wireless sync, of which I am a huge fan. This issue however, never seems to make it under the spotlight, and through my lurking, many of the posts on the topic appear to go unanswered, or just filled up with replies of people facing the same issue.

All I ask is that a moderator get in on this, and possibly elevate the issue to the proper channels so that it gets addressed before other Winamp users, including myself, begin searching out an alternative to the program. Of course, my complaint will also be posted in the sticky related to bugs, but I thought a fresh post could do it justice as well.
zachbauer91 is offline   Reply With Quote
Old 12th August 2012, 22:33   #2
Kloreep
Junior Member
 
Join Date: Aug 2012
Posts: 1
I recently installed WinAmp to use with my Galaxy S3 and I'm having the same problem. Whenever I sync (to SD Card) following a fresh wipe of the SD card, both the WinAmp app and the Google Play app will display abridged or even blank playlists. Browsing by album will show all of it to be there, it's just not showing up on the playlists. Which songs are omitted vary with each sync, and it can even include some but not all of individual albums, so there does not appear to be a pattern or possibility of an issue with individual tracks. Winamp itself will show the playlists in their complete form when looking at them under the card in Devices.

Too bad, WinAmp has a lot of stuff I like. But without a way to overcome this problem I think it's time to dump it just days after installing it and go find something else.
Kloreep is offline   Reply With Quote
Old 11th September 2012, 00:24   #3
solstafir
Junior Member
 
Join Date: Sep 2012
Posts: 1
I got a Motorola atrix a year and a half ago and had this exact same problem. While sending a playlist over wi-fi it says its working fine but nothing shows up in the list or just a few songs.

I can't believe it still hasn't been resolved. It seems crazy that such basic functionality is missing.
solstafir is offline   Reply With Quote
Old 12th February 2013, 05:14   #4
JMullins
Junior Member
 
Join Date: Feb 2013
Posts: 30
I am having problems with transferring *some* playlists. On my PC all of the playlists create fine and are useable. I create a playlist "Pink Floyd" and populate it with the songs I want. Everything works well. When I transfer it to my external SD card in the Galaxy S3 it shows everything is transferring. It completes without error.
The Playlist it created but empty. Now the weird part is that the albums/songs are not shown under the default lists of Artists/Albums/Songs. So there appears to be no way to actually play the music.

Now the really weird part. If I look at the device through my computer interface I see in the Music folder an entry for Pink Floyd. Under that are the proper entries for the albums and the songs. Both mp3 and m4v are located in the correct directories. Further when I attempted to resync the playlist to created filename.dup0 and filename.dup1 entries in the directory.

Looking around it appears that I now own several hundred Unknown Artist/Unknown Album files. Several of these have Album Art associated with the files. On the PC everything is properly identified.

I am going to make a guess. All of these problems are probably associated with the fact that the extSDcard is formatted FAT32. My PC is Win7x64 with NTFS drives. So file names like "'70s Soul Gold Disk 2" are valid in the PC but fail on the phone because of that ' character.

Now could I go through all of my songs and fix all of the special characters? Yes, but I am not going to. I have nearly a TB of media and would find a new media player first. I understand that the problem is not caused by WinAmp but a limitation of the phone. But I would expect that Winamp can solve the problem when it is transferring the music by eliminating characters from the name that will mess up the file system. Those characters can be preserved in the ID3 info.
JMullins is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp for Android

Tags
android, playlist, sync, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump