Old 30th November 2012, 04:39   #1
dd-b
Junior Member
 
Join Date: Feb 2003
Location: Minneapolis
Posts: 7
Winamp silent for a few particular files

There are a very few files in my MP3 collection that Winamp claims to be playing (the progress bar moves, and the little histogram window shows activity) -- but no sound comes out. I just tracked down one of these files, and it plays fine in VLC media player (first thing I could lay hands on that plays MP3s other than winamp on my system). It's definitely the file -- repeats across days, across reboots, etc. The vast majority of my files play fine, these few (I've got two I've nailed down for sure, out of tens of thousands of MP3 files) don't.

This has been going on for months or years, I'm just slow in finding the particular files and nailing it down well enough to complain. It's continued across several Winamp versions (I'm currently running 5.622 on Windows 7). I'm going to grab the latest in a second, just for completeness' sake -- but since it's persisted across several versions I'm not particularly expecting that to help. If I don't post tonight that the latest version fixed this, then it didn't.

I can upload an example, I think (looks like I'd have to put it in a zip file, which is dumb, but easy), if anybody wants to actually look at the example.
dd-b is offline   Reply With Quote
Old 30th November 2012, 04:43   #2
dd-b
Junior Member
 
Join Date: Feb 2003
Location: Minneapolis
Posts: 7
Same behavior in 5.63

Yeah, as expected since it's crossed many versions in the past, the behavior is in fact the same in the latest download of 5.63.
dd-b is offline   Reply With Quote
Old 30th November 2012, 05:28   #3
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
do you use RG?

have u examined your files with mp3val?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 30th November 2012, 16:38   #4
dd-b
Junior Member
 
Join Date: Feb 2003
Location: Minneapolis
Posts: 7
No idea what RG is and google isn't helping, it being such a short name that appears in many words.

Mp3val I googled up, downloaded, and ran.

One of the files shows a problem, but only garbage at end. The other files in the same directory (same source), which both play fine in Winamp, also show the same problem. Just as a reminder, this problem file plays fine in VLC media Player. I've played it to the end before, it's not truncated.

The other file (and on further investigation, in this case it's the entire album worth of files, which I ripped myself years ago) is OK according to Mp3val, but still doesn't play in Winamp. And still plays fine in VLC Media Player.

I'm going to try re-ripping the CD for the one I have in that format, and see if the results are different. Which would solve the immediate problem, but not really resolve my curiosity.

(The music archive, and all my files, are on a Solaris fileserver with ZFS -- which means there are data block checksums for both copies of the redundant data blocks, and that they're verified on both halves of the mirror every week when I run a scrub. I can't of course actually rule out local corruption absolutely, but undetected corruption based on a disk, controller, or cable error is much much less likely in this setup than in most.)
dd-b is offline   Reply With Quote
Old 30th November 2012, 16:42   #5
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
RG = Replay Gain. i had a situation where a file was fine in other apps, silent in winamp, b/c of the RG tags in the file.

RG or mp3val might not be the answer, but it was just somewhere to start looking. make sure you have copies of unfixed afflicted files you can send the devs in case you "fix" the files, so that the devs can replicate the issue even if u fix it.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 30th November 2012, 20:51   #6
dd-b
Junior Member
 
Join Date: Feb 2003
Location: Minneapolis
Posts: 7
Ah, that RG. No, not in use.

Ah, Replay Gain. I've got that turned off. I don't remember doing anything that might have added tags to the files, but some of these files are a decade old, so who knows?

When I do re-rip the album I have the CD for that has a problem, I was certainly going to keep bagged samples of the problem files (assuming the new files work okay).

Thanks for your ideas so far! It's useful to talk to people who know this stuff better than me while trying to debug it.
dd-b is offline   Reply With Quote
Old 30th November 2012, 21:04   #7
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
pick a file in ML then do alt+3 and you can see if it has RG tags or not. shouldn't matter if you have RG off, but something to check. also, the equalizer has a limiter, but i doubt thats it either.

at this point i would say you should try upgrading to 5.63 and then install "one for nunz" and post your plugins list.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 2nd December 2012, 17:29   #8
dd-b
Junior Member
 
Join Date: Feb 2003
Location: Minneapolis
Posts: 7
I did upgrade to 5.63 back on 29-Nov; behavior is unchanged (see message from then).
dd-b is offline   Reply With Quote
Old 2nd December 2012, 21:05   #9
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
Quote:
Originally Posted by MrSinatra View Post
and then install "one for nunz" and post your plugins list.
???

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 8th April 2013, 17:47   #10
Gingko
Junior Member
 
Join Date: Jun 2009
Location: France
Posts: 3
Hello,

I have the same problem on Windows 7 (Ultimate, x64, SP1) with some MP3 files.
These files play fine if I play them on the same computer using, for example, VLC media player.
They play fine also if I copy them on another computer running Windows XP Professional SP3, using the very same WinAmp application and version.
Many other MP3 files play fine also with WinAmp and Windows 7.

But I've probably found how these files are different: they are recorded as "monophonic" whereas as others are "stereo" or "joint stereo".

So I would like to know how I could play monophonic MP3 files using WinAmp on Windows 7 Ultimate SP1 x64?

Thank you in advance for any answer.
Gingko is offline   Reply With Quote
Old 8th April 2013, 17:54   #11
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
winamp plays mono fine.

post an example file at 4shared.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 8th April 2013, 20:36   #12
Gingko
Junior Member
 
Join Date: Jun 2009
Location: France
Posts: 3
Test results

Quote:
Originally Posted by MrSinatra View Post
winamp plays mono fine.

post an example file at 4shared.
I don't doubt that WinAmp can play mono files perfectly.

This seems to be more likely an interactive issue between WinAmp and some Windows versions, and/or with the sound card driver. And actually, even when there is no sound, there are some meters in the sound cards controls (thus outside WinAmp) that move like if a sound were played. But nothing goes out of the speakers.

As I have several computers with multiple Windows versions installed on each (multiboot), I just made more tests by trying to play one of these monophonic files on six different Windows installations.

The results are the following.
  • Computer 1 (Dell Laptop)
    • Windows 7 Ultimate SP1 (x64) : No sound
    • Windows Vista Home Premium SP2 (x86) : No sound
    • Windows XP Professional SP3 (x86) : Works fine
  • Computer 2 (Desktop computer with ASUS Mainboard)
    • Windows 8 Professional (x64) : Works fine
    • Windows Vista Ultimate SP2 (x64) : Works fine
    • Windows XP Professional SP3 (x86) : Works fine

Where no sound is heared using WinAmp, the same problem seems to happen using Windows Media Player. But the file can be perfectly played using VLC media player or Media Player Classic.

And once again, this seems to concern only monophonic files (at least two of them tried).

You can download the monophonic MP3 file that I tried to play here (Actually a ring tone for mobile telephone. No, it isn't on 4shared. I uploaded it on my own server).

Gingko
Gingko is offline   Reply With Quote
Old 8th April 2013, 21:53   #13
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
plays fine on my alienware win7 ult sp1 laptop. r u using winamp 5.7b?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 9th April 2013, 05:22   #14
Gingko
Junior Member
 
Join Date: Jun 2009
Location: France
Posts: 3
Quote:
Originally Posted by MrSinatra View Post
plays fine on my alienware win7 ult sp1 laptop. r u using winamp 5.7b?
I am using WinAmp 5.63.
Latest official release, as far as I know.

Gingko
Gingko is offline   Reply With Quote
Old 9th April 2013, 05:24   #15
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
it is, but 5.7b would just be something to try.

also, it is possible that your RG settings on those computers where it doesn't work are such that the volume is way down on files without RG tags, as opposed to the other computers.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 12th March 2015, 18:16   #16
Cassie1254
Junior Member
 
Join Date: Mar 2015
Posts: 1
Gingko, do you still have the problem where you don't hear any sound when a monophonic song (mp3 format) is played on winamp / WMP. I have now all of sudden the same problem where I don't hear anything when a mono song is played on Winamp or WMP but the sound is fine when I play the song on VLC media player - other files that are in stereo is playing in Wimamp, WMP and VLC media player
What can I do to solve this as I use Winamp as my default player
Cassie1254 is offline   Reply With Quote
Old 12th March 2015, 18:41   #17
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,622
Send a message via AIM to MrSinatra
post your info report and an example file.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump