Old 19th July 2007, 13:58   #1
dunniecash
Junior Member
 
Join Date: Jul 2007
Posts: 3
Jump to File option much slower than before?

I have a question about the Jump to File option. My playlist is rather large, 27800 tracks thereabout. Up until version 5.32 or so, searching with the Jump to File option was quick. With this version, the dialog box pops up slower (even though it only has to load 25 out of 27800 tracks, because of the 'search optimalisation') and when I type keywords, it takes two or three seconds to show the results. When typing those keywords, it takes Winamp some seconds to show what you typed in the box. Annoying when you type fast, because when you make a typo, your search will not return any results. So as soon as you notice your typo, you try to backspace of course. However, this goes slow too because Winamp is still trying to gather results on your search. Anybody else having this problem? Or know what I could do about it? Thanks in advance.
dunniecash is offline   Reply With Quote
Old 19th July 2007, 19:46   #2
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
I wonder if 25 is too small? i'm not sure. what happens with the default 100?
You could increase the delay from last key stroke. default is 250ms, maybe go up to 2x that.

I dont have that many files, so i'm of little help...
billyvnilly is offline   Reply With Quote
Old 20th July 2007, 13:14   #3
dunniecash
Junior Member
 
Join Date: Jul 2007
Posts: 3
Anyone else? Really, this is so annoying.
dunniecash is offline   Reply With Quote
Old 20th July 2007, 13:29   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
with all of the optimisations and ensuring you're using the latest version of the jtfe plugin it should be quicker with large playlists of that size against the original winamp code. there will be a delay happening on loading (modern skins will cause more of a delay since it interfers with the gui updates at times) and when changing/entering the search it will take a little while to display the results (since gui updates on the list are disabled whilst running the search).

when the search changes, the results should from what i remember of the code abort and tell winamp not to add anything else to the results.

without knowing what setup your running/other plugins/skin type it's hard to even really guess (since i'd expect a few seconds delay with a pre 2ghz machine with that sort of playlist). from the tests i've done with duplicating my playlist up a few times, things seemed to run smoothly but maybe i just don't type fast enough, etc or it's something with the playlist you're working with (the search provided with the jtfe plugin is more exact than the original/built in jtf search function which will be slower but other tinkerings mean it should be faster unless i've really messed up...).

i guess you can try it with gen_jumpex.dll disabled (rename to .off or move out of the plugins folder) and see what happens with that (you won't have list results limits in that case) if it's any better.

-daz
DrO is offline   Reply With Quote
Old 20th July 2007, 18:15   #5
dunniecash
Junior Member
 
Join Date: Jul 2007
Posts: 3
I just tried disabling gen_jumpex.dll, but it only made the jump to file option slower. I'm running on an AMD Athlon XP 2400+ 2.00 Ghz, with 1,75 GB of RAM. In search optimalisations I set the limit of search results to 200 and the delay from last typing to 1 ms. It is a little faster now, but still not fast enough for a fast typer like I am..

So, I'm wondering.. how come the option was so much faster before, and is so much slower now? Is it because the option is more advanced and thus needs more processing time? In this case, more advanced is not always better IMHO..
dunniecash is offline   Reply With Quote
Old 20th July 2007, 18:49   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
ah that would explain things.

the lower the delay is, the more the code is going to have to try to work to keep up and with a playlist of that size there is effectively no way to do that without a faster machine. increasing the delay would be preferable since it will then allow you to effectively type what you want and just search on the end search text in one go instead of running multiple searches on every change made.

as for the speed difference, that's because gen_jumpex.dll does a number of tricks over the very simple code that otherwise is used by the jtf dialog.

-daz
DrO is offline   Reply With Quote
Old 20th September 2007, 16:16   #7
crossover
Junior Member
 
Join Date: Jun 2006
Posts: 8
I have this problem too, but I think it's something with the version of WA. It happens with WA 5.35, but not with an earlier version I used.
But I rather keep using this version. I have about 5500 tracks in my playlist and the delay is 1 or 2 seconds. It used to jump to the files right away but not anymore. Any help??

Excuse me for the crappy English, Dutchman here.
crossover is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump