Old 10th July 2008, 11:02   #1
heavydawson
Junior Member
 
Join Date: Dec 2005
Location: Ireland
Posts: 25
Memory usage with online features

Winamp memory usage shoots up when using online features (artist info / shoutcast radio listings), and it seems to hold whatever instances of IE it creates (my understanding is it uses IE anyway) open until Winamp itself is closed. My usage jumps from 50/60MB private bytes to between 200-300 mb when I start using the online services. And when I switch back to say my audio library, the memory used by the browser instance is not released. It's probably for performance reasons I suppose, but damn that's a lot of memory.

Also the "More information about this artist" button opens up a blank black page for me. I'm living in Ireland so maybe that has something to do with it. I think I read about localized pages in some of the threads recently.
heavydawson is offline   Reply With Quote
Old 10th July 2008, 11:16   #2
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,911
hmm, I can confirm this. is this a bug?

bug with ie?


winamp discussion --> bug reports.
Rocker is offline   Reply With Quote
Old 10th July 2008, 11:19   #3
heavydawson
Junior Member
 
Join Date: Dec 2005
Location: Ireland
Posts: 25
Quote:
Originally posted by Rocker
hmm, I can confirm this. is this a bug?

bug with ie?


winamp discussion --> bug reports.
Well the reason I didn't want to go straight to bug reports is that I think that the IE instances are being kept alive (and re-used for the most part from what I can tell) for performance reasons. It may be a design decision. Any devs able to confirm this?
heavydawson is offline   Reply With Quote
Old 10th July 2008, 14:02   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,136
Hmm, I can't seem to reproduce the problem here.
Is it the "Mem Usage" column you're looking at, or "VM Size"?

Windows Task Manager isn't to be trusted as an accurate representation. If it's the "Mem Usage" value, you can prove this by minimizing Winamp to the taskbar/systray, and you'll now see that Task Mgr mem usage for winamp.exe goes waaaay down to almost minimal.

When I use those features, reported mem usage goes up to about 50-85mb.
But afterwards, if I minimize Winamp, it goes down to less than 10mb.

And yes, heavydawson, all of Winamp's online pages/features use Internet Explorer.

http://forums.winamp.com/showthread....d=161361#specs

What's your Windows OS and Internet Explorer version?
Are there any realtime security apps running (Internet Security, AV, antispyware, script/ad blockers, etc)?

Re: blank page in Now Playing when clicking 'More info' button

Hmm... this suggests either a serverside issue, or an IE problem...
I'm not rightly sure at the moment.
The new NowPlaying features are still undergoing some initial teething problems, so anything's possible...
DJ Egg is online now   Reply With Quote
Old 10th July 2008, 14:13   #5
heavydawson
Junior Member
 
Join Date: Dec 2005
Location: Ireland
Posts: 25
@DJ EGG
I use Process Explorer to determine the mem usage (Specifically I use the Private Bytes figure, not the Working Set)
At the moment I see 197 MB after opening and switching between some of the online services. However, if I restart Winamp, I'm looking at around 71MB. I'm running Win XP Pro SP3 with Mcafee Viruscan Corporate 8.0i.
I've got a couple of Spyware apps - Spyware Blaster, Spybot S&D, Ad-aware 2008 and Windows Defender all running.
The hardward is a Core 2 Quad with 4 GB RAM.

***Did you see the mention of "More information on this artist" not working properly on my first post also. I think that's more of a bug than the memory issue. I reckon it has to do with the fact I'm in Ireland.
heavydawson is offline   Reply With Quote
Old 10th July 2008, 18:44   #6
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
This is an IE / COM issue. We release the IWebBrowser2 object right away, but for some reason it hangs around in memory for a few minutes more.
Benski is offline   Reply With Quote
Old 11th July 2008, 10:03   #7
heavydawson
Junior Member
 
Join Date: Dec 2005
Location: Ireland
Posts: 25
Quote:
Originally posted by DJ Egg
Hmm, I can't seem to reproduce the problem here.
Is it the "Mem Usage" column you're looking at, or "VM Size"?

Windows Task Manager isn't to be trusted as an accurate representation. If it's the "Mem Usage" value, you can prove this by minimizing Winamp to the taskbar/systray, and you'll now see that Task Mgr mem usage for winamp.exe goes waaaay down to almost minimal.

When I use those features, reported mem usage goes up to about 50-85mb.
But afterwards, if I minimize Winamp, it goes down to less than 10mb.

And yes, heavydawson, all of Winamp's online pages/features use Internet Explorer.

http://forums.winamp.com/showthread....d=161361#specs

What's your Windows OS and Internet Explorer version?
Are there any realtime security apps running (Internet Security, AV, antispyware, script/ad blockers, etc)?

Re: blank page in Now Playing when clicking 'More info' button

Hmm... this suggests either a serverside issue, or an IE problem...
I'm not rightly sure at the moment.
The new NowPlaying features are still undergoing some initial teething problems, so anything's possible...
@DJ egg,
The NowPlaying issue seems to be resolved. It started working yesterday evening for me on both machines I use. I'm trying to verify the memory is released as per Benskis comment. I'm just waiting to see how long it takes before it drops down to pre-online-feature-usage memory levels.

Also, for my own personal benefit, have you tried using Process Explorer as a memory measurement tool? Perhaps you or on of the devs could let me know if it's accurate? My understanding is also that Vista gives far more accurate memory readings than XP does.

And finally....has the super-secret Winamp dropbox feature got anything to do with this site?
http://www.getdropbox.com/

If it does, then consider me pretty excited about it. If not, then I'm just downright curious.
heavydawson is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump