Old 8th May 2007, 02:57   #1
theblazingangel
Junior Member
 
Join Date: Mar 2006
Posts: 29
$pluginsdir

i'm confused about the result i'm getting here:

i used the InitPluginsDir command in .OnInit, and then used the following code:
PHP Code:
Section "Installation"

    
SetOutPath $PLUGINSDIR

    File program
.exe
    File 
/r bin

    MessageBox MB_OK
|MB_ICONEXCLAMATION "plugindir: $PLUGINSDIR\\program.exe$\\r$\\ninstalldir: $INSTDIR\\program.exe"

SectionEnd 
for some reason this outputs:
plugindir: C:\DOCUME~1\username\LOCALS~1\Temp\nsg53.tmp\program.exe
installdir: C:\DOCUME~1\username\LOCALS~1\Temp\program.exe

no wonder ExecWait didn't work when i used $INSTDIR\program.exe

why the difference? :S

btw, this forum strips single back slashes from php tags but not the rest of the post, i had to double them up to get them to display!
theblazingangel is offline   Reply With Quote
Old 8th May 2007, 03:24   #2
Brummelchen
Major Dude
 
Join Date: May 2003
Posts: 681
SetOutPath sets $OUTDIR - not $INSTDIR

Greets, Brummelchen
Brummelchen is offline   Reply With Quote
Old 8th May 2007, 15:32   #3
theblazingangel
Junior Member
 
Join Date: Mar 2006
Posts: 29
damn it, now i feel stupid

cheers
theblazingangel is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump