Old 19th March 2009, 20:03   #1
Brute
Junior Member
 
Join Date: Feb 2009
Location: UK
Posts: 17
Stream freeze

I have been running a video stream for a few days now and have noticed that the stream seriously lags/freezes when changing episode? I am using SHOUTcast and .nsv files, if anyone can offer any assistance i would greatly appreciate it.

Cheers,

Brute
Brute is offline   Reply With Quote
Old 19th March 2009, 20:06   #2
Brutish Sailor
Major Dude
 
Brutish Sailor's Avatar
 
Join Date: Jan 2009
Location: San Diego CA
Posts: 998
Send a message via Skype™ to Brutish Sailor
http://forums.winamp.com/forumdispla...s=&forumid=152

try these forums, and great name by the way.

KNSJ.org 89.1 FM San Diego
Brutish Sailor is offline   Reply With Quote
Old 19th March 2009, 20:22   #3
Brute
Junior Member
 
Join Date: Feb 2009
Location: UK
Posts: 17
Quote:
Originally posted by Brutish Sailor
http://forums.winamp.com/forumdispla...s=&forumid=152

try these forums, and great name by the way.
Do you really think i didnt search?
Brute is offline   Reply With Quote
Old 19th March 2009, 20:50   #4
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
--> Moved to Shoutcast/NSV forum
dotme is offline   Reply With Quote
Old 19th March 2009, 20:53   #5
Brute
Junior Member
 
Join Date: Feb 2009
Location: UK
Posts: 17
Thanks
Brute is offline   Reply With Quote
Old 19th March 2009, 22:54   #6
sankt
Moderator
 
sankt's Avatar
 
Join Date: Apr 2003
Location: www.ScenicTelevision.com
Posts: 2,976
What codecs are you using ?

What are the specs for your computer ?

Scenic Television is your ambient window to the world - - www.ScenicTelevision.com
sankt is offline   Reply With Quote
Old 20th March 2009, 01:05   #7
Brute
Junior Member
 
Join Date: Feb 2009
Location: UK
Posts: 17
VP3 at approximatley 128kbps and mp3 at 64kbps

Quad core zeon, 4GB of RAM, 1TB hard drive array and a 1gbps line
Brute is offline   Reply With Quote
Old 20th March 2009, 01:46   #8
sankt
Moderator
 
sankt's Avatar
 
Join Date: Apr 2003
Location: www.ScenicTelevision.com
Posts: 2,976
Are you sourcing the NSV content on the same machine that the Shoutcast DNAS is on ?

Try making the sourcing a priority program, instead of a background one.

Scenic Television is your ambient window to the world - - www.ScenicTelevision.com
sankt is offline   Reply With Quote
Old 20th March 2009, 15:57   #9
Brute
Junior Member
 
Join Date: Feb 2009
Location: UK
Posts: 17
Quote:
Originally posted by sankt
Are you sourcing the NSV content on the same machine that the Shoutcast DNAS is on ?

Try making the sourcing a priority program, instead of a background one.
The SHOUTcast server and NSV content are located on the same machine. Is that done through a SHOUTcast/NSV setting or via setting affinity/priority through the OS?
Brute is offline   Reply With Quote
Old 20th March 2009, 23:04   #10
sankt
Moderator
 
sankt's Avatar
 
Join Date: Apr 2003
Location: www.ScenicTelevision.com
Posts: 2,976
Thats done on the operating system itself.

Scenic Television is your ambient window to the world - - www.ScenicTelevision.com
sankt is offline   Reply With Quote
Old 20th March 2009, 23:49   #11
Brute
Junior Member
 
Join Date: Feb 2009
Location: UK
Posts: 17
Quote:
Originally posted by sankt
Thats done on the operating system itself.
Its still doing it, the strem freezes at the end of an episode and then simply lags out and plays what it has in the buffer every minute or so. There arent any errors in either the NSV console nor the SHOUTcast console. I have no idea why its doing it?
Brute is offline   Reply With Quote
Old 21st March 2009, 18:12   #12
sankt
Moderator
 
sankt's Avatar
 
Join Date: Apr 2003
Location: www.ScenicTelevision.com
Posts: 2,976
Did you encode each NSV file exactly the same ?

Same audio bitrate, video bitrate etc ?

Scenic Television is your ambient window to the world - - www.ScenicTelevision.com
sankt is offline   Reply With Quote
Old 21st March 2009, 23:41   #13
Brute
Junior Member
 
Join Date: Feb 2009
Location: UK
Posts: 17
Quote:
Originally posted by sankt
Did you encode each NSV file exactly the same ?

Same audio bitrate, video bitrate etc ?
I encoded them all at the same time using the same profile in the NSV batch encoder
Brute is offline   Reply With Quote
Old 22nd March 2009, 00:58   #14
sankt
Moderator
 
sankt's Avatar
 
Join Date: Apr 2003
Location: www.ScenicTelevision.com
Posts: 2,976
I'm not sure what the problem is then.

Scenic Television is your ambient window to the world - - www.ScenicTelevision.com
sankt is offline   Reply With Quote
Old 22nd March 2009, 02:51   #15
Brute
Junior Member
 
Join Date: Feb 2009
Location: UK
Posts: 17
Quote:
Originally posted by sankt
I'm not sure what the problem is then.
Awesome ^^
Brute is offline   Reply With Quote
Old 27th March 2009, 22:44   #16
Brute
Junior Member
 
Join Date: Feb 2009
Location: UK
Posts: 17
The reason the stream is freezing at the end is because the beginning of the new episode seems to have an extremely high bitrate, like 600kbps, but after like 1min it falls to 150kbps like it should be.
Brute is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast TV / Nullsoft Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump