Old 14th May 2002, 11:20   #1
nj3h
Junior Member
 
Join Date: May 2002
Posts: 9
Built in Visualizations Problem

I need the help of some expert out there. Please respond here and to my email, which is nj3h@yahoo.com

All had been working fine, but one area is not working now. It used to!!!

I am referring to the built-in visualization. This is the “vertical bars” that move up and down while the music is playing and acts like a spectrum analyzer.

On mp3 files, no problem. On CD-audio or midi files, this no longer works. All I get is a horizontal line in the middle of the spectrum analyizer area.

There is a message for CD audio that says “be sure to set up your soundcard sampling input to the correct input source in order to have visualization.” Apparently, it is looking for 44khz 16 bit stereo.

What WINAMP displays for CD audio is 14H kbps and 44 khz. The music plays fine, but the sampling rate is not correct.

I do not know what 14H means.

How do you set up the soundcard CD sampling rate?

How do I get WINAMP to function properly again?

I have a Sager 2280 laptop with an SiS sound card in it, whatever that is, and am using Windows 98 as the operating system.

Also, I have turned on the checkboxes for visualization sampling in the input driver section for CD and Midi, but this has no affect.

Sincerely,
George Stein
Stephens City, VA USA
nj3h is offline   Reply With Quote
Old 14th May 2002, 11:28   #2
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,910
try CDReader
for cd support(this is a replacement plug-in)

works much nicer
(please remember to read the readme that comes with the installer)


read this for info on enabling vis for MIDI playback
Rocker is offline   Reply With Quote
Old 7th May 2019, 04:27   #3
jr3
Junior Member
 
Join Date: Sep 2006
Posts: 8
Quote:
Originally Posted by Rocker View Post
try CDReader
for cd support(this is a replacement plug-in)

works much nicer
(please remember to read the readme that comes with the installer)


read this for info on enabling vis for MIDI playback
Pulled from archive.org:

Quote:
Getting visualisation to work

If you are using some DirectMusic (*) software synth (Microsoft Synthesizer or Yamaha's Softsynth for DirectMusic), enable 'play through Winamp's output system' on output tab and everything should work fine.

Otherwise, you need to use sampling. You can enable it on output tab. After that, you need to configure device to record from, data source (usually "MIDI" or something), sampling format (higher quality = more CPU usage + better-looking VIS), etc.

It is recommended that you set one of those 'standard' formats (eg. 44100 Hz / stereo / 16-bit or 22050 Hz / mono / 8-bit), otherwise it probably won't work with your soundcard (or simply leave the default settings and don't change them).

Selecting source is usually the most troublemaking part. There should be something like 'MIDI' on the list; select it. If you can't find it, try playing with various settings. If no one of them works or signal is too weak, select 'default', then go to windows' volume control / options / properties, select recording and enable all controls, close properties window and try messing with settings (note: you can do that while playing MIDI - effects of changed settings will be visible immediately.)
It seems that on some systems you don't get any options under source if you set 'microsoft sound mapper' (or something like that) as recording device - if this happens, select your soundcard under device frist.



(*) Note that you must turn off "Disable DirectMusic support" option on DirectMusic tab and restart Winamp first. DirectMusic is now disabled by default because of poor quality of available drivers causing Winamp to crash on startup.
jr3 is offline   Reply With Quote
Old 7th May 2019, 04:48   #4
jr3
Junior Member
 
Join Date: Sep 2006
Posts: 8
(Incidentally, I still can't get it to work using Win 10 + CoolSoft VirtualMIDISynth, which allows you to use custom (amazing) SoundFonts. Fount the SoundFonts in this thread on the CoolSoft Forums: https://coolsoft.altervista.org/en/forum/thread/711
jr3 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Tags
midi, visualization

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump