Old 26th March 2013, 22:57   #1
MrX_1980
Senior Member
 
Join Date: Mar 2003
Location: Germany - NRW
Posts: 109
Send a message via ICQ to MrX_1980
Vorbis Decoder - arflac.ogg - Connecting...

Winamp -> open URL -> http://icecast-beta.timlradio.co.uk:8000/arflac.ogg = I get always "Connecting..."
VLC 2.0.6 is playing it without problems.

Codec: FLAC (Free Lossless Audio Codec) (flac)
Channels: Stereo
Sample rate: 44100 Hz
Bits per sample: 16

Bug in in_vorbis.dll v1.71 ?
Or is it because of .ogg instead of .flac ?
Attached Files
File Type: txt Winamp_Info_Report_27.03.2013.txt (17.3 KB, 107 views)
MrX_1980 is offline   Reply With Quote
Old 26th March 2013, 23:18   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's because of how the stream path is specified and how Winamp works. as it's seeing 'ogg' as the file type from the url and so tries to get in_vorbis to play it, whereas it should really have 'flac' in the url so that it could be sent to in_flac (if that had streaming support).
DrO is offline   Reply With Quote
Old 27th March 2013, 14:08   #3
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
I think it's probably Ogg FLAC. Such an abomination does exist. I'm hoping to add support for some of the other Ogg flavors (Ogg FLAC, Speex, Opus, Theora) but the technical details of the file format (and limitations of the Xiph libraries) make that extremely difficult and it's not currently at the top of the priority list.
Benski is offline   Reply With Quote
Old 27th March 2013, 14:10   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
got to love the OGG formats...
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump