Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Closed Thread
Thread Tools Search this Thread Display Modes
Old 16th September 2012, 19:03   #1
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Genre drop-down in the “File Info” window is NOT populating correctly for FLAC files

Winamp: 5.63 (Build 3235 FINAL_2012_0628_151026)
Language Pack: English
Skin: Big Bento

OS: Windows 7 (Service Pack 1) 64-bit
Locale: English US
CPU: Intel(R) Core(TM)2 Duo CPU T7700 @2 2.40 GHz 2.40 Ghz
Memory: 4GB RAM


The Genre drop-down in the “File Info” window is NOT populating correctly for FLAC files. It works as expected for MP3 files.

The issue is only with what value displays in the drop-down in the “File Info” window. The correct value displays in the Genre column of the Media Library.

It appears that all FLAC files have a value of “Rock” in the Genre drop-down, regardless of what is saved to the tags.

Can anyone else replicate this problem?
Attached Thumbnails
Click image for larger version

Name:	Genre in File Info window.jpg
Views:	278
Size:	167.2 KB
ID:	49888  
jph6t is offline  
Old 17th September 2012, 07:22   #2
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
Quote:
Originally Posted by jph6t View Post
The Genre drop-down in the “File Info” window is NOT populating correctly for FLAC files. It works as expected for MP3 files.

The issue is only with what value displays in the drop-down in the “File Info” window. The correct value displays in the Genre column of the Media Library.

It appears that all FLAC files have a value of “Rock” in the Genre drop-down, regardless of what is saved to the tags.

Can anyone else replicate this problem?
i can't. perhaps you have id3 tags or some other corruption in your FLACs? or are you using 3rd party codecs?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 17th September 2012, 21:30   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
is really going to need a small sample file - only thing i can think off (without looking at source code) is the genre may have a space or other whitespace character which is causing the automatic lookup to fail and it defaults to 'rock' for some reason. as the library just shows what is entered, it would look ok.

-daz
DrO is offline  
Old 18th September 2012, 02:59   #4
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
RE: Genre drop-down in the “File Info” window is NOT populating correctly for FLAC fi

Quote:
Originally Posted by DrO View Post
is really going to need a small sample file - only thing i can think off (without looking at source code) is the genre may have a space or other whitespace character which is causing the automatic lookup to fail and it defaults to 'rock' for some reason. as the library just shows what is entered, it would look ok.
So I wanted to test your theory a bit DrO. I have a mix of FLACs that I downloaded and ripped myself. It seemed odd to me that they all would have the same issue with the tags given their varied sources. Thus, I made sure to check a sampling that included both downloaded and ripped (using EAC) FLACs. All displayed "Rock" in the drop-down regardless of the actual value for the Genre tag (which is correctly displayed in both the Media Library (ML) and on the "File Info" window's "Advanced" tab).

So then I took my most recent FLAC (downloaded) and updated the Genre via the drop-down in Winamp. I changed it from 'Classic Rock' (displayed in the drop-down incorrectly as 'Rock') to 'Pop'. I clicked Ok, and the ML immediately updated to 'Pop' as expected. Then I went to the next FLAC, and the next, and the next ... they all now show 'Pop' in the drop-down regardless of what is actually saved to the tags and displaying in the ML.

It seems the drop-down is displaying whatever value was last used (instead of pulling the value from the selected FLAC).

Does this new angle on my bug report help?
Can anyone replicate this now?


If you need a small test FLAC file I can make you one. But it doesn't look like the forum accepts FLACs as attachments to posts.
What is the best way/site to get the file to you?
jph6t is offline  
Old 18th September 2012, 03:18   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
will give it a go on trying to replicate it that way some point tomorrow (as time allows) so no need to upload anything for the time being.

-daz
DrO is offline  
Old 18th September 2012, 05:58   #6
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
i just randomly checked a whole bunch of my FLACs. they all had the correct info. basic, advanced, ML etc. all correct.

i changed one to something else, basic still showed correct for it. checked a different file, basic still showed correct on the different file. changed the first one back, and you guessed it, basic still showed correct.

you didn't answer my questions though. and you should prob provide a plugin list.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 18th September 2012, 16:46   #7
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
RE: Genre drop-down in the “File Info” window is NOT populating correctly for FLAC fi

Quote:
Originally Posted by MrSinatra View Post
you didn't answer my questions though.
Which question MrSinatra? On whether I'm using third party codecs?

A = Yes, I guess I am. None of my FLACs have been created through Winamp.
All have been created either through EAC (using the FLAC Frontend) or downloaded already encoded by someone else.
jph6t is offline  
Old 18th September 2012, 14:31   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
a plug-in list is unlikely to be of any use in this case. it's something to do with the loading of the artwork page impacting upon the main page. i've wasted 3hrs trying to find the cause and so far cannot determine anything specific other than disabling the artwork page completely or adding in a massive delay seems to resolve it.

the genre is correctly being read from the file and attempted to be set in the genre dropdown but it never seems to be displayed correctly (if i manually query the genre then it gives back the correct genre).

had initially thought it's down to the buttons jtfe hacks onto the dialog but that turned out not to be the case.

-daz
DrO is offline  
Old 18th September 2012, 16:52   #9
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
RE: Genre drop-down in the “File Info” window is NOT populating correctly for FLAC fi

Quote:
Originally Posted by DrO View Post
the genre is correctly being read from the file and attempted to be set in the genre dropdown but it never seems to be displayed correctly (if i manually query the genre then it gives back the correct genre).
Does this imply you were able to replicate the issue DrO?

Quote:
Originally Posted by DrO View Post
i've wasted 3hrs trying to find the cause and so far cannot determine anything specific other than disabling the artwork page completely or adding in a massive delay seems to resolve it.
Thank you for your help/time DrO
jph6t is offline  
Old 18th September 2012, 17:00   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
yes, i can reproduce something not being right but i cannot pin-point what or why the issue is happening. overall it means i've ended up spending 5hrs+ in the end with nothing to show for it (not happy as this had seemed like something simple otherwise i'd have not even attempted to look into it). so yes i can replicate some weirdness through i'm now not sure if i'm working with a dodgy compile as none of the genre saving is working for me now (so i'm going to have to find some time at a later date to re-build my compiles and try again).

and with that, i'm now going to try to do my actual job.


and where / how the files have been created doesn't seem to make any difference as mine were done through Winamp with artwork associated with them. the best i can tell is there's some sort of memory corruption going on but because _most_ of the things are working when actually checked, it's probably something dumb somewhere that i cannot see for the time being.

-daz
DrO is offline  
Old 18th September 2012, 17:11   #11
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
DrO,

can you explain the artwork issue? does this issue only happen if artwork is embedded to the file? what do you mean disabling the artwork page? that tab?

jph6t,

the reason i asked about 3rd party codec is i recently had an issue with genres, and Aminifu was getting different genres on his machine from my files b/c of it. you can see here:

http://forums.winamp.com/showthread.php?t=346981

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 18th September 2012, 17:24   #12
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
RE: Genre drop-down in the “File Info” window is NOT populating correctly for FLAC fi

Quote:
Originally Posted by MrSinatra View Post
DrO,
does this issue only happen if artwork is embedded to the file? what do you mean disabling the artwork page? that tab?
Just as an FYI ... the FLACs that are causing me trouble.
None of them have artwork (either embedded OR stand-alone files in the same folder).
jph6t is offline  
Old 18th September 2012, 17:32   #13
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
Quote:
Originally Posted by jph6t View Post
Just as an FYI ... the FLACs that are causing me trouble.
None of them have artwork (either embedded OR stand-alone files in the same folder).
so strange, b/c i can't replicate.

btw, my Q about 3rd party codecs is for playback, not encoding. u can use 3rd party stuff to decode files. also, i still think u and DrO should compare plugin lists, b/c maybe a plugin is influencing things, although its good he has it narrowed down to the artwork tab.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 18th September 2012, 17:18   #14
DrO
 
Join Date: Sep 2003
Posts: 27,873
what i mean is if i prevent Winamp from even attempting to load the artwork tab (so there is no artwork tab) then it seemed to work reliably in the scenario shown. just having the dialog load without any of the code running on it still shows the issue mentioned which is really weird so i need to scrape my mind for anything like that happening before from my win32 days. which is why i'm wondering if there's something else weird going on but i don't have the time to further investigate it now (is no point if i'm not doing the work i'm meant to be doing - though would be fun to get sacked from the contract as then i could just walk away from Winamp and not about crap like this).

-daz
DrO is offline  
Old 18th September 2012, 17:38   #15
DrO
 
Join Date: Sep 2003
Posts: 27,873
i don't think the artwork tab is the cause and if this is a memory corruption from somewhere then based on the wasted time, it's likely a white elephant in the room. i am trying to convey that what is going on here is not a simple and in all honesty at the moment i don't feel compelled to look into it any further in the coming weeks.

and it doesn't seem to be just FLAC as i'm seeing crap with the ID3v1 genre list. comparing plug-ins is not going to be any use as i'm getting this with no extra plug-ins (even with jtfe disabled).

-daz
DrO is offline  
Old 19th September 2012, 18:15   #16
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Nothing to add at this point. Just interested in this discussion, and I don't know how to bookmark threads, or otherwise easily keep track of those I don't have a post in.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline  
Old 20th September 2012, 20:46   #17
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Quote:
Originally Posted by Aminifu View Post
Nothing to add at this point. Just interested in this discussion, and I don't know how to bookmark threads, or otherwise easily keep track of those I don't have a post in.
In the future, just click "Subscribe to this Thread" under "Thread Tools" in the bottom-left of the page.
jph6t is offline  
Old 2nd May 2013, 16:45   #18
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
jph6t,

do you see the issue with lossless m4a (alac) files?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 4th May 2013, 16:42   #19
DrO
 
Join Date: Sep 2003
Posts: 27,873
i've tried to replicate this again against the current internal build and i'm not seeing the issue anymore though i've a suspicion it'll probably still be present in the next public build (only r-tried now as we fixed a few minor memory issues between 3367 and the current internal build which may or may not [more likely] be related to this issue).

as there's no reason for it to be happening but as i cannot replicate anymore and couldn't find a cause let alone a solution when i was able to replicate, i can only assume some sort of weird memory corruption / caching going on.
DrO is offline  
Old 9th May 2013, 07:39   #20
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Quote:
Originally Posted by DrO View Post
i've tried to replicate this again against the current internal build and i'm not seeing the issue anymore though i've a suspicion it'll probably still be present in the next public build (only r-tried now as we fixed a few minor memory issues between 3367 and the current internal build which may or may not [more likely] be related to this issue).

as there's no reason for it to be happening but as i cannot replicate anymore and couldn't find a cause let alone a solution when i was able to replicate, i can only assume some sort of weird memory corruption / caching going on.
I just installed Winamp 5.8 Beta 6, build 3381

I'm still having the same issue as before.

For FLAC files, the Genre drop-down in the "File Info" window is displaying whatever value was last written to a file (instead of pulling the value from the selected FLAC). The correct value displays in the ML. It's only on the "Basic Info" tab of the "File Info" that it displays incorrectly ... and only for FLAC files. On mp3 files everything works as expected.
jph6t is offline  
Old 5th May 2013, 16:12   #21
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
I still wonder if there are id3 tags in the FLACs. that's always a thorny issue, b/c sometimes even mp3tag won't report such a state.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 5th May 2013, 16:29   #22
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Quote:
Originally Posted by MrSinatra View Post
I still wonder if there are id3 tags in the FLACs. that's always a thorny issue, b/c sometimes even mp3tag won't report such a state.
Then how do you check for that?

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline  
Old 5th May 2013, 17:50   #23
Batter Pudding
Major Dude
 
Batter Pudding's Avatar
 
Join Date: Jun 2008
Posts: 1,665
Quote:
Originally Posted by Aminifu View Post
Then how do you check for that?
The only 100% reliable method for checking for bad tags would be a HEX Editor and a copy of the relevant specs. In the chase for perfection it won't take too long to learn manual decodes of data. This would also allow manual correction. Though may be trickier working with the embedded images in those cases. This is pretty easy to do. I have read whole SQL Databases this way when rescuing corrupted (or "deleted") files. Just takes patience.
Batter Pudding is offline  
Old 5th May 2013, 18:08   #24
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Quote:
Originally Posted by Batter Pudding View Post
The only 100% reliable method for checking for bad tags would be a HEX Editor and a copy of the relevant specs.
Way back in another life, when I was coding in assembly, a HEX editor was my best friend.

Anyway I have not exprienced the genre box error with the few flacs I have. I have seen it for a long time with the ID3 v1 tab. Hopefully the next release will fix it. But if not, oh well. Dealing with it has become routine for me.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline  
Old 5th May 2013, 18:10   #25
Batter Pudding
Major Dude
 
Batter Pudding's Avatar
 
Join Date: Jun 2008
Posts: 1,665
Quote:
Originally Posted by Aminifu View Post
Way back in another life, when I was coding in assembly, a HEX editor was my best friend.
Everyone should be forced to work in Z80.
Batter Pudding is offline  
Old 5th May 2013, 18:38   #26
DrO
 
Join Date: Sep 2003
Posts: 27,873
and everyone should be free to use the format that best matches _their_ needs rather than being shoe-horned into format x by others who it may be better for them, but not for others *shrugs*

Quote:
Originally Posted by Aminifu View Post
I have seen it for a long time with the ID3 v1 tab. Hopefully the next release will fix it. But if not, oh well. Dealing with it has become routine for me.
have you mentioned this before? what's the specific steps to replicate? and what exactly isn't seemingly working correctly? i.e. is the value going into the tag then wrong or is this just a visual issue (assuming it's a genre that can be mapped to a v1 genre value if dealing with id3v2.x tags on the file as well).
DrO is offline  
Old 5th May 2013, 16:30   #27
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
S.box server can report such a state. not sure what else does so reliably.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 5th May 2013, 16:44   #28
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Quote:
Originally Posted by MrSinatra View Post
S.box server can report such a state. not sure what else does so reliably.
My choice of WavPack for a lossless format is looking better and better.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline  
Old 5th May 2013, 17:50   #29
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
Quote:
Originally Posted by Aminifu View Post
My choice of WavPack for a lossless format is looking better and better.
not if you care about being able to use your files on a broad array of products and software with no effort on your part. and id3 is a legacy standard that has limitations, and like any of these choices has its own set of pros and cons, as the genre issues between v1 and v2 demonstrate.

the whole reason I am converting from FLAC to m4a (alac) is to increase their universal usability, which to me, is the most important aspect of a filetype format.

as to the id3 in a FLAC issue, it could happen to any format. software that allows id3 to be hacked into a FLAC, (which unfortunately EAC can do), is just behaving badly, its a hack. to be clear, I think that mp3tag can show id3v2 in a flac, but not v1, or maybe vice versa... I forget. I have been able to avoid the issue altogether by being aware of it.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 5th May 2013, 18:03   #30
Batter Pudding
Major Dude
 
Batter Pudding's Avatar
 
Join Date: Jun 2008
Posts: 1,665
Quote:
Originally Posted by MrSinatra View Post
not if you care about being able to use your files on a broad array of products and software with no effort on your part.
That made me laugh. ALAC is an Apple Lock-in scam. Trying to convert everyone over to the "The Apple Way".

That is not a standard, that is an attempt at dominance of the market. Making it "open source" is not enough. If Apple were really about the "community" and "openness" then they would have moved to FLAC like many others are now doing. (See any modern phone - Androids, Blackberrys, etc.... anything that isn't an Apple)

ANYTHING connected with that mess that is iTunes and Quicktime needs to be shot at birth as a horrendous insult to humanity.

Surely, if you want something that plays on a wider array of devices you should be picking Microsoft's WMA Lossless? WMA is supported way wider than ALAC. And even a basic skim of the Wiki article shows FLAC supported on many more different types of devices than ALAC.

Or are you just counting up how many devices Apple have sold and calling that a "broad array"?
Batter Pudding is offline  
Old 5th May 2013, 23:42   #31
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
Quote:
Originally Posted by Batter Pudding View Post
That made me laugh. ALAC is an Apple Lock-in scam. Trying to convert everyone over to the "The Apple Way".

That is not a standard, that is an attempt at dominance of the market. Making it "open source" is not enough. If Apple were really about the "community" and "openness" then they would have moved to FLAC like many others are now doing. (See any modern phone - Androids, Blackberrys, etc.... anything that isn't an Apple)

ANYTHING connected with that mess that is iTunes and Quicktime needs to be shot at birth as a horrendous insult to humanity.

Surely, if you want something that plays on a wider array of devices you should be picking Microsoft's WMA Lossless? WMA is supported way wider than ALAC. And even a basic skim of the Wiki article shows FLAC supported on many more different types of devices than ALAC.

Or are you just counting up how many devices Apple have sold and calling that a "broad array"?
umm, lets get a grip, shall we?

I use mp3 for lossy, nearly everything in the world uses that. so, no argument there, yes?

I used FLAC for lossless. it made sense at the time, b/c it was the best codec given a variety of factors, including how it technically works, tagging, and especially universality.

but now that apple has made ALAC freely available, its just a matter of time until everything supports it. most important to me is that winamp now supports it, AND iTunes / idevices do. istuff was never going to support FLAC, or WMA for that matter.

so, for my purposes, it is the best solution. nothing else lossless that I know of would just easily and natively work with both winamp and istuff. and again, over time, alac will become nearly as universal as FLAC.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 5th May 2013, 18:39   #32
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Quote:
Originally Posted by MrSinatra View Post
not if you care about being able to use your files on a broad array of products and software with no effort on your part.
TBH, I'm mostly care about the products and software that I use. Also a little effort is good for the mind, body, and soul.

I maintain a passing interest in Apple stuff to sometimes assist a few close friends (whom have bought into the Apple hype) with their issues.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline  
Old 5th May 2013, 16:49   #33
DrO
 
Join Date: Sep 2003
Posts: 27,873
i doubt it's anything to do with combined tags on files as i re-used the same files i had seen the issue with which 100% only have the vorbis tag on them (seeing as they were ripped specifically to test the issue). and we don't process ID3 tags on flac files even if they were present.
DrO is offline  
Old 5th May 2013, 18:46   #34
DrO
 
Join Date: Sep 2003
Posts: 27,873
that's fine, got a tonne of other things already to work on at the moment before attempting to look into it.
DrO is offline  
Old 6th May 2013, 14:16   #35
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Quote:
Originally Posted by DrO View Post
that's fine, got a tonne of other things already to work on at the moment before attempting to look into it.
The first link in MrSinatra's post #35 is the thread where we discussed the genre box issue in the Alt+3 editor's ID3v1 tab. I would have sworn it was more than 4 months ago.

Your response then is basically the same as now, i.e. cause unknown. So I'm eager to see if what you said in post #19 (above) changes anything.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline  
Old 6th May 2013, 14:21   #36
DrO
 
Join Date: Sep 2003
Posts: 27,873
k, will see if i can squeeze in some time to look into it again, though at the moment i cannot promise a solution (especially if based on how things have gone with this that i can no longer replicate the issue).
DrO is offline  
Old 9th May 2013, 06:28   #37
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
but what about when what you specify in basic or v2 is a value OTHER THAN one of the finite existing v1 values?

in other words, I would expect "blues" and "easy listening" to be in the v1 values, meaning codes exist for those. what happens when you specify something in basic or v2 that has no equal in v1? that's what I was talking about.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 9th May 2013, 14:02   #38
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Quote:
Originally Posted by MrSinatra View Post
but what about when what you specify in basic or v2 is a value OTHER THAN one of the finite existing v1 values?

in other words, I would expect "blues" and "easy listening" to be in the v1 values, meaning codes exist for those. what happens when you specify something in basic or v2 that has no equal in v1? that's what I was talking about.
What has this to do with the visual discrepancy issue?

You could test that yourself and see what happens. I mentioned before I usually don't go looking for trouble. For the ID3v1 genre, I always use something from the provided listing. I sometimes use a custom value for the v2 genre. For example, I use "RnB" for v2 and "R&B" for v1 (that does not change the visual discrepancy problem).

If you want to discuss this (mp3 ID3v1 genre tag display issue) further, I suggest we use my thread and leave this one for the flac genre display issue.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline  
Old 9th May 2013, 14:44   #39
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,624
Send a message via AIM to MrSinatra
Quote:
Originally Posted by Aminifu View Post
What has this to do with the visual discrepancy issue?
you need to test it to find out.

Quote:
Originally Posted by Aminifu View Post
You could test that yourself and see what happens.
and what makes you think I haven't? the whole point of msg boards is to share info though, but in bug testing you don't want to influence someone elses results with your own, until AFTER they test.

Quote:
Originally Posted by Aminifu View Post
I mentioned before I usually don't go looking for trouble. For the ID3v1 genre, I always use something from the provided listing. I sometimes use a custom value for the v2 genre. For example, I use "RnB" for v2 and "R&B" for v1 (that does not change the visual discrepancy problem).
looking for trouble has nothing to do with it. sometimes when you do something unexpected you find out things. and in this case its not unexpected in the marketplace sense, lots of people use both tags while also using any value they want for Genre.

given that, it was reasonable to ask what the behavior of winamp was under such a scenario. how instructive it ends up being or not is another matter, but u don't know until you do it.

Quote:
Originally Posted by Aminifu View Post
If you want to discuss this (mp3 ID3v1 genre tag display issue) further, I suggest we use my thread and leave this one for the flac genre display issue.
fine with me, although you injected it into this thread, and it seems from DrO's posts the two issues are related, (to some degree).

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline  
Old 9th May 2013, 16:22   #40
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Quote:
Originally Posted by MrSinatra View Post
fine with me, although you injected it into this thread, and it seems from DrO's posts the two issues are related, (to some degree).
I added that I'm seeing the same thing (visual discrepancy) with the mp3 ID3v1 genre tag dialog that jph6t is seeing with his flacs in another part of the Alt+3 editor. You injected the side questions, which may or may not be related to the visual discrepancy. I also added a few OT comments related to a couple other posts in this thread (sorry, jph6t).

I'm willing to do whatever tests that I think are directly related to my issues, especially if a dev suggests them. I'm willing to do the same thing for the issues of others that I chose to get involved in.

I realize I could be wrong in what I think is directly related (but I trust my background and experience just like you do yours). I can live with being wrong from time to time. I need to draw a line somewhere, as I don't wish to spend the time doing anything and everything.

So I'm not so willing to go on 'witch hunts' looking for what may happen. As things come up, I deal with them as directly as I can. If you like doing these general tests that you think could be related, that's fine with me. The fact that you don't want to share your results until someone else does the same test and shares their results is not very helpful, imo. But, that's fine with me too.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump