Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 17th February 2011, 04:35   #1
Crogge
Junior Member
 
Join Date: Feb 2011
Posts: 2
Radio is working just fine but not appearing in the public list

Dear Shoutcast community,

I planned to revive my webradio and installed the required software this night. I tested DNAS 2.0 (Using a valid key) and DNAS 1.9.8 (Stable).

Both servers are working fine as they should, the only problem is that both aren't listed in the Shoutcast directory.

The log of 2.0 Beta shows only the following:

Quote:
2011-02-17 05:32:27 I msg:[YP2] Connecting to yp.shoutcast.com
2011-02-17 05:32:27 E msg:[dst 64.12.243.204:47074 sid=1] SHOUTcast 1 client connection rejected. Stream not available. SHOUTcast Directory Tester
2011-02-17 05:32:27 I msg:[dst 64.12.243.204:47074 sid=1] SHOUTcast 1 client connection closed (0 seconds) [Bytes: 0] Agent: `SHOUTcast Directory Tester'
2011-02-17 05:32:38 I msg:[YP2] Connecting to yp.shoutcast.com
2011-02-17 05:35:23 I msg:[YP2] Connecting to yp.shoutcast.com
Related config:
Quote:
yp2=1
ypaddr=yp.shoutcast.com
ypport=80
yppath=/yp2
streamauthhash=(My key which I got from Shoutcast)
The log of 1.9.7 says the following (Which looks quite ok):

Quote:
<02/17/11@05:43:28> [dest: 64.12.243.203] starting stream (UID: 0)[L: 1]{A: SHOUTcast Directory Tester}(P: 0)
<02/17/11@05:43:28> [dest: 64.12.243.203] connection closed (0 seconds) (UID: 0)[L: 0]{Bytes: 14345}(P: 0)
<02/17/11@05:43:28> [yp_add] yp.shoutcast.com added me successfully
Do I have to open any additional ports to get listed on the Shoutcast directory or am I doing anything wrong?
Crogge is offline   Reply With Quote
Old 17th February 2011, 09:32   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
make sure you're running Build 14 of the v2 DNAS as that will show more information about what the YP attempts are doing (without having to enable debug logging).

-daz
DrO is offline   Reply With Quote
Old 18th February 2011, 01:04   #3
Crogge
Junior Member
 
Join Date: Feb 2011
Posts: 2
I tested build 14 today with the following result:

Quote:
2011-02-18 01:59:17 I msg:[YP2] Connecting to yp.shoutcast.com
2011-02-18 01:59:17 E msg:[DST 64.12.243.206:57093 sid=1] SHOUTcast 1 client connection rejected. Stream not available. SHOUTcast Directory Tester
2011-02-18 01:59:17 I msg:[DST 64.12.243.206:57093 sid=1] SHOUTcast 1 client connection closed (0 seconds) [Bytes: 0] Agent: `SHOUTcast Directory Tester'
2011-02-18 01:59:18 I msg:[YP2] Connected to yp.shoutcast.com. The station should now be listed in the SHOUTcast Radio Directory (YP).
2011-02-18 01:59:50 E msg:[SRC 109.192.159.143:61551 sid=1] [SRC 109.192.159.143:61551 sid=1] Remote socket closed while waiting for data
2011-02-18 01:59:50 E msg:[SRC 109.192.159.143:61551 sid=1] Remote socket closed while waiting for data
2011-02-18 01:59:50 I msg:[YP2] Connecting to yp.shoutcast.com
2011-02-18 01:59:50 I msg:[SRC 109.192.159.143:61556] SHOUTcast 2 source connection.
2011-02-18 01:59:50 I msg:[SRC 109.192.159.143:61556] password accepted. Stream id is 1
2011-02-18 01:59:50 I msg:[YP2] Disconnected from yp.shoutcast.com. The station should now be de-listed from the SHOUTcast Radio Directory (YP).
2011-02-18 01:59:51 I msg:[SRC 109.192.159.143:61556 sid=1] stream configuration complete. [
type=SHOUTcast 2
mimeType=audio/mpeg
maxPayloadSize=16377
avgBitrate=128000
maxBitrate=128000
desiredBufferSize=320
minimumBufferSize=0
icyName=CroggesServer
icyGenre=alternative
icyURL=http://www.CroggesServer.com
icyPub=1
2011-02-18 01:59:51 E msg:[DST 64.12.243.203:38402 sid=1] SHOUTcast 1 client connection rejected. Stream not available. SHOUTcast Directory Tester
2011-02-18 01:59:51 I msg:[DST 64.12.243.203:38402 sid=1] SHOUTcast 1 client connection closed (0 seconds) [Bytes: 0] Agent: `SHOUTcast Directory Tester'
2011-02-18 01:59:51 I msg:[YP2] Connected to yp.shoutcast.com. The station should now be listed in the SHOUTcast Radio Directory (YP).
2011-02-18 02:00:07 I msg:[YP2] Connecting to yp.shoutcast.com
...
It works sometimes now but its not appearing always

The ID in the Shoutcast directory is "1585245", the radio URL "Masterroot.de:8000" (Not always online until the issue has been fixed). I noticed that the web interface is not always working as it should, in the logs it says...

Quote:
2011-02-18 02:10:52 I msg:[YP2] Connecting to yp.shoutcast.com
2011-02-18 02:10:57 I msg:[DST 109.192.159.143:64014 sid=1] SHOUTcast 1 client connection accepted. Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
2011-02-18 02:10:59 E msg:[DST 109.192.159.143:64014 sid=1] Socket error while waiting to send data. err=Broken pipe(32)
2011-02-18 02:10:59 I msg:[DST 109.192.159.143:64014 sid=1] SHOUTcast 1 client connection closed (2 seconds) [Bytes: 253287] Agent: `Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3'
2011-02-18 02:11:07 I msg:[YP2] Connecting to yp.shoutcast.com

Edit: I noticed that I see it in the media library of Winamp but it's not appearing on Shoutcast.com oO! Is that a software issue Shoutcast itself?
Crogge is offline   Reply With Quote
Old 22nd February 2011, 14:14   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
from the first few logs it looks about ok especially the error lines which are normally when the DNAS is being checked by the YP (relating to the 'SHOUTcast Directory Tester' as you then get listing messages.

however, it can take a while for stations to appear in the directory listing which possibly explains the difference between the main site and the Winamp view as that might be querying some of the apis directly instead of caching as the site might (though i'm probably wrong on that).

with the last log, it seems like there's something wrong with the connection attempt being made by the FF 3.6.3 install which would make that appear to not work when tested, otherwise i cannot see anything wrong with the log contents.

btw, build 17 is now the current version at the time of this reply (was released a few hours after my prior post).

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
crogge, directory, listing, shoutcast

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump