Old 12th November 2013, 10:59   #1
Olgaarog
Junior Member
 
Join Date: Dec 2012
Posts: 13
Shoutcast Relay and Different Bitrate strem "Problem"

Hello everybody,
I took a dissertations for broadcasting audio το Shoutcast, And i have to bring all the technique used.

So far I managed to broadcast a stream.
Firstly,
I want to show how a stream transmits in different bitrate.
I did it with Winamp, using two outputs with different bitrate in the same port,
in Shoutcast status i can see Stream1 and stream 2 and in my site i write "iport/stream/1" and "iport/stream/2" but i can listen only the first stream.
What other can i do?

Secondly,
When a listener choosing to listen a stream, i want to hear my stream and when i go away , and i would like to relay othen stream in my streamid_1=1. How can i do this?
This can be done with sc_tranc or something like this here:

In configuration file i wrote:

publicserver=never
password=pas
adminpassword=pas2
streamid_1=1
streampath_1=/test.aac
streamid_2=2
streampath_2=/relay
streamrelayurl=http://otheriport/
allowrelay=1

It's not work for stream2 to relay other stream.
Please help me
Olgaarog is offline   Reply With Quote
Old 12th November 2013, 11:16   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
try using the v2.2 DNAS as v2.0 had bugs with the streampath handling in exactly the manner you're trying to do.
DrO is offline   Reply With Quote
Old 12th November 2013, 11:22   #3
Olgaarog
Junior Member
 
Join Date: Dec 2012
Posts: 13
Do you know what can i do to relay a stream.?
Im dificult to understant the transcoder.
Olgaarog is offline   Reply With Quote
Old 12th November 2013, 11:27   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
sc_trans can do it but it's not built to be as easy to configure as it should be so you may have to look for a paid solution instead to achieve that aspect (or read the docs and look at the example config which show how to setup a relay).
DrO is offline   Reply With Quote
Old 12th November 2013, 11:59   #5
Olgaarog
Junior Member
 
Join Date: Dec 2012
Posts: 13
Stream1 and Stream 2

In my browser when i write http://127.0.0.1:8000/stream/1 -> appear my first stream
when i write http://127.0.0.1:8000/stream/2 -> appear my second stream

In my site , in my shoutcast player, i write http://127.0.0.1:8000/stream/1 and i can hean my first stream and when i write http://127.0.0.1:8000/stream/2 , i can not listen something.


For Relay, in configuration file:
streamid_2=2
streampath_2=/relay
streamrelayurl_2=http://otheiport/

but the realy appeard in my first stream, WHY?
Olgaarog is offline   Reply With Quote
Old 12th November 2013, 12:13   #6
Olgaarog
Junior Member
 
Join Date: Dec 2012
Posts: 13
RELAY
in sc_serv i writed :
streamid_2=2
streampath_2=/relay
streamrelayurl=http://otheriport/
but it appears in my stream_1, and i want in my stream2
why?

The most important is:
In website, in the shoutcast player i write 127.0.0.1:8000/steam/1 and its ok
but when i write 127.0.0.1:8000/steam/2 i cant listen the second stream.
E.g i did it before i write for relay.

What else can i do?
Olgaarog is offline   Reply With Quote
Old 12th November 2013, 12:23   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
as i said, you need to be using v2.2 of the DNAS.
DrO is offline   Reply With Quote
Old 12th November 2013, 12:25   #8
Olgaarog
Junior Member
 
Join Date: Dec 2012
Posts: 13
With v2.0 i couldnt relay , but i intalled the V.2.2 and i manage to relay bu and i have the problems before,

:/
Olgaarog is offline   Reply With Quote
Old 12th November 2013, 12:28   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
pm me the complete configuration file (you can remove the passwords from it) and i'll check it out. also what OS version are you using ?
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump