Old 26th March 2015, 02:53   #1
darkstrike
Junior Member
 
Join Date: Feb 2009
Posts: 9
Cover.jpg not working in Winamp?

Hi all,

Recently, I've had a few albums not properly display their cover.jpg files from their directory when playing them in Winamp. I store all my music this way: C:\Music\Artist\Album\ and have a cover.jpg file in each album folder as appropriate.

The albums in question have no embedded cover image (I deleted them all) and all do have a proper cover.jpg file in their respective album folders, yet I get the "No cover image" error in the Album Art viewer built into Winamp for all of each album's songs. Strangely though, the Media Library DOES display the cover art when viewing these albums no problem.....any ideas as to what is going on...?

I have the latest version of Winamp (5.666) running the Drone_v1 skin. I've tried renaming the cover.jpg files to front.jpg or some of the other options, but the same thing happens.

Any help / suggestions would be appreciated!
darkstrike is offline   Reply With Quote
Old 26th March 2015, 10:26   #2
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,650
Send a message via AIM to MrSinatra
Quote:
Originally Posted by darkstrike View Post
yet I get the "No cover image" error in the Album Art viewer built into Winamp for all of each album's songs. Strangely though, the Media Library DOES display the cover art when viewing these albums no problem
you need to expound further, where does it work exactly, and where doesn't it work exactly?

also, have you tried renaming the file to Folder.jpg to see if that works? and / or used a utility to see if the extension is proper? (sometimes a gif has a jpg extension, etc)

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 26th March 2015, 10:40   #3
darkstrike
Junior Member
 
Join Date: Feb 2009
Posts: 9
Hi,

Yes, I have tried renaming it to folder.jpg, as well as all of the other naming options for non-embedded album covers. I have gone online and completely redownloaded the covers from different websites, so I know they are the proper extensions.

I'm not sure what you mean by this - "you need to expound further, where does it work exactly, and where doesn't it work exactly?" - The album covers show up in the Media Library for all songs in each of these albums, they do NOT show up in the Album Art viewer while a song is playing or on the pop-up on screen when Winamp switches to a new song from any of these albums....I don't know where else to talk about...? If I click on view file info, the files all do show the proper Album Art in the file info under the Album Art tab, and say the proper resolution, file name and type. Aren't those the only four places in Winamp that album art is visible?

I've even tried saving the files as Bitmaps, then re-saving them from the Bitmaps as jpgs again to no avail...
darkstrike is offline   Reply With Quote
Old 26th March 2015, 10:45   #4
ryerman
Major Dude
 
ryerman's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 699
Quote:
Originally Posted by darkstrike View Post
Any help / suggestions would be appreciated!
Try switching to a native skin, like Bento.

Windows 10 Home, 64 bit, Winamp 5.666, Bento Skin
ryerman is offline   Reply With Quote
Old 26th March 2015, 10:52   #5
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,650
Send a message via AIM to MrSinatra
Quote:
Originally Posted by darkstrike View Post
I'm not sure what you mean by this - "you need to expound further, where does it work exactly, and where doesn't it work exactly?" - The album covers show up in the Media Library for all songs in each of these albums,
like ryerman said, r u in Bento or what? when you say ML, I may think somewhere else than you, so u prob should show it via screenshot.

Quote:
Originally Posted by darkstrike View Post
they do NOT show up in the Album Art viewer while a song is playing or on the pop-up on screen when Winamp switches to a new song from any of these albums....I don't know where else to talk about...?
even more true for this. I don't know where u mean, or to put it another way, I don't want to assume. screenshot would be best.

Quote:
Originally Posted by darkstrike View Post
If I click on view file info, the files all do show the proper Album Art in the file info under the Album Art tab, and say the proper resolution, file name and type. Aren't those the only four places in Winamp that album art is visible?
I do understand this. its good they work in show file info.

you might want to post some example files. are they huge sizes?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 26th March 2015, 11:10   #6
darkstrike
Junior Member
 
Join Date: Feb 2009
Posts: 9
Switching to Bento seems to solve the problem, as they DO show up there everywhere.

As I mentioned in my first post, I am running the Drone_v1 skin - album art works flawlessly in it for all my other albums - I'm not a fan of Bento's integrated design, as I can reposition parts of Drone to different parts of my screen and much prefer it's button layout and color choices, so it's possibly a problem with Drone. I would just hate to have to switch to another skin other than Drone as I've used Drone for years (since probably 2009) and am quite accustomed to it!

I've attached a screenshot of the media library (medialibrary.jpg) - two of the albums in question are the one showing art for the "FREE MEGA-ALBUM" and "It's Freaking Christmas" - the album art shows up in the Media Library for them here, and in their songs' respective File Info pages, but not in the popup when the player switches songs, nor in Drone's Cover Art viewer.

The second screenshot (coverartviewer.jpg) shows what happens in the cover art viewer function of Drone with any of these albums' songs, it just gives a "No Cover Art" error.

Third screenshot (songpopup.jpg) shows the song change notification with no album art being displayed.

The fourth screenshot (fileinfo.jpg) shows the File Info tab for one of the songs from one of the albums.

The fifth screenshot (right.jpg) is what things are SUPPOSED to look like on the song popup and cover art viewer when the cover art is working properly.

It just confuses me as all my other albums work fine, but not these. I've downloaded other albums in between these and they work fine as well, just not these for some reason...

File resolutions for these album art files were originally high-res, like 1000x1000, 1300x1300, however, I thought size might be an issue and downsized some of them - same problem (even though I have other songs with 1000x1000 or so res covers displaying properly).
Attached Thumbnails
Click image for larger version

Name:	medialibrary.jpg
Views:	115
Size:	459.5 KB
ID:	51753   Click image for larger version

Name:	coverartviewer.jpg
Views:	107
Size:	427.1 KB
ID:	51754   Click image for larger version

Name:	songpopup.jpg
Views:	89
Size:	427.3 KB
ID:	51755   Click image for larger version

Name:	fileinfo.jpg
Views:	92
Size:	384.6 KB
ID:	51756   Click image for larger version

Name:	right.jpg
Views:	92
Size:	454.1 KB
ID:	51757  

darkstrike is offline   Reply With Quote
Old 26th March 2015, 11:21   #7
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,650
Send a message via AIM to MrSinatra
I assume at this point, the problem is with your skin, Drone, but it will take a dev to say for sure.

also, there are other characteristics to jpgs besides resolution, such as filesize, compression ratio, etc... I am guessing something about the "bad" ones is different from the good ones, and explains the behavior.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 26th March 2015, 11:25   #8
darkstrike
Junior Member
 
Join Date: Feb 2009
Posts: 9
Well, I've downloaded completely different versions of the covers from different sites that are different resolutions, so I would assume they would be different enough to show up if it was something with those specific cover files.
darkstrike is offline   Reply With Quote
Old 26th March 2015, 11:27   #9
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,650
Send a message via AIM to MrSinatra
well, that is bizarre. what happens when u put a copy of a known good artwork in there? does it show or no?

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 26th March 2015, 12:14   #10
darkstrike
Junior Member
 
Join Date: Feb 2009
Posts: 9
Copy-pasting a working cover.jpg from another folder works fine 0_o

Not sure what's going on, haha!
darkstrike is offline   Reply With Quote
Old 26th March 2015, 14:32   #11
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,650
Send a message via AIM to MrSinatra
I suspect that the bad ones, even when they are from differing sources or sizes or whatnot, all share some characteristic that drone doesn't like. no idea how to test it however.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump