Old 6th May 2012, 10:47   #1
vinlandQT
Junior Member
 
Join Date: Apr 2012
Posts: 5
Play .vob-files

I have a problem with playing .vob-files with winamp.
Before i ask: I know that the vlc-media player can play .vob... but why should i have so much software on my pc when winamp could do everything.

I searched a while and there is a way to play .vob:
To play mp4 video: Winamp is not set to faultless play mp4 video so what you do is go to preferences/plugins/input/mpeg-4 audio decoder select config and delete everything except "m4v". Then go to directshow decoder and select config, then add "MP4;M4V" so the direct show decoder should have "MPEG;MPG;M2V;AVI;MP4;M4V"
You can also set it to play Vob files. Dvd files. Just add ";vob" to the directshow decoder


But i don't have the mpeg-4 audio decoder plugin and can't find it in the winamp-browser :s
i installed ffdshow (someone in a forum said that should help), but i still can't play .vob-files with winamp.

What can i do to make winamp playing .vob-files?
I need it for a presentation next weekend And VLC crashes all the time on my teachers old pc >.<
vinlandQT is offline   Reply With Quote
Old 6th May 2012, 11:00   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,136
The MPEG-4 Audio Decoder (in_mp4.dll) was renamed to MP4 Demuxer quite some time ago....

However, it is irrelevant where VOB is concerned as VOB is an MPEG-2 video format.

All you should need to do is add ;VOB to the Extension List in the DirectShow Decoder (in_dshow) config.

If they still don't play, then we will need more info.

(Windows OS, Winamp version, MediaInfo log for one of the .vob files, dxdiag log, etc)

Also confirm that MPEG2 is set to libavcodec in ffdshow video decoder config....
DJ Egg is offline   Reply With Quote
Old 6th May 2012, 11:10   #3
vinlandQT
Junior Member
 
Join Date: Apr 2012
Posts: 5
Quote:
Originally Posted by DJ Egg View Post
All you should need to do is add ;VOB to the Extension List in the DirectShow Decoder (in_dshow) config.
I don't have (in_dshow) in my plugin-list. Where can i get it?
Sorry i'm a newbie.
Quote:
Originally Posted by DJ Egg View Post
Also confirm that MPEG2 is set to libavcodec in ffdshow video decoder config....
Thanks, did it.
vinlandQT is offline   Reply With Quote
Old 6th May 2012, 12:11   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,136
If the Nullsoft DirectShow Decoder (in_dshow.dll) isn't listed under Winamp > Prefs (Ctrl+P) > Plugins > Input,
then reinstall Winamp 5.623 and make sure "DirectShow Formats (MPG, M2V)" is checkmarked under the "Multimedia Engine > Video Playback" section on the Choose Components page of the Installer Options.
DJ Egg is offline   Reply With Quote
Old 6th May 2012, 13:52   #5
vinlandQT
Junior Member
 
Join Date: Apr 2012
Posts: 5
Thanks
Now i can hear the video, but i can't see anything
vinlandQT is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump