Old 21st June 2014, 21:20   #1
jimstrider
Junior Member
 
Join Date: May 2013
Posts: 5
MPG Video Listed in Audio Library, Not Video

Hello:

Using Winamp Pro 5.666, I added an MPG video file. Unfortunately, it appears in the Audio tab of the library rather than the video tab.

The MPG extension is configured in the "in_directshow.dll", along with AVI, which file type does appear properly in the video tab of the library.

I cannot find any other configuration point to correct this categorization problem.

Does anyone have advice on where I can configure Winamp to display MPG (mpeg) files in the video tab of the library?

Thanks!
jimstrider is offline   Reply With Quote
Old 23rd June 2014, 12:45   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
you really need to provide an info tool report (http://forums.winamp.com/showthread....161361#plugins) as in_directshow.dll is not a known plug-in (unless you're referring to in_dshow.dll ?).

as everything associated via in_dshow will be reported as video unless the file(s) are being determined to not have a video aspect in the file(s). so maybe the files are badly encoded or something else or you've got a different plug-in handling things which would also explain it.
DrO is offline   Reply With Quote
Old 24th June 2014, 05:47   #3
jimstrider
Junior Member
 
Join Date: May 2013
Posts: 5
Yes, I should have typed "in_dshow.dll"; the DirectShow dynamic link library.

FWIW, Winamp plays the video file just fine. It simply shows up in the wrong library tab, that is Audio, rather than Video.
jimstrider is offline   Reply With Quote
Old 24th June 2014, 10:59   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
then it's most likely it's being incorrectly reported by the file and ideally we could do with a small example file which shows the issue to try to use it to determine what is / isn't going on.
DrO is offline   Reply With Quote
Old 25th June 2014, 06:01   #5
jimstrider
Junior Member
 
Join Date: May 2013
Posts: 5
I guess that puts us in an awkward state. The file in question is 1.21GB. Not exactly small. Going to try converting to wmv and see if that gets filed properly. Thanks for your help.
jimstrider is offline   Reply With Quote
Old 26th June 2014, 05:47   #6
jimstrider
Junior Member
 
Join Date: May 2013
Posts: 5
The conversion to a wmv file enabled Winamp to integrate the video properly into the library's video tab.

Reply posted to benefit anyone else who might experience the same issue.

I do not know why the mpg version appeared in the audio tab instead of the video tab.
jimstrider is offline   Reply With Quote
Old 26th June 2014, 10:42   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
i think that seems to almost confirm my suspicion that the original file is not reporting it has video in it (why i don't know). maybe i should do something to add a force override option to ensure everything is treated as video, but will have to have a think / see if i can find anything which shows the same issue to track down if our existing handling is correct or not.
DrO is offline   Reply With Quote
Old 26th June 2014, 21:37   #8
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
One thing you could do is add your own Smartview and a series of if "FILENAME contains .mpg" or "FILENAME contains .wmv" and so on. I did that to create a view that only has MP3, OGG, and ACC files in it. I have another view that just has MOD files and another view that just has MIDI files.

I just realized.. I have no video files in Winamp. Never bothered adding any to the library on this system.

Is Winamp basing its audio/video detection based on the file's extension, header information, or if detects an audio or video stream within the file? Technically you can make a AVI or FLV file without the video part.
MarkRH is offline   Reply With Quote
Old 26th June 2014, 21:40   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
a bit of everything you said.
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump