Old 17th August 2007, 13:51   #161
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by xbarns
Ok i went back to Eclipse 3.2.2 and EclipseNSIS 0.9.5.1, everything works again
But you will then miss all the enhancements that came with NSIS 2.26 and above.
Sorry I could not be of more help.
But if you could check the Eclipse 3.3 error log using the method I described earlier, I may be able to help you.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 17th August 2007, 14:11   #162
xbarns
Senior Member
 
xbarns's Avatar
 
Join Date: Aug 2007
Location: Frankfurt, Germany
Posts: 187
Quote:
No, the error log I mean can be accessed by going to Window->Show View->Error Log in the Eclipse 3.3 menu.
Nope sorry, no entries , i still have 3.3 installed.

I opened one of my exisiting files as well as creating a new one which i could compile once but after closing and opening again....

Quote:
But you will then miss all the enhancements that came with NSIS 2.26 and above.
Yes , but right now i just need to be able to compile.


If there is anything else you want me to try just let me know i have downloaded all the stuff and i can set up another installation in minutes.


_ edit _

ok i installed again, no errors in the log you mentioned, only when i click on the "Export the NSIS script as an HTML file" Button i get

eclipse.buildId=I20070625-1500
java.version=1.6.0_02
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Command-line arguments: -os win32 -ws win32 -arch x86

Error
Fri Aug 17 15:39:15 CEST 2007
java.lang.reflect.InvocationTargetException


but i guess that is bnot what you are looking for, is it ?

Last edited by xbarns; 17th August 2007 at 14:42.
xbarns is offline   Reply With Quote
Old 17th August 2007, 22:17   #163
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
No that is not what I was looking for.
But since you got that error, perhaps you could double click on it in the Error view to get the detailed stack trace information? Or did Eclipse crash completely?

However, in an attempt to reproduce your problem, I set up an Windows XP SP2 German installation.
I then installed Sun JRE 1.5.0-12, NSIS 2.29, Eclipse 3.3, GEF 3.3 and EclipseNSIS 0.9.6.
I was able successfully open and compile NSIS scripts.
I also tried exporting as HTML without any problems.

Is there something special I need to know about your setup?
Which edition of Windows XP are you using? Is it one of the "N" editions?

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 18th August 2007, 11:02   #164
xbarns
Senior Member
 
xbarns's Avatar
 
Join Date: Aug 2007
Location: Frankfurt, Germany
Posts: 187
Quote:
No that is not what I was looking for.
But since you got that error, perhaps you could double click on it in the Error view to get the detailed stack trace information? Or did Eclipse crash completely?
Hmm too bad, Eclipse did not crash completely, do you want me to send you the stack trace?

Quote:
Is there something special I need to know about your setup?
Which edition of Windows XP are you using? Is it one of the "N" editions?
Not that i am aware of, what bugs me the most ist that it happens on different machines (my Laptop, my Desktop and a VMWare running on the Desktop).

My Windows Edition are all Volume License Versions and N would be the one without Media Player or IE right ? But they all have IE and MediaPlayer.
xbarns is offline   Reply With Quote
Old 18th August 2007, 15:09   #165
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by xbarns
Hmm too bad, Eclipse did not crash completely, do you want me to send you the stack trace?
Sure, go ahead - it can't hurt.

Quote:
Originally posted by xbarns

Not that i am aware of, what bugs me the most ist that it happens on different machines (my Laptop, my Desktop and a VMWare running on the Desktop).

My Windows Edition are all Volume License Versions and N would be the one without Media Player or IE right ? But they all have IE and MediaPlayer.
Yes, I also installed a Volume License version of XP SP2 German.

If you are familiar with Java programming, you can debug the plugin. The source code is also available as a plugin.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 19th August 2007, 09:33   #166
xbarns
Senior Member
 
xbarns's Avatar
 
Join Date: Aug 2007
Location: Frankfurt, Germany
Posts: 187
Quote:
If you are familiar with Java programming, you can debug the plugin. The source code is also available as a plugin.
Well i guess that would be my next problem I have no idea about programming.

Here is the stack trace.

http://www.bergens.name/Eclipse_Stack_Trace.txt
xbarns is offline   Reply With Quote
Old 19th August 2007, 11:58   #167
xbarns
Senior Member
 
xbarns's Avatar
 
Join Date: Aug 2007
Location: Frankfurt, Germany
Posts: 187


I think i might have the solution....

Ok there is 2 ways to save your .nsi File in Eclipse:

1. in a project
2. on the filesystem

It works when i save it in a project but not when i save it in the filespace.

Can you confirm this ?

I switched to using projects now...
xbarns is offline   Reply With Quote
Old 20th August 2007, 14:35   #168
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Thanks, that was the key. I can reproduce the problem. I will investigate and hopefully release an update shortly.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 21st August 2007, 16:54   #169
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
EclipseNSIS 0.9.6.1 and EclipseNSIS InstallOptions Editor 0.9.6.1 released

EclipseNSIS 0.9.6.1 and EclipseNSIS InstallOptions Editor 0.9.6.1 are both available for download now.
See the EclipseNSIS home page for details.

Notes:
This release addresses the problems opening external files.

Changes:

EclipseNSIS
EclipseNSIS InstallOptions Editor

As always, I am looking for any and all bugs you may find. These may be entered in the EclipseNSIS project SourceForge Bug tracker. Feature requests may also be entered.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 23rd August 2007, 20:31   #170
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by xbarns


I think i might have the solution....

Ok there is 2 ways to save your .nsi File in Eclipse:

1. in a project
2. on the filesystem

It works when i save it in a project but not when i save it in the filespace.

Can you confirm this ?

I switched to using projects now...
Did you try the 0.9.6.1 update yet?
It should fix this problem.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 23rd August 2007, 22:03   #171
xbarns
Senior Member
 
xbarns's Avatar
 
Join Date: Aug 2007
Location: Frankfurt, Germany
Posts: 187
Quote:
Did you try the 0.9.6.1 update yet?
It should fix this problem.
Darn i was busy annoying a customer and forgot all about it.

Just tried it, it works fine, thanks for the effort.
xbarns is offline   Reply With Quote
Old 29th August 2007, 15:23   #172
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by ********
Will there be an all-in-one update site distribution for 0.9.6? Downloads ratio of 1/8 for version 0.9.5.1 is good enough to consider experiment successful including the fact the package released two weeks later after a main release.

I would appreciate the option to download all three eslipsensis arts and install them at once by pointing from within an eclipse rather than messing with unzip and eclipse folders.
0.9.6.1 is now available as an archived site.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 11th November 2007, 17:19   #173
TobbeSweden
Senior Member
 
Join Date: Oct 2006
Posts: 106
I can't get EclipseNSIS working. I first tried to install it using Eclipse's update manager. That didn't work. I then tried doing it the manual way. That didn't work either. I didn't get any error messages or anything when installing it.

I can see the EclipseNSIS options in the Preferences dialog and there is an NSIS Update Wizard entry in the Help menu. But There isn't a EclipseNSIS menu, and there isn't an nsis perspective and there is no nsis project wizard.

I'm using Eclipse SDK Version: 3.3.1.1 Build id: M20071023-1652 on Windows XP SP2 Swedish with JavaRE 1.6.0_03

What can I do to get it working?
TobbeSweden is offline   Reply With Quote
Old 12th November 2007, 00:26   #174
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by TobbeSweden
I can't get EclipseNSIS working. I first tried to install it using Eclipse's update manager. That didn't work. I then tried doing it the manual way. That didn't work either. I didn't get any error messages or anything when installing it.
No error messages is good.
That means it worked.

Quote:
Originally posted by TobbeSweden
I can see the EclipseNSIS options in the Preferences dialog and there is an NSIS Update Wizard entry in the Help menu. But There isn't a EclipseNSIS menu, and there isn't an nsis perspective and there is no nsis project wizard.
You are looking for things that don't exist. There is no NSIS perspective nor is there any such thing as an NSIS project.
What you will find, however, is an NSIS Script Wizard which you can use to create new NSIS scripts.
Alternatively, you can open an existing NSIS script using the File->Open menu item.
If you have an NSIS file in an existing Eclipse project, you should be able to double click on it to open it.
The EclipseNSIS menu will show up once an NSIS script has been opened in the NSIS editor.

Quote:
Originally posted by TobbeSweden
I'm using Eclipse SDK Version: 3.3.1.1 Build id: M20071023-1652 on Windows XP SP2 Swedish with JavaRE 1.6.0_03

What can I do to get it working?
It appears that everything is actually installed correctly. Just open an NSIS script and see if you can edit and compile it propertly.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 12th November 2007, 16:08   #175
TobbeSweden
Senior Member
 
Join Date: Oct 2006
Posts: 106
Wow! Don't I feel stupid?

One thing though. When I get a compilation error and click on it in the console a new copy of the file with the error in it is opened, even if it's already opened in Eclipse. I think it would be better if it would just jump to the line with the error in the already opened file.

Other than that, great work, and thanks for your help
TobbeSweden is offline   Reply With Quote
Old 12th November 2007, 16:41   #176
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Hmmm... it should jump to the line in the existing editor.
Can you provide details of the file, e.g., is it an external file or a internal file (i.e., part of a project).
How did you open it? Is it possible to attach the file to your reply so that I can test with it?

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 12th November 2007, 20:10   #177
TobbeSweden
Senior Member
 
Join Date: Oct 2006
Posts: 106
I opened the file by dragging it from explorer and dropping it in Eclipse. This is the file: (The error is on line 10)
code:
!include MUI.nsh

Name "Test"
OutFile "TestMUI.exe"
ShowInstDetails show
ShowUninstDetails show
InstallDir "$PROGRAMFILES\Test"

!insertmacro MUI_PAGE_WELCOME
!insertmacro MUI_PAGE_LICENSE "${NSISDIR}\COPYING_" ; Error on this line
!insertmacro MUI_PAGE_COMPONENTS
!insertmacro MUI_PAGE_DIRECTORY
!insertmacro MUI_PAGE_INSTFILES
!insertmacro MUI_PAGE_FINISH

!insertmacro MUI_UNPAGE_WELCOME
!insertmacro MUI_UNPAGE_CONFIRM
!insertmacro MUI_UNPAGE_INSTFILES
!insertmacro MUI_UNPAGE_FINISH

!insertmacro MUI_LANGUAGE "English"

Section "Main Application" sec01
SetOutPath $INSTDIR
File /r '${NSISDIR}\Stubs'
WriteUninstaller "$INSTDIR\uninstal.exe"
SectionEnd

Section UnInstall
RMDir /r $INSTDIR
SectionEnd



Talking about projects... How do I create an installer project?
TobbeSweden is offline   Reply With Quote
Old 12th November 2007, 20:33   #178
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
OK, thanks. I can reproduce it. I will investigate.

Also, there is no such thing as an "Installer Project".
At least, not that I know of.
You can add your nsi file to any Eclipse project.
If you don't have an Eclipse project, you can create a new Project and set its location to be that of your nsi file.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 12th November 2007, 21:39   #179
TobbeSweden
Senior Member
 
Join Date: Oct 2006
Posts: 106
Quote:
there is no such thing as an "Installer Project"
Yeah, that's why I got confused... When I'm going to write something in Java I choose "File->New->Project->Java Project". When I'm going to write something in C++ I go "File->New->Project->C++ Project". So naturally I went looking for a "Installer Project" or "NSIS Project" but couldn't find anything... I found a "General Project", guess I can use that...
TobbeSweden is offline   Reply With Quote
Old 15th November 2007, 12:54   #180
pospec
Senior Member
 
pospec's Avatar
 
Join Date: Jun 2007
Location: Otrokovice, Czech Republic
Posts: 308
EclipseNSIS is very nice, but I had problems with Compile / Test / Compile & Test buttons. I commited my problem with Test button into bugtracker (ID 1830306).

Now my Compile & Test button refuses to launch installer after compiling. I didn't change EclipseNSIS Preferences. It is a pitty, that was best feature at all ;-)

EDIT: I've restarted my computer (after 4 days). It's fuzzy - both "bugs" sometimes work and sometimes don't.

Last edited by pospec; 15th November 2007 at 13:14.
pospec is offline   Reply With Quote
Old 15th November 2007, 14:18   #181
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by pospec
EclipseNSIS is very nice, but I had problems with Compile / Test / Compile & Test buttons. I commited my problem with Test button into bugtracker (ID 1830306).

Now my Compile & Test button refuses to launch installer after compiling. I didn't change EclipseNSIS Preferences. It is a pitty, that was best feature at all ;-)

EDIT: I've restarted my computer (after 4 days). It's fuzzy - both "bugs" sometimes work and sometimes don't.
I have not been able to reproduce this problem- in fact, you are the first person to experience this issue.
I will need more information from you:
Windows OS version
Eclipse version
NSIS version
EclipseNSIS version

Does this happen with any NSIS script or just one particular one? Would it be possible to attach a sample script to the bug report?

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 16th November 2007, 08:17   #182
pospec
Senior Member
 
pospec's Avatar
 
Join Date: Jun 2007
Location: Otrokovice, Czech Republic
Posts: 308
I have experienced it day or two after installation, now I can't reproduce it too. If it occurs again, I'll post a message here. Thanks anyway
pospec is offline   Reply With Quote
Old 16th November 2007, 16:34   #183
danielkza
Junior Member
 
Join Date: Jul 2007
Posts: 10
Hi,first of all thanks for all the work in EclipseNSIS,it is being very helpful, specially because I'm used to Eclipse,so thanks again.

I used Eclipse with NSIS this afternoon, creating an InstallOptions page with the editor.I finished it,tested,and it was ok.Now when I try to open it,create a new InstallOptions page, or even open the InstallOptions editor,it throws me an error,and goes to the source editor.I also can't preview the file.

I attached the stack trace so you can see what's the problem

Thanks again.

EDIT: Now it's a different error.I edited the attachment with it to.
Attached Files
File Type: txt stack.txt (8.0 KB, 335 views)
danielkza is offline   Reply With Quote
Old 16th November 2007, 18:41   #184
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
I need the original stack trace. The second stack trace no longer shows the actual cause of the error- it is only being thrown because the class cannot be loaded.
Close eclipse, restart it and then try to open the IO script and capture the stack trace.
Also, provide the following info:
Windows OS version
Eclipse version
NSIS version
EclipseNSIS version
JRE version

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 19th November 2007, 10:12   #185
galevsky
Senior Member
 
Join Date: Oct 2007
Posts: 101
It is not possible to read the user manual on eclipse (seems to be html instead of xhtml), so:

code:
org.xml.sax.SAXParseException: The element type "br" must be terminated by the matching end-tag "</br>".
at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(Unknown Source)
at org.eclipse.help.internal.dynamic.DocumentReader.read(DocumentReader.java:56)
at org.eclipse.help.internal.dynamic.XMLProcessor.process(XMLProcessor.java:49)
at org.eclipse.help.internal.xhtml.DynamicXHTMLProcessor.process(DynamicXHTMLProcessor.java:66)
at org.eclipse.help.internal.webapp.servlet.DynamicXHTMLFilter$1.close(DynamicXHTMLFilter.java:79)
at java.io.FilterOutputStream.close(Unknown Source)
at org.eclipse.help.internal.webapp.servlet.FilterHTMLHeadAndBodyOutputStream.close(FilterHTMLHeadAndBodyOutputStream.java:290)
at org.eclipse.help.internal.webapp.servlet.EclipseConnector.transfer(EclipseConnector.java:162)
at org.eclipse.help.internal.webapp.servlet.ContentServlet.doGet(ContentServlet.java:42)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:596)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
at org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:180)
at org.eclipse.equinox.http.servlet.internal.ServletRegistration.handleRequest(ServletRegistration.java:90)
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:111)
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:67)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
at org.eclipse.equinox.http.jetty.internal.HttpServerManager$InternalHttpServiceServlet.service(HttpServerManager.java:288)
at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)
at org.mortbay.jetty.servlet.ServletHandler.dispatch(ServletHandler.java:677)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:568)
at org.mortbay.http.HttpContext.handle(HttpContext.java:1530)
at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)
at org.mortbay.http.HttpServer.service(HttpServer.java:909)
at org.mortbay.http.HttpConnection.service(HttpConnection.java:820)
at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:986)
at org.mortbay.http.HttpConnection.handle(HttpConnection.java:837)
at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:245)
at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:357)
at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)




What can I do ? Anyone can read it ?

Gal'
galevsky is offline   Reply With Quote
Old 23rd November 2007, 17:30   #186
galevsky
Senior Member
 
Join Date: Oct 2007
Posts: 101
Am I alone to face this issue ?

EDIT> I am riding an Europa Eclipse v3.3.1.1 targetting a NSIS compiler v2.3.3 .

Gal'

Last edited by galevsky; 23rd November 2007 at 17:51.
galevsky is offline   Reply With Quote
Old 25th November 2007, 00:24   #187
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Eclipse help supports pure HTML. It is possible that a different plugin is causing this problem.
I will need exact steps on how to reproduce this.
Also, what other plugins have you installed?
The error you see appears to be caused by an invalid xhtml document, but all the EclipseNSIS help is in plain vanilla html.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 2nd January 2008, 20:05   #188
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
EclipseNSIS 0.9.6.2 and EclipseNSIS InstallOptions Editor 0.9.6.2 released

EclipseNSIS 0.9.6.1 and EclipseNSIS InstallOptions Editor 0.9.6.1 are both available for download now.
See the EclipseNSIS home page for download links and instructions.

Notes:
This is a minor maintenance release.

Changes:
EclipseNSISAs always, I am looking for any and all bugs you may find. These may be entered in the EclipseNSIS project SourceForge Bug tracker. Feature requests may also be entered.

This release is also available as an archived Eclipse update site.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 2nd January 2008, 21:31   #189
TobbeSweden
Senior Member
 
Join Date: Oct 2006
Posts: 106
Did you fix the bug where it would open an extra copy of the file when double clicking an error if the file was opened by drag-and-drop?
TobbeSweden is offline   Reply With Quote
Old 2nd January 2008, 23:47   #190
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by TobbeSweden
Did you fix the bug where it would open an extra copy of the file when double clicking an error if the file was opened by drag-and-drop?
Yes.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 2nd January 2008, 23:49   #191
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Re: EclipseNSIS 0.9.6.2 and EclipseNSIS InstallOptions Editor 0.9.6.2 released

Quote:
Originally posted by iceman_k
EclipseNSIS 0.9.6.1 and EclipseNSIS InstallOptions Editor 0.9.6.1 are both available for download now.
Oops. This should obviously read:

EclipseNSIS 0.9.6.2 and EclipseNSIS InstallOptions Editor 0.9.6.2 are both available for download now.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 3rd January 2008, 08:24   #192
TobbeSweden
Senior Member
 
Join Date: Oct 2006
Posts: 106
Great, thank you!
TobbeSweden is offline   Reply With Quote
Old 23rd June 2008, 09:38   #193
natalie74
Junior Member
 
Join Date: Jun 2008
Posts: 1
Hello all,

I also want to use NSIS in my Eclipse IDE. But before i should know wether I can use NSIS with user input(point out to a special directy e.g.) in the installer which i can write into my already existing .XML file.

I have also googeled about NSIS + xml but found several plugins? Do they work together with NSIS-eclipse and which one to use is best?
natalie74 is offline   Reply With Quote
Old 23rd June 2008, 10:15   #194
elllit
Junior Member
 
Join Date: Jun 2008
Location: Germany
Posts: 18
Hi

I don't exactly know what you are asking. If it is equal to:

"I want to do something with an XML file using NSIS and am afraid that EclipseNSIS doesn't support it"

I can say: Eclipse is just being used as IDE, referring to standard makensis.exe when building the installer. That means, feel free to use it. In fact im writing an installer that reads/writes an XML file as well.

The next question was:

"Which is the best XML plug-in for NSIS?"

You are right, there are several ones...

http://nsis.sourceforge.net/NsisXML_plug-in_(by_Wizou)
http://nsis.sourceforge.net/NsisXML-...arser_for_NSIS
http://nsis.sourceforge.net/NsXML_plug-in_(by_rsegal)

I use this one:

http://nsis.sourceforge.net/XML_plug-in

I suggest to take a look at the features and the trade-offs of all of them, then decide which one to try.

Till
elllit is offline   Reply With Quote
Old 29th September 2008, 18:46   #195
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
EclipseNSIS 0.9.7 and EclipseNSIS InstallOptions Editor 0.9.7 released

EclipseNSIS 0.9.7 and EclipseNSIS InstallOptions Editor 0.9.7 are both available for download now.
See the EclipseNSIS home page for details.

Notes:
  • Eclipse 3.3 is not supported in this release. You must upgrade to Eclipse 3.4 (Ganymede).
  • The new nsDialogs plugin is still not supported by the InstallOptions editor, however I am open to suggestions on how this can be done.


Changes:

EclipseNSIS
  • Upgraded to Eclipse 3.4 - no longer compliant with Eclipse 3.3.
  • Added support for new !searchparse command.
  • Added support for new /file option for !define command.
  • Added support for !else in outline view.
  • Wizard now supports MUI2 and Multi-User Install.
  • Added preview to NSIS Command Wizard.
  • Added support for unicode version of NSIS.
  • SourceForge download site is validated in Update preference page.
  • Proxy configuration is obtained from Eclipse network settings preferences.
  • Feature Requests:
    o 1902422
  • Bug Fixes
    o 1996176
    o 2050658
  • Other minor bug fixes.

EclipseNSIS InstallOptions Editor
  • Upgraded to Eclipse 3.4 - no longer compliant with Eclipse 3.3.
  • Minor bug fixes.

As always, I am looking for any and all bugs you may find. These may be entered in the EclipseNSIS project SourceForge Bug tracker. Feature requests may also be entered.

This release is also available as an archived Eclipse update site.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 19th November 2008, 10:51   #196
o_owd
Senior Member
 
o_owd's Avatar
 
Join Date: Feb 2003
Location: TGM, Romania
Posts: 176
Send a message via ICQ to o_owd Send a message via Yahoo to o_owd
Hey,
I have (probably) a stupid question.
Every time i save my script, it unfolds. This is annoying.
I searched in Preferences but i did not find anything.
Can this be unchecked somewhere ?

Thanks,
OJi.
o_owd is offline   Reply With Quote
Old 20th November 2008, 22:11   #197
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by o_owd
Hey,
I have (probably) a stupid question.
Every time i save my script, it unfolds. This is annoying.
I searched in Preferences but i did not find anything.
Can this be unchecked somewhere ?

Thanks,
OJi.
Every time you save the script, the internal model representing the script structure is completely refreshed. When this happens, Eclipse automatically expands all collapsed regions.
This does not happen if an incremental refresh is done of the model.
However, because of the complexity of NSIS scripts, I have not implemented incremental refreshes yet.

If you would like to see the collapsed regions stay as such when you save a script, file a feature request and I will get around to it when I can.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 5th April 2009, 08:51   #198
mattn2
Junior Member
 
Join Date: Apr 2009
Posts: 1
nice to have an eclipse plugin. but one question remains: Why only for windows? I mean, nsi is also available for linux.
mattn2 is offline   Reply With Quote
Old 22nd March 2010, 08:30   #199
iponomarev
Junior Member
 
Join Date: Mar 2010
Posts: 2
Where did 0.9.7.3 version gone?

Hello,

It is told on EclipseNSIS revision history page (http://eclipsensis.sourceforge.net/revisions.shtml) that 0.9.7.3 version of EclipseNSIS was released on 10/06/2009.

I need this version because EclipseNSIS stopped working when I moved from 32bit Vista to 64bit Windows 7, and they say that support for Windows 7 was added.

However, I can only download 0.9.7.2 from update site and sf.net download pages. Was the update ever released? How can I get it?

Since I did not find any contact information on eclipsensis.sourceforge.net site, I will be grateful if you just suggest me the way to contact EclipseNSIS developers.

Regards,

Ivan.
iponomarev is offline   Reply With Quote
Old 27th March 2010, 11:38   #200
luca.vagnozzi
Junior Member
 
Join Date: Mar 2010
Posts: 1
Hi,
I'm in the same situation, and AFAIK support for 64bit machine doesnt exists yet.
luca.vagnozzi is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump