Old 19th November 2012, 08:51   #1
PubRocK
Junior Member
 
Join Date: Nov 2012
Posts: 8
Incorrect Streaming Track/Artist Info Now Playing

Hi, I hope I am in the right place.

I am streaming via SAM Broadcaster, hosting service is ShoutcastCity (Centova CP) and Shoutcast DNAS 2 server.

When I view my currently playing tracks in any player, i.e. Shoutcast player, RadioTuna, my own website, the artist information does not link up with what is in fact currently playing. For example Now Playing -> James; Now Showing -> The White Stripes??

It will show for about 1-2min in the beginning of a song and change therafter. If the song is about 8min long, 3 artist/track info will appear in that time.

Anything I can do to fix this? Thanks in advance for your help.

PS. Sorry if this has been posted elsewhere, I tried searching first.
PubRocK is offline   Reply With Quote
Old 19th November 2012, 10:22   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'd need a link to the listing to confirm what is / isn't going on.

-daz
DrO is offline   Reply With Quote
Old 19th November 2012, 10:58   #3
PubRocK
Junior Member
 
Join Date: Nov 2012
Posts: 8
http://208.43.81.142:8278/

Thank you!
PubRocK is offline   Reply With Quote
Old 19th November 2012, 11:15   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
is as i thought, you're running a v1 DNAS (and not a v2 DNAS as your post implied) which doesn't update the listing details when a title change happens, so what is shown is what was sent during the last 'touch' update. you can tell a v1 based listing by it showing 'recently played: ...' for the listing.

so what is shown on the site isn't going to appear as you'd expect with the versions of things being used.

-daz
DrO is offline   Reply With Quote
Old 19th November 2012, 11:25   #5
PubRocK
Junior Member
 
Join Date: Nov 2012
Posts: 8
I also just realised it was indeed version 1. Sorry about that.

What are my options? Do I need to 'upgrade' to version 2?

It used to work, for about a month, and not now.

I'm sorry if I don't understand, but it changes the stream detail within a current song which at first was displayed correctly.. Almost as if it 'times out'?
PubRocK is offline   Reply With Quote
Old 19th November 2012, 11:46   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
v1 listings only send the title update generally every 10 mins, unless something fails in the communication between DNAS and YP, that will keep happening as long as the DNAS is active and listed. everything you've described matches with things running in v1 mode.

as for the other question, the v2 DNAS will do it 'live' as long as you're using a v2 source (or a build of the DNAS which doesn't have a bug with v1 sources and YP updates). but the only way to get it showing 'now playing: xxx' is to use a v2 DNAS as it works in a different manner which allows it to update titles when they change rather than waiting for a specific timeout.

-daz
DrO is offline   Reply With Quote
Old 19th November 2012, 12:00   #7
PubRocK
Junior Member
 
Join Date: Nov 2012
Posts: 8
2:47pm Actually Playing NIN - Wish/ Showing NIN - Wish
2:50pm Actually Playing NIN - Wish/ Showing Live - Turn My Head
2:51pm Actually Playing Nirvana - Come as you are/ Showing Nirvana - Come as....
2:55pm Jingle
2:55pm Actually Playing Rise Against - Satellite/ Showing Guns & Roses - Civil War
2:59pm Jingle
2:59pm Actually Playing Oasis - Lyla/
PubRocK is offline   Reply With Quote
Old 19th November 2012, 12:04   #8
PubRocK
Junior Member
 
Join Date: Nov 2012
Posts: 8
was still busy posting

2:59 Actually Playing Oasis - Lyla Showing Oasis - Lyly
3:00 Actually Playing Oasis - Lyla Showing Unkown - Is this it

The actual initial (sometimes) correct info is displayed as the song changes, and then again in between.. So no 10min intervals here.. Again, it used to work, and not anymore.. Somethings changed.
PubRocK is offline   Reply With Quote
Old 19th November 2012, 12:13   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
the site caches things so that's out of kilt at times (depending on where in the update cycle and what host you're hitting).

i have been looking at the raw data from the last few updates (which come in at a 3min offset e.g. 13:03, 13:13, etc) and i'm only seeing an update every 10mins. i cannot explain what you're seemingly seeing as it doesn't match with the raw updates.

-daz
DrO is offline   Reply With Quote
Old 19th November 2012, 12:20   #10
PubRocK
Junior Member
 
Join Date: Nov 2012
Posts: 8
Here we go, this is from Centova Cotrol Panel: In Green, Never played... Maybe the issue lies with SAM..

1. Garbage - I Would Die For You
03:13 PM 2. Violent Femmes - Add It Up
03:13 PM 3. PR - WWW
03:10 PM 4. Mumford & Sons - I Will Wait
03:07 PM 5. U2 - All I want is you
03:07 PM 6. Coolest party eva
03:05 PM 7. Skunk Anansie - Charlie Big Potato
03:04 PM 8. The Black Box Revelation - High On A Wire
03:00 PM 9. Unknown - Is This It
02:59 PM 10. Oasis - Lyla
PubRocK is offline   Reply With Quote
Old 19th November 2012, 12:24   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
i think we're talking about different things as what goes on in Centova is separate from the YP aspects.

the last update that just came through is 'Bloodhound Gang - Foxtrot Uniform Charlie Kilo'.

-daz
DrO is offline   Reply With Quote
Old 19th November 2012, 12:38   #12
PubRocK
Junior Member
 
Join Date: Nov 2012
Posts: 8
Yes, that is correct, but see this from my Shoutcast DNAS panel.. In RED never played, yet it comes up while I listen via Winamp in now playing. You will also notice that the times of these being listed or appearing as playing is too close or possible to ACTUALLY play.. giving you a song length of a minute..

I will restart SAM tonight to see if it continues and revert..


Played @ Song Title
07:32:35 Bob Dylan - Blowing in the wind Current Song
07:32:33 SFX - Cat
07:30:15 The Roots - The Seed 2.0
07:27:25 Blur - Coffee and TV
07:25:11 Violent Femmes - Gone Daddy Gone
07:24:06 Blue October - Dirt Room
07:24:02 PR - WWW
07:21:11 Bloodhound Gang - Foxtrot Uniform Charlie Kilo
07:20:09 Nirvana - Smells Like Teen Spirit
07:17:42 The Virginmary's - Dead Man Shoes
PubRocK is offline   Reply With Quote
Old 19th November 2012, 12:48   #13
DrO
 
Join Date: Sep 2003
Posts: 27,873
i don't know, i can only go on what i'm seeing, maybe it's a bug in SAM, but i cannot say either way as the DNAS will just report whatever the source tells it.

-daz
DrO is offline   Reply With Quote
Old 20th November 2012, 05:04   #14
PubRocK
Junior Member
 
Join Date: Nov 2012
Posts: 8
Hi again, the problem lied within SAMBC.. I edited the playlist rotation rules and removed any SFX shorter than 2 sec and restarted and the problem disappeared.

Thanks for your assistance.
PubRocK is offline   Reply With Quote
Old 20th November 2012, 09:50   #15
DrO
 
Join Date: Sep 2003
Posts: 27,873
rightio, that's good to know that you're sorted now.

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Technical Support

Tags
artist, now playing, streaming info, track

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump