Old 13th March 2006, 14:12   #1
AudioFreak79
Junior Member
 
Join Date: Mar 2006
Posts: 7
Enqueue gone from Context Menu

Hi guys,
Searched everywhere & cannot fix this!

When I right-click on an mp3, the "Enqueue in Winamp" is gone.

I've tried the following:

- Reinstalled Winamp (v5.2)
- Unticked and reticked "Show Winamp in folder context menues"
- Disabled/enabled Winamp Agent
- Deregistered the WMP shell extensions (just in case that helped, but no luck)

I've checked the Registry entry in HKEY_CLASSES_ROOT\Directory\shell\Winamp.Enqueue. It's present with the following string "C:\Program Files\Winamp\winamp.exe" /ADD "%1"

If anyone has any suggestions, i'd be grateful!

Cheers,
Andrew
AudioFreak79 is offline   Reply With Quote
Old 13th March 2006, 14:41   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,912
"Show Winamp in folder context menus" and HKEY_CLASSES_ROOT\Directory\shell\Winamp.Enqueue both relate to actual folders, not filetypes.

Is MP3 selected (hi-lighted) in the Extension List in Winamp > Prefs > File Types?

What's your Windows OS?

HKEY_CLASSES_ROOT\.mp3

(default) = Winamp.File

Then make sure that HKEY_CLASSES_ROOT\Winamp.File\shell\Enqueue\command exists

(default) = "C:\Program Files\Winamp\winamp.exe" /ADD "%1"
DJ Egg is online now   Reply With Quote
Old 13th March 2006, 14:47   #3
AudioFreak79
Junior Member
 
Join Date: Mar 2006
Posts: 7
Hey DJ Egg,
Adding mp3 to the extension list worked!

However, in the past I'm sure i've had WMP as my default mp3 player & this has still worked.

I like to use Winamp to play my playlists & WMP for playing single mp3 files (that aren't in my playlist).
AudioFreak79 is offline   Reply With Quote
Old 13th March 2006, 15:43   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,912
okaaay...

So deselect MP3 from the list in Winamp > Prefs > File Types

Close Winamp

Edit the registry as follows:

HKEY_CLASSES_ROOT\.mp3
(Default) = mp3file

HKEY_CLASSES_ROOT\mp3file\shell\Enqueue
(default) = &Enqueue in Winamp

HKEY_CLASSES_ROOT\mp3file\shell\Enqueue\command
(default) = "C:\Program Files\Winamp\winamp.exe" /ADD "%1"

(you'll need to manually create the Enqueue and Enqueue\command subkeys)

Note, I'm assuming because you referred to it in your first post, that you're familiar/comfortable with editing the registry. But if you need further help just let me know.

You could just export those two keys - HKEY_CLASSES_ROOT\.mp3 and HKEY_CLASSES_ROOT\mp3file - (right click them in the tree on the left, select Export, make sure 'Selected Branch' is checkmarked), save the two .reg files to disk, then zip them up and attach them here. I'll then edit them for you so you can then reimport them. Also include Windows OS in your reply.

Of course, the more user-friendly method would be to go to:
WMP > Tools > Options > File Types
Checkmark MP3

Then go to Folder Options > File Types > MP3
and manually add the Enqueue In Winamp action there.
DJ Egg is online now   Reply With Quote
Old 13th March 2006, 15:55   #5
AudioFreak79
Junior Member
 
Join Date: Mar 2006
Posts: 7
Thanks for that.

I've matched what you put, but now when I double-click an mp3, it adds it to the Winamp Playlist instead of using WMP to open it.

Can you see if my settings are correct? They're attached to this.

Thanks for your help!

EDIT: Sorry, i've got WinXP SP2
Attached Files
File Type: zip reg.zip (1.4 KB, 570 views)
AudioFreak79 is offline   Reply With Quote
Old 13th March 2006, 16:31   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,912
Hmm... strange. Your reg files look correct to me.
These two keys state that the default action is "Play"
and that the command for "Play" is to Play with WMP

[HKEY_CLASSES_ROOT\mp3file\shell]
@="play"

[HKEY_CLASSES_ROOT\mp3file\shell\play\command]
@="\"C:\\Program Files\\Windows Media Player\\wmplayer.exe\" /prefetch:6 /Play \"%L\""

Does "Play" appear in bold text (ie. the default action) when you right-click an MP3 file in Explorer?

Is "Play" set as the default action via:
Control Panel > Folder Options > File Types tab > MP3 > Advanced?
Is the command line for 'Play' (via: Play > Edit) set to:
"C:\Program Files\Windows Media Player\wmplayer.exe" /prefetch:5 /Play "%L"
DJ Egg is online now   Reply With Quote
Old 13th March 2006, 16:49   #7
AudioFreak79
Junior Member
 
Join Date: Mar 2006
Posts: 7
The bold (default) action on right-click is "Enqueue in Winamp".

Under "mp3" in Folder Options, it says "You have customized files with extension "MP3". To restore to default type (mp3 audio file (mp3)) click Restore". Due to this, there is no "Advanced" button.

Upon clicking "Restore", the "Advance" option is there. The command line has "prefetch:6" instead of "prefetch:5". Changing that to "5" seems to fix the problem. No idea how that became "6"!

Now it's working the way I wanted it to!

Wow - what a work around!!

Thanks heaps for your help. It's greatly appreciated!!
AudioFreak79 is offline   Reply With Quote
Old 13th March 2006, 17:24   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,912
Ahh yeah, even I didn't notice that. But for sure, I can see the '5' and '6' as plain as day in your (old) reg key and my command line from the post above. Yup, I guess that Prefetch:6 means nothing to WMP, and that's why it wouldn't work (so it just chose the next working action from the list instead, which just so happened to be Enqueue in Winamp).

Anyway, glad it's all worked out fine :-)
DJ Egg is online now   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump