Old 1st September 2007, 04:06   #281
RnB
Junior Member
 
Join Date: Sep 2007
Posts: 4
Ok, I did install with "separate settings per user". Found the files. I was looking in the wrong place. Thank you again for your help!
RnB is offline  
Old 1st September 2007, 08:09   #282
MarkRH
Senior Member
 
Join Date: Nov 2002
Location: Oklahoma City, OK
Posts: 405
Never really messed with embedded album art, but is the art stored at the beginning or end of the file? If it's the beginning, then could Winamp pick-up and display it from a streamed-in MP3 via ml_www or something?

This is how I listen to my music when I'm visiting the folks and using their computer.
MarkRH is offline  
Old 1st September 2007, 09:21   #283
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,908
it should be stored at the beginning of the file(inside id3v2 tags) but I think its a waste of bandwith, and it might muck up gapless playback.
Rocker is offline  
Old 1st September 2007, 10:16   #284
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
Yeah, but if the images are already there, you're already downloading them. May as well display no?

Didn't winamp start reading id3v2 tags from streaming media in a fairly recent 5.x ? Seems plausible to push it to the display to me.

CraigF is offline  
Old 1st September 2007, 11:02   #285
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,908
correct me if i'm wrong.

if you are downloading the tags then yes they might as well be displayed, but I don't know if the shoutcast dsp will send complete tags to the dnas and then on to the end users.

if you have a tag thats 100k+ then i'd say its gonna lag over a normal internet connection everytime the server decides to send the tags and its added overhead.

theirs not really any reason you can't have super high resolution images in tags.(last time I checked)

maybe the shoutcast dsp needs a resizer for images? for their to be a better point in implementing this for streaming.
Rocker is offline  
Old 1st September 2007, 12:57   #286
synthetiq
Senior Member
 
Join Date: Nov 2004
Location: Portugal
Posts: 153
well... these are just ideas
hope you dont mind

its not coded...



thankx
synthetiq is offline  
Old 1st September 2007, 13:01   #287
synthetiq
Senior Member
 
Join Date: Nov 2004
Location: Portugal
Posts: 153
sorry
i wanted to upload an image
its here: http://imagescap.com/viewer.php?file...9t5ixf7bf3.png

i hope

thankx
synthetiq is offline  
Old 1st September 2007, 14:23   #288
armstrong
Junior Member
 
Join Date: Oct 2006
Location: 32°4'1''N, 34°46'13''E
Posts: 7
Re: Winamp 5.36 Beta Preview 2 (Build 1504)

Quote:
DJ Egg sez:
Winamp 5.36 Beta, Build 1504
...
* Fixed: [in_flac] 24bit files don't play when 'Allow 24bit' setting is disabled
When 'Allow 24' is set, it'd better play 24 bits for 16-bit files as well. Early flac plugins used to do that for very pleasing sound.

Flac does a good job 'guessing' what could be there beyond 16 bits. This is a cute side-effect: decompression is always bit-perfect to the 'original' 16 bits; the 'extra' least significant bits mitigate 16-bit quantization artifacts (and can also 'fix' poorly-applied dither during CD mastering -- an all-too-common problem).

Thanks (and kudos for the new FgH mp3, too!)
armstrong is offline  
Old 1st September 2007, 14:26   #289
ctkatz8086
Senior Member
 
Join Date: Sep 2002
Location: louisville, ky home of the CARDINALS
Posts: 401
i didn't read this entire thread, but i also did a search and didn't come up with anything so i hope this isn't a repeat.

you are unable to import outside podcasts with 5.36. you get an "invalid link (404 or timeout)" error. i have tried links from a page full of podcasts and opened the links up themselves in opera. opera can add those links as newsfeeds so i know that they are up and active.

os: vista

ctkatz8086 is offline  
Old 1st September 2007, 14:41   #290
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Any idea if this can be corrected? See attached image.
Attached Images
File Type: png winamp-notification.png (3.8 KB, 411 views)

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 1st September 2007, 15:14   #291
IndexDrive
Junior Member
 
Join Date: Aug 2007
Location: Borås, Sweden
Posts: 3
Quote:
Originally posted by DJ Egg
@IndexDrive
Sorry, but I'm truly baffled. Anyone else got any ideas?
I removed the BETA and installed 5.35 and now it looks as it should. So It must be a mix of the BETA and something on my PC. I just have to wait for the next build or when 5.36 will be out of the BETA.
IndexDrive is offline  
Old 1st September 2007, 17:36   #292
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,908
clean reinstall.
Rocker is offline  
Old 1st September 2007, 18:59   #293
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
@armstrong
Go to: Winamp > Prefs > Playback
and checkmark 'Use Replay Gain'
If 'Allow 24bit' is also checked, then 16bit FLAC files will now playback at 24bit.
(If your files aren't RG'ed, then you can set the 'adjustment for files without rg' slider to '0' if you wish).


@ctkatz8086
The podcast manual subscriptions still work okay for me.
The url must be an actual rss/xml feed, eg.
http://www.postmodernrock.com/podcast/index.xml
http://www.loungecast.net/rss/loungecast.xml
http://www.ultimathule.info/xml/Ulti...usic_Radio.xml
If it's some url which opens a web page or opens in some on-site internal player, then it isn't going to work (you need to find the actual feed url to be able to subscribe to it)
DJ Egg is offline  
Old 1st September 2007, 21:06   #294
PatrickNeil
Member
 
PatrickNeil's Avatar
 
Join Date: Aug 2002
Location: Washington, DC
Posts: 95
Album Art alternatives

New Winamp 5.36 Beta is great, especially the album art feature. I'd love to make use of this, but I've never sorted my mp3s by album. So while the "Get Album Art" feature works, it is constantly replacing the "folder.jpg" file. Now I'm hoping that the 5.36 final uses a different file name for each, but if not, is there a program or plugin that I can use to do this. I'm not sure I want to put it in the ID3 tag, since that seems redundant to me, to have the same big chunk data in twenty different files, but perhaps that's a better way. Still, any suggestions?

Patrick
PatrickNeil is offline  
Old 1st September 2007, 21:17   #295
dkordik
Junior Member
 
Join Date: Nov 2004
Posts: 28
I have a similar concern. Is it possible to have Winamp *never* replace a folder.jpg that is already there? I've gone through a lot of trouble to get super high quality album artwork and it is a shame when Winamp 5 replaces one of them with a 200x200 cover.

note, my cover location: <artist>/<album>/folder.jpg (the cover hangs out with the audio files)

I love that cover art is finally a part of Winamp. I'm anxiously awaiting the final stable 5.36!
dkordik is offline  
Old 1st September 2007, 22:25   #296
synthetiq
Senior Member
 
Join Date: Nov 2004
Location: Portugal
Posts: 153
Me too, have all my albums folders with a folder.jpg file inside.
And hope that winamp doesn't change that without authorisation.
synthetiq is offline  
Old 1st September 2007, 22:33   #297
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
Yes. We hope to make it so it saves as %album%.jpg
DJ Egg is offline  
Old 2nd September 2007, 02:20   #298
ctkatz8086
Senior Member
 
Join Date: Sep 2002
Location: louisville, ky home of the CARDINALS
Posts: 401
@dj
in opera, when i click on podcast links, i get promted to add the feed to my newsfeeds (opera can handle newsfeeds). i don't get any .html pages. i tried your podcast links and got the same result.

i'm going to try again with a new install and see what happens.

ctkatz8086 is offline  
Old 2nd September 2007, 03:33   #299
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
@ctkatz8086
Hmm. You're supposed to add them via:
Winamp > Media Library > Podcasts > Subscriptions > Add
Copy+Paste the feed url's into there...
DJ Egg is offline  
Old 2nd September 2007, 13:11   #300
cybermarz
Member
 
Join Date: Nov 2003
Location: Netherlands
Posts: 73
I did not read all posts so if this is mentioned before, I'm sorry.

At this moment I'm using Winamp 5.36-1504 an Windows 2000 SP4.

* Winamp always keep the focus, no matter what application I try to get to the foreground.

* Pressing F5 key refreshes Winamp completely or crashes

* The library view buttons are unclear what function they have. I would prefer fast switch buttons and a separate settings dialog.

* There is an old problem with the so-called compilation albums. I don't know if I used to keep them out of the library of knew an hidden option. The album covers are cluttered by the single artist tracks and thus renders this view useless.
(Look at iTunes for a good solution for the "various artists" albums)

* It would be nice to have a "large icon" view with little more "details" underneath (album title is too sparse) (a popup balloon will do also)

* The loading of the covers takes ages, still even after hours. A cache would be more than welcome (I don't change these images not every hour, so ..... )

Thanks, for keeping Winamp (Rock & ) Rollin'
cybermarz is offline  
Old 2nd September 2007, 15:00   #301
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
@cybermarz

1. Can't reproduce. What skin? Is the "Always On Top" option enabled?

2. Yes, F5 has always been the hotkey for refreshing the current Modern skin. I can't reproduce any crash though.

3. Yes, agreed. The new View Options buttons need tooltips.

4-6. Album Art features are still in development. As previously mentioned, there's still a fair few more features to come, including cache & loading optimizations, and more right-click options, edit/refresh, etc.
DJ Egg is offline  
Old 2nd September 2007, 17:36   #302
miguel_montes
Junior Member
 
Join Date: Aug 2007
Location: Faro, Portugal
Posts: 4
Quote:
Originally posted by DJ Egg
4-6. Album Art features are still in development. As previously mentioned, there's still a fair few more features to come, including cache & loading optimizations, and more right-click options, edit/refresh, etc.
DJ Egg, what about implementing album art in the music notification window? Kinda like what the Toaster plug-in does?
miguel_montes is offline  
Old 2nd September 2007, 18:03   #303
kzuse
Senior Member
 
kzuse's Avatar
 
Join Date: Oct 2005
Location: (D)
Posts: 480
Send a message via ICQ to kzuse Send a message via Skype™ to kzuse
@armstrong: Additionally this would mean, FLAC files ripped from a HDCD-featured Audio-CD would play in 24-bit mode as a "real" HDCD, meaning the extra sound quality of the HDCD is reproduced by Winamp in this mode - am I right?

At least it sounds promising...
kzuse is offline  
Old 2nd September 2007, 18:57   #304
cybermarz
Member
 
Join Date: Nov 2003
Location: Netherlands
Posts: 73
@DJ Egg

1. Hmmm, the "always on top" was on. Maybe I tried to "select all", that is the default Windows shortcut!

2. OK. But Ctrl+F5 or so would be more logic, since F5 always refresh the content and not the skin and/or application. (Nice feature b.t.w. the Ctrl select in artist display,will display only the corresponding album art!)
I can't reproduce the crash either, I guess it was during stressing the 5.36-1500 version.

3,5-6. I'm happy to taste the omelet you are about to cook!

4. I haven't had this "single artist track" problem for years. I just wondered if something had changed and brought back this old behavior. But I love to see this fixed in the "fair few more features" you mentioned.
cybermarz is offline  
Old 2nd September 2007, 23:36   #305
don-vip
Junior Member
 
Join Date: Jul 2007
Posts: 11
Thank you for finally solving this bug:

* Fixed: Long filepaths corrupted when opening Winamp via Explorer context menu

that was present on every version of Winamp since Vista Beta 2, one year ago !

Winamp works fine on Vista, now
don-vip is offline  
Old 2nd September 2007, 23:59   #306
DrO
 
Join Date: Sep 2003
Posts: 27,873
well that's one confirmation from the few who posted about the issue so thank you for that. is just a shame that none of the others who kept posting haven't also confirmed it as well (along with the notification icon text issue as well). the longpath issue wasn't just limited to vista btw and could also happen on xp and win2k as well, just vista made the issue more evident

-daz
DrO is offline  
Old 3rd September 2007, 09:59   #307
Jimekus
Junior Member
 
Join Date: Nov 2004
Location: NZ
Posts: 33
Send a message via Yahoo to Jimekus
I've been looking around for some days regarding a recent problem that has cropped up in my sixth year of developing a front end for Winamp. Since the last few releases, and I don't know which one because I no longer have the Winamp installs to go back and test, but also there seems to be others who have the problem, Winamp does not minimize when called from another program. I have used all shades of Shell and ShellExecute but the Winamp program shows up and its "minimize" button in the top right does not work. Close works and the 'shrink' button in the middle works but not minimize. It's like the program thinks it's minimized but is actually shown normally. I have to right click the Windows taskbar icon for Winamp and click restore before I can then minimize it. One other thing when this happens the playlist window is completely blank. Clicking the playlist button twice fixes this but that still doesn't allow Winamp to be minimized.
Jimekus is offline  
Old 3rd September 2007, 16:32   #308
martin.deimos
Android/UI Development
 
martin.deimos's Avatar
 
Join Date: Sep 2004
Location: Bavaria
Posts: 1,242
Send a message via ICQ to martin.deimos Send a message via AIM to martin.deimos Send a message via Yahoo to martin.deimos
Quote:
Originally posted by TheUniqueTiger
Any idea if this can be corrected? See attached image.
Yep, i will hopefully correct this for the next public beta. thx for the report.

WebSite: www.skinconsortium.com - Community for Userinterface Design & Coding
Skins: Click Here
martin.deimos is offline  
Old 3rd September 2007, 21:01   #309
inukshuk
Junior Member
 
Join Date: Sep 2007
Posts: 2
Don't Have Album art Radio Button???

Don't seem to have access to the ML button for album art, please point me through how to activate to show,

Thanks much,

Inuk

http://img62.imageshack.us/img62/951...libraryyc6.png
inukshuk is offline  
Old 3rd September 2007, 21:45   #310
Chrissyx
Member
 
Chrissyx's Avatar
 
Join Date: Jul 2006
Location: Germany
Posts: 63
Send a message via ICQ to Chrissyx
Re: Re: Re: Winamp 5.36 Beta Preview 1 (Build 1500)

Quote:
Originally posted by DrO
with some of the other changes that will be coming into play in a few more builds, i think win9x support is dead even on the lite - it's definitely not a platform being tested on anymore now (official testing is effectively xp sp2 which screws me over as i'm a win2k stallwart).
I've tested beta full and lite: The full crashes immediately at start up at least, the lite version seems to run well (except the FLAC issues i reported in the 5.35 release thread).
Attached a screenshot of the error.

Quote:
Originally posted by DrO
alas for the things that is needed with features in the player, crippling things for win9x support has reached the point where it's no longer feasible (as a lot of other programs have reached - just look at foobar which hasn't even worked on win9x for a few years now).
Who cares about foobar? Winamp rocks! ...until now

Quote:
Originally posted by DrO
things have basically reached the stage where if it works then it's a bonus but with no dedicated testing pattern or desire to cripple things for the main user base, the win9x support will become unofficial/partial. like Egg's post mentions, things to do with the media library are the main cause of the win9x issues (along with anything to do with cd accessing) but other changes are likely to force things even on the main client (is still uncertain on a few things so i may or may not be right on that)

-daz
Sad to hear. I hoped for 9x support till 6.0 is released. Is there really no hope of continued 9x support under Winamp 5.X?
Attached Images
File Type: jpg winamp9x.jpg (54.4 KB, 320 views)

I like "silly devs"!

At the going down of the sun and in the morning ...
we will remember Winamp ♥
Chrissyx is offline  
Old 4th September 2007, 03:20   #311
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
CD playback problems :

Permanent
Sonic - Glitch at start of tracks, sounds like a buffer not getting flushed.

Intermittent, crash.
Nero ASPI 2.0.1.74 /**

Intermittent, playback breaks up.
Adaptec ASPI 4.71.02
SPTI

Still plenty of problems with CDDB.
There seems to be differences between info held in the DB, the ML, and the Playlist under varying circumstances.
This gives rise to problems with constant unwanted lookups, CD-Text reading being locked out and edits not being registered until a restart.

On the subject of CD-Text, would it be possible to look for CD-Text before CDDB. i.e 1st party before 3rd party.
Are there plans to have a 'Remove entry from DB' button again, currently there is no way to reread/refresh CD-Text.

/**
winamp caused an Access Violation (0xc0000005)
in module WNASPI32.DLL at 001b:05e349b5.

UJ
ujay is offline  
Old 4th September 2007, 05:13   #312
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
@ujay

The "crash when using aspi & stuttering when using spti" issues are fixed in the latest internal build (I also came across them a few days back).

As for the CDDB & CD-Text issues... yup!
DJ Egg is offline  
Old 4th September 2007, 07:53   #313
djpete
Major Dude
 
djpete's Avatar
 
Join Date: Apr 2004
Location: Melbourne, Australia
Posts: 940
small one but...
On first install ok but then it changes...not sure why...
The Library button text seems to go off on any classic skin...seems to go up a font and bold....strange.
Image attached.

Still this thing flies...very fast compared to older versions....
Hows the next build going...are we there yet are we there yet??
I'm overseas for 6 wks from this Friday and would love to see the new build before I go!!!lol
Attached Images
File Type: jpg image1.jpg (26.0 KB, 315 views)

Cheers, Pete

Anything & Everything Winamp - All In One Place...
Winamp Enthusiasts Group

Last edited by djpete; 4th September 2007 at 09:28.
djpete is offline  
Old 4th September 2007, 09:37   #314
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Request.

Put "CD-Text Present/Not Present" under 'Additional Info' in the Medium Info panel of Rip & Burn. Possible?

UJ
ujay is offline  
Old 4th September 2007, 10:56   #315
martin.deimos
Android/UI Development
 
martin.deimos's Avatar
 
Join Date: Sep 2004
Location: Bavaria
Posts: 1,242
Send a message via ICQ to martin.deimos Send a message via AIM to martin.deimos Send a message via Yahoo to martin.deimos
Quote:
Originally posted by TheUniqueTiger
Any idea if this can be corrected? See attached image.
Hey, here is the fix -- copy to winamp modern/scripts
http://shup.com/Shup/3104/notifier.maki

as an info: the next beta preview will include this fix + the albumart wnd fix, so you need not to download additional files. and it will also feature another goodie for wa modern - stay tuned

WebSite: www.skinconsortium.com - Community for Userinterface Design & Coding
Skins: Click Here
martin.deimos is offline  
Old 5th September 2007, 06:23   #316
djpete
Major Dude
 
djpete's Avatar
 
Join Date: Apr 2004
Location: Melbourne, Australia
Posts: 940
has anything been done with the sound on the beta?
I am sure I notice an improvement in the quality...
??

Cheers, Pete

Anything & Everything Winamp - All In One Place...
Winamp Enthusiasts Group
djpete is offline  
Old 5th September 2007, 16:44   #317
synthetiq
Senior Member
 
Join Date: Nov 2004
Location: Portugal
Posts: 153
Any developements with the betas ?

the forum has been too quiet lately :S
synthetiq is offline  
Old 5th September 2007, 17:24   #318
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Quote:
Originally posted by martin.deimos
Hey, here is the fix -- copy to winamp modern/scripts
http://shup.com/Shup/3104/notifier.maki

as an info: the next beta preview will include this fix + the albumart wnd fix, so you need not to download additional files. and it will also feature another goodie for wa modern - stay tuned
Thank you very much. In fact this bug was there ever since I saw the modern skin and I even posted a bug report but I guess nothing was done to it. (I wonder how it wasn't noticed!) I'll wait for the next beta (or may be the final 5.36).

As always waiting for new features in my favorite Winamp... I hope this goodie makes me wonder 'Wow!'

Thanks once again!

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 5th September 2007, 18:41   #319
pjn123
Major Dude
 
pjn123's Avatar
 
Join Date: Jan 2006
Location: /\/¯¯¯¯¯\/\ , South-Africa
Posts: 1,030
When can we expect the final public version? I know its difficult to say but please make a estimate. And please no.. "when its ready"

Is there room in the beta team?

ClassicPro© v2.01 : This plugin allows you to use cPro skins in Winamp. ClassicPro skins are all SUI skins and loads very quickly. ClassicPro skins is even easier to skin than Winamp Classic skins. A new layout have been added since version 2.
Download ClassicPro© ==== cPro Skins ==== ClassicPro© Homepage ==== SC Forums
pjn123 is offline  
Old 5th September 2007, 19:54   #320
Serpher
Senior Member
 
Serpher's Avatar
 
Join Date: Jun 2006
Location: Poland
Posts: 146
Ok, when next beta? Or maybe not. When final release?

Sorry for my bad English
=====================
MB: Gigabyte P35C-DS3R || CPU: Intel Core 2 Duo E8400 (3.00 GHz) || RAM: 8 GB Kingston DDR3 1333MHz || Audio card: ASUS Xonar D2X || Video card: GeForce 460 GTX || OS: Windows 7 SP1 || DirectX: 9.0c (latest) || Winamp version: latest || Winamp skin: Modern
Serpher is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump