Old 5th October 2007, 23:52   #241
DrO
 
Join Date: Sep 2003
Posts: 27,873
i really can't think off hand what would be preventing things from being detected with a modern skin since the playlist editor (where the playback detection is found) hasn't been messed with from what i remember.

also, in the post you've quoted, that's a slightly newer version (is a capital G in the download link against the older lower-case g as the site is case-sensitive on files) which is 1.1.11p6-DrO (the one before was 1.1.11p5) and it'd be good to know if that has the same result (as i changed the plugin to better honour unicode support in the newer winamp (incase that might have been related to it...)

i'll have a think over what else i can do to try and better the detection of playback start (since the current way is far from ideal anyway - this is why i want to re-do the standalone plugin but i've not had the time since i briefly started on it at the start of the year)

-daz
DrO is offline  
Old 6th October 2007, 00:34   #242
flocksoft
Major Dude
 
flocksoft's Avatar
 
Join Date: Aug 2006
Location: Italy
Posts: 695
Audioscrobbler

just to report it...
also with Audioscrobbler (1.1.11p6-DrO) and classic skins, just few songs are scrobbled
flocksoft is offline  
Old 6th October 2007, 00:40   #243
Zero2FiftyIn4
Senior Member
 
Join Date: Sep 2007
Location: In my head....the voices there are nice
Posts: 170
Quote:
Originally posted by DrO
i really can't think off hand what would be preventing things from being detected with a modern skin since the playlist editor (where the playback detection is found) hasn't been messed with from what i remember.

also, in the post you've quoted, that's a slightly newer version (is a capital G in the download link against the older lower-case g as the site is case-sensitive on files) which is 1.1.11p6-DrO (the one before was 1.1.11p5) and it'd be good to know if that has the same result (as i changed the plugin to better honour unicode support in the newer winamp (incase that might have been related to it...)

i'll have a think over what else i can do to try and better the detection of playback start (since the current way is far from ideal anyway - this is why i want to re-do the standalone plugin but i've not had the time since i briefly started on it at the start of the year)

-daz
Alright DrO everything seems to be up and running how it should be. for me at least. I did however notice that if I have "remove silence at beginning/end of track check" that causes a song not to be detected. But it doesnt happen all the time. Other than that it is detecting the songs properly and submitting them now and works with both the modern and classic skins. Nice work.

.:edit:.
Guess I spoke too soon, it's not detecting songs again.

"It is, in the end, whatever the Hell I want it to be,
And when I'm through with it, it's gonna blow a hole,
This wide, straight through the worlds own idea of itself.
They're throwing bottles at your house.
Come on, lets go break their arms."
Zero2FiftyIn4 is offline  
Old 6th October 2007, 04:18   #244
lordsky
Member
 
Join Date: Mar 2002
Posts: 59
Send a message via AIM to lordsky
The Auto-Tag feature rocks! I have so many songs that are in dire need of it's tagging goodness...
There is just one thing I wish. I have a lot of songs with Japanese titles and artists. A some songs tagged (in ID3v1) with the artist name in romanji (english translations) but once I hit Auto-Tag the original tags (ID3v1) gets overwritten with, "?????". Since ID3v1 doesn't support unicode would it be possible to detect unicode result and not have that information destroy the exist info?

Basically in psuedo-code:
PHP Code:
gracenote_info fetch_gracenote_info();
   if( 
is_not_empty(current_ID3v1_tag_title) && is_unicode(gracenote_info['title']) ) {
      
// do not write id3v1 tag
   
} else {
     
current_id3v1_tag_title gracenote_info['title']
   } 
sorry to geek out on you.
lordsky is offline  
Old 6th October 2007, 05:03   #245
lordsky
Member
 
Join Date: Mar 2002
Posts: 59
Send a message via AIM to lordsky
IDv3 Auto-Tag

Seperate issue I found.

Clean Winamp Build 1600 install
WinXP
Bento Skin

1. Remove all IDv1/2 data from an mp3. Save it.
2. Auto-Tag it and uncheck IDv1 data. (must do this together)
3. Click Save.
BUG: The artist is missing from the IDv2 tag

Auto-tag the same file and uncheck the IDv1 data again and the artist info will stick.
lordsky is offline  
Old 6th October 2007, 05:50   #246
unitexa
Junior Member
 
Join Date: Oct 2007
Posts: 2
@DrO

I downloaded your file, opened up winamp and started playing 30 seconds to mars (an ogg) and i get: Playing (Invalid - Didn't detect track play) [-1]

I stop the player and start playing 311 (an mp3) says submitting in 70 seconds, keep switching to other 311 mp3's and the counter updates to a new time. I switch back to a 30 seconds to mars ogg and the counter updates, now it's recognizing the songs it didn't like a minute ago...yeah, odd.

I stop the playing, and then click start, on the same 30 seconds to mars song, and now I'm getting the invalid didn't detect track play error again. It seems there is an issue detecting the play/stop/next/prev events maybe?

Btw, I'm using the bento skin. This is my titles display format (if it matters): '['$if(%albumartist%,%albumartist%,%artist%)']' $if2(%title%,$filepart(%filename%))

I'm loading these tracks from the media library, which I repopulated fresh just in case after installing this build.

I'm also running this on Vista Ultimate 64bit, but as I said the 1550 build scrobbled just fine. Forcing it in to running with admin priv doesn't make any difference. Uh...I can't think of anything else to mention.

Feel free to throw anything at me and I'll test it.

Thanks
unitexa is offline  
Old 6th October 2007, 09:51   #247
wesderby
Junior Member
 
Join Date: Oct 2007
Location: Everett, WA
Posts: 11
Send a message via Yahoo to wesderby
Crashing Problem; Never Had This Before

I've just started using the current beta, but have been a Winamp user for years.

Before I jump into my problem, let me explain that I am blind, use a screenreader (JAWS), so everything I do is from the keyboard...Sorry, there will be no mouse references here.

The issue I have is that Winamp gives an error, though my screenreader doesn't tell me what said error is, and also says it can't launch the reporter tool to send the error report. The error/crash occurs in one of four instances.

1. I've tabbed beyond the artist and album views and am in the list of individual tracks by a particular artist
2. I've got a song playing, and decide to use the tag editor (alt+3). Once I hit the "OK" button, the whole program crashes, and won't restart automatically even though I've checked the box for it to do so.
3. I right click on an artist or album and use the "Send To AutoTagger" function. I get as far as hitting the "Apply Changes" button, and then it crashes.
4. I get lucky enough to get into the song list and it doesn't crash; but as soon as I use control+e to edit a track or group of tracks, it crashes when I hit the "Update" button.

Again, this has never happened on another version of Winamp.

Since the "Send Error" function isn't working for some reason, I've provided the links to the Memory Dump file and the log file on Sendspace. The first link if the dump file, the second link is for the log file.

http://www.sendspace.com/file/fy8jsy

http://www.sendspace.com/file/2bxtg1

Any help anyone can give on this would be greatly appreciated. Other than this issue, I've been a satisfied Winamp Pro user since September of 2005, and have used the standard Winamp program since late 1998. With the classic skin, it's a VERY accessible media player, ripper, and burner.

t me know if more information is required. I am running XP, Internet Explorer 7, and using a cable connection through Comcast.

[Edit --> DJ Egg]
Logs in one report.zip here:
http://stashbox.org/41390/report.zip
http://stashbox.org/41390/report.zip
wesderby is offline  
Old 6th October 2007, 13:44   #248
Ojay
Junior Member
 
Join Date: Sep 2006
Posts: 21
Re: IDv3 Auto-Tag

Quote:
Originally posted by lordsky
BUG: The artist is missing from the IDv2 tag

Auto-tag the same file and uncheck the IDv1 data again and the artist info will stick.
That is one of the many reports about the weird behavior of the tag editor. I hope this will be fixed in -final.
Ojay is offline  
Old 6th October 2007, 14:12   #249
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
@lordsky & Ojay
Yup, that in_mp3 bug is already fixed for final :-)

@lordsky
Note, you can uncheck 'Write ID3v1' in in_mp3 config

@wesderby
I'm not sure what's going on there... yet, but thanks for the crash logs/report.
DJ Egg is offline  
Old 6th October 2007, 16:21   #250
ecereb
Junior Member
 
Join Date: Sep 2007
Location: Cincinnati
Posts: 12
Apple iPod Classic not playing songs

v5.5 build 1600 - Apple iPod Classic not playing songs that were dragged to it.
The iPod just does not play songs.

I dragged several songs from a playlist on WinAmp to the iPod and they don’t play on the iPod. They do play on the PC, meaning, I can click on the song that is listed under the iPod playlist and WinAmp does read from the iPod and play the song on the PC.

Scenario:
• I dragged several songs from one of my WinAmp playlists like Classical under Local Media directly into the iPod under portables.
• After sync is completed, I then ejected the iPod.
• The songs show up on the iPod screen.
• But when I select the song, tt does not play.

The iPod just sits at the playing screen with the time bar and time not incrementing. This happens either when I select the song on the iPod from the playlist or from the album or artist menu.

I then reattach the iPod. The songs still show up on the iPod play list on WinAmp. I can select the songs and play them with WinAmp. I can also remove the songs from the device with WinAmp.

Note. I can play either MP3 and WAV file songs that were loaded with iTunes.

The file on the iPod under x:\iPod_Control\Music\F?? folders are both WAV and MP3 file types.

x:\iPod_Control\iTunes\ml_pmp.ini file:

~~~
[ml_pmp]
syncOnConnect_time=1191680131
adiv1pos=48152
adiv2pos=50000
colPos_1000=1
colHidden_1000=0
colPos_1001=2
colHidden_1001=0
colPos_1002=0
colHidden_1002=0
colPos_1003=3
colHidden_1003=0
colPos_1007=4
colHidden_1007=0
colPos_1008=5
colHidden_1008=1
colPos_1009=5
colHidden_1009=0
colPos_1010=6
colHidden_1010=0
colPos_1011=7
colHidden_1011=0
colPos_1012=8
colHidden_1012=0
colHidden_1013=1
colHidden_1015=1
colHidden_-1=1
colHidden_1004=1
colHidden_1005=1
colHidden_1006=1
HideRoot=1
colWidth_1000=165
colWidth_1001=652
extractpath=C:\My Music
extractfmt2=<Artist> - <Album>\## - <Trackartist> - <Title>
syncOnConnect_hours=12
FillPercent=90
forcetranscodingbitrate=250
transrate=0
lastusedencoder=541934401
media_numfilters=2
media_filter0=Artist
media_filter1=Album
media_filter2=Album
enableTranscoder=0
extractusecdrip=1
transcodeWavFiles=0
[enc_wav]
ext=WAV
[Transcoder]
pref-enc_541934401=2:

~~~

Apple iPod Classic Model: MB150LL
iPod Classic software Version 1.0.1

Please help.

Winamp, keep up the excellent work.

Thanks
eCereb

Last edited by ecereb; 6th October 2007 at 19:20.
ecereb is offline  
Old 6th October 2007, 16:32   #251
kraps
Junior Member
 
Join Date: Dec 2005
Posts: 4
Bento's really nice - fresh, clean and elegant. It would be perfect though to have album art tab built into it (plenty of room for some new tabs) or even better - to display album art in video tab (you never watch both at the same time) so you don't have to switch it back and forth.

Good job on developing all these years - thanks and keep up!
kraps is offline  
Old 6th October 2007, 18:25   #252
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
You can already display album art in File Info, Playlist, and Media Library (and all at the same time if you want). How many other places does it need to be?!
soulstace is offline  
Old 6th October 2007, 20:20   #253
lordsky
Member
 
Join Date: Mar 2002
Posts: 59
Send a message via AIM to lordsky
ID3 Editor - Artwork Editor

Could you have "Load Artwork..." start in the folder the song is in, instead of starting in My Documents? I hate to have to traverse all those folders to locate my cover.
lordsky is offline  
Old 6th October 2007, 20:25   #254
lordsky
Member
 
Join Date: Mar 2002
Posts: 59
Send a message via AIM to lordsky
RE: this post

Quote:
Originally posted by DJ Egg

@lordsky
Note, you can uncheck 'Write ID3v1' in in_mp3 config
I want the auto-tagger to tag my ID3v1 IF it isn't unicode.
lordsky is offline  
Old 6th October 2007, 22:51   #255
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
I just looked at my task manager in Windows XP, and noticed my system is using ~200 MB more memory than usual. Looking at the process list, nothing seemed to be taking an abnormal amount of memory.

So I decided to load up a more powerful tool, called Process Explorer by Sysinternals. It shows Winamp is actually using 233MB of memory!



I'm not sure what is going on here, nor whether it is normal behaviour or not. I think it may be related to the gracenote (playlist generator) scan I did of my media library a few hours ago.

Any ideas?
soulstace is offline  
Old 7th October 2007, 00:52   #256
Kn0tte
Major Dude
 
Join Date: Feb 2007
Posts: 585
So, is anyone else having the problems that I have? The Media Library "open" bug (opens behind other windows), and when starting up Winamp (and shuffle is OFF), the songticker displays "Winamp 5.5 Beta..." instead of the song (until you click another song)?

I have crossed my fingers and I hope that I dont get these problems in 5.5 Final...
I loved all the other beta versions so much, and in the last, LAST beta, I get these two annoying problems...

And since the DEVs said that they cant try to fix it either, I am a little bit afraid for 5.5 Final.. But I hope the problems is gone when 5.5 Final is released.. I dont want these problems when Im going to celebrate 10 years of Winamp you know

Besides these problems, Winamp 5.5 looks amazing..


Quote:
Originally posted by soulstace
So I decided to load up a more powerful tool, called Process Explorer by Sysinternals. It shows Winamp is actually using 233MB of memory!
Any ideas?
Wow, that is alot... Have you tried to restart your computer and see if anything has changed?
Kn0tte is offline  
Old 7th October 2007, 01:11   #257
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
Nope, I haven't restarted yet. Everything else seems fine besides the 321MB memory usage of winamp.exe.
soulstace is offline  
Old 7th October 2007, 09:37   #258
iron2000
Senior Member
 
iron2000's Avatar
 
Join Date: Mar 2002
Location: Singapore
Posts: 391
Is it possible to get the ML Smart View multi pane filters to sort by comments? Or just add all IDtag fields to the drop-down?

Thanx
iron2000 is offline  
Old 7th October 2007, 09:39   #259
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
When Winamp is playing normally (Bento skin), its taking about 69-70 MB of virtual memory, which also is quite high, isn't it? I remember 5.35 with modern skin taking about 40-45 MB virtual memory. Why this huge memory consumption? Is it related to the skin or album art or anything else?

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 7th October 2007, 09:44   #260
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Quote:
Originally posted by iron2000
Is it possible to get the ML Smart View multi pane filters to sort by comments? Or just add all IDtag fields to the drop-down?
Customize the columns in the bottom pane of the smart view to show the comments field... then in the smart view click on the comments column header to sort it asc/desc.

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 7th October 2007, 11:08   #261
proove2613
Junior Member
 
Join Date: Aug 2007
Posts: 11
Sometimes when closing winamp, the following errors occur:

---------------------------
Assertion failed
---------------------------
Expression: hdc != NULL
File: .\canvas\win\win32_canvas.cpp
Line: 1029




---------------------------
Microsoft Visual C++ Runtime Library
---------------------------
Runtime Error!
Program: C:\Program Files\Winamp\winamp.exe
R6025
- pure virtual function call

Using W Vista
proove2613 is offline  
Old 7th October 2007, 11:57   #262
Franky_B
Junior Member
 
Join Date: Aug 2002
Posts: 19
I've downloaded the toolbar from http://download.gdownload.nullsoft.c...es/toolbar.exe

See Attachment to see what happens, when i try to install it
Attached Images
File Type: jpg error.jpg (17.3 KB, 266 views)
Franky_B is offline  
Old 7th October 2007, 12:49   #263
mynameisnobody
Senior Member
 
mynameisnobody's Avatar
 
Join Date: Jan 2006
Location: Austria
Posts: 149
as "xamphear" wrote(http://forums.winamp.com/showthread....33#post2249233)
on some files, the embedded albumart is not shown.
With the last build there was´nt a problem with these files.

If I remove the embedded cover and re-insert it, it will be shown.

Any idea, why?
mynameisnobody is offline  
Old 7th October 2007, 13:38   #264
SwIeRsZcZ
Junior Member
 
SwIeRsZcZ's Avatar
 
Join Date: Oct 2006
Location: Poland
Posts: 34
Do u know , when there will be the FINAL release of ver. 5.5 ?? :/
SwIeRsZcZ is offline  
Old 7th October 2007, 13:43   #265
DrO
 
Join Date: Sep 2003
Posts: 27,873
Re: ID3 Editor - Artwork Editor

Quote:
Originally posted by lordsky
Could you have "Load Artwork..." start in the folder the song is in, instead of starting in My Documents? I hate to have to traverse all those folders to locate my cover.
you're not the only one and a initial directory has now been specified with the load/save artwork open file dialogs

@SwIeRsZcZ: google for 'winamp 5.5 release date' (though i think a fixed release date is stupid but there we go...)

-daz
DrO is offline  
Old 7th October 2007, 14:43   #266
niktheguru
Senior Member
 
Join Date: May 2003
Location: London, UK
Posts: 120
If possible guys can we have the option to save album art into the IDv3 tags please?? Nearly all my songs have album art in this format, and its good that winamp reads it but can it be possible for an option to write it there too?

Thanks guys, keep up the good work.

Nikhil
niktheguru is offline  
Old 7th October 2007, 15:12   #267
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
@nicktheguru
Unlikely to happen in time for this release, but maybe there'll be an option to embed/save art to tags in a forthcoming 5.5x release....?


@mynameisnobody
Please see Known Issues section of first post.
Embedded art not showing in Alt+3 is fixed for 5.5 Final


@Franky_B
Delete the toolbar.exe file, empty your internet cache, then download the setup file again. Do not use any 3rd-party download manager (eg. GetRight, etc). Use rt-click -> Save Target/File As, save it to your hard drive, then double-click to run it.

The file should be v5.1.6.2 at 1.13 MB

If it's smaller than that, then I suggest that you run a full AV scan, and also use Ad-Aware and/or Spybot SD to scan for any adware/spyware/trojans.


@proove2613
Please attach the (zipped) error logs
(see: Winamp > Prefs > Error Feedback for details)
DJ Egg is offline  
Old 7th October 2007, 16:11   #268
iron2000
Senior Member
 
iron2000's Avatar
 
Join Date: Mar 2002
Location: Singapore
Posts: 391
Quote:
Originally posted by TheUniqueTiger
Customize the columns in the bottom pane of the smart view to show the comments field... then in the smart view click on the comments column header to sort it asc/desc.
What I mean is the panes above that larger one below.
Is it possible to make it display comments too instead of artist and album?

Thanx
iron2000 is offline  
Old 7th October 2007, 18:13   #269
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Quote:
Originally posted by iron2000
What I mean is the panes above that larger one below.
Is it possible to make it display comments too instead of artist and album?
You can build a smart view query for comments but not the upper panes/columns as that is not one of the options there...

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline  
Old 7th October 2007, 18:19   #270
ecereb
Junior Member
 
Join Date: Sep 2007
Location: Cincinnati
Posts: 12
Quote:
Originally posted by DJ Egg

Unlikely to happen in time for this release...?
I haven’t heard anything about WAV files exported by WinAmp to the iPod Classic not playing on the iPod Classic.
Setting: (transcodeWavFiles=0)
ecereb is offline  
Old 7th October 2007, 18:58   #271
xamphear
Senior Member
 
Join Date: Sep 2007
Location: NH, USA
Posts: 106
Feature Request: A global keyboard shortcut action for "Show Notifier"
xamphear is offline  
Old 7th October 2007, 19:45   #272
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Re: Album Art for Albums with the same title

Quote:
Originally posted by DJ Egg
This was the last preview before Final.
If there's still any minor bugs (hopefully not) then there's always 5.51/2/3/etc to fix them. As you surely know, no software can ever be 100% bug free. Someone will eventually always find something.
I haven’t pestered about this one, as I know the DEVs are often looking at things even if they are NOT being discussed in the BETA thread, but I hope the previously documented issue with displaying the correct Album Art for Albums with the same title will be looked into/addressed before release of the final build.

Whereas embedding Album Art into ID3 tags and the capability to configure the location of Album Art image files could be introduced in a later release with little affect on existing functionality (ex. if ability to configure Album Art location is put in at a later date … users who already downloaded Album Art can just drag & drop their existing image files
to the folder at its new location), the same can NOT be said for the naming scheme
used in saving image files for use in displaying Album Art via the %album% method.

Once released to a mass audience via the Final build, users are going to begin grabbing Album Art for their huge music collections (ie. many many image files). I would speculate most users will not be very excited about the prospect of having to edit the filenames of these existing image files at a later date because the naming scheme needed update.

Sorry to bug the powers that be with redundant posts, but I just think this is a design decision that needs to be thought over again before it is too deeply rooted in the user base to consider changing.

Last edited by jph6t; 7th October 2007 at 20:15.
jph6t is offline  
Old 7th October 2007, 20:25   #273
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
What are the drawbacks of storing album art in tags?

The only drawbacks I can think of;

1) Having to update the album art of every mp3 in an album if you find a better quality image of the art. (there are third party tools that make this pretty easy)

2) Maybe some small % increase in size of the entire mp3 collection, because you are redundantly saving the same album art to multiple files.
soulstace is offline  
Old 7th October 2007, 22:30   #274
Mecha25
Member
 
Join Date: May 2004
Posts: 55
Overview and comments

@JW, just a shout out, your idea for organizing album art is fantastic, I take my hat off to you sir!

@Proove2613, DUPLICATED!!! More times than I can freaking count, and it always undoes all the changes I've made to winamp configurations (they don't get saved).
Also, this only happens when I'm exiting in a modern skin and playing a song at the same time.
I've looked, but for some reason this crash produces no error logs for me. The whole program crashes, the error reporter doesn't even get a chance to run. sorry!

NO MORE VISTA CRASH'N'BURNS!

Scrollbar issues:

Modern Skin scrollbars still don't change their bar size to match the size of the content being scrolled, makes it very awkward to use in my opinion.

Scrollbars in modern skin for website browsing are really primitive looking, and still appear even when the page cannot be scrolled

It would be nice if you could shrink the Multi-Content pannel in bento to zero, but not critical

Beat vis in Bento is a tad too sensitive, on heavier/louder tracks (even Blink 182) it is on solid the whole time
Wish the Bento seeker could be made longer in stick

outright bugs:
Bento crashed when trying to rapidly choose color themes, but didn't shut down windows (thank goodness).

When album art below playlist is accidentally shrunk to zero, it takes going back to the menu to get it back


Kn0tte's ML behind bug DUPLICATED! From complete clean install, open modern skin, open media library, close media library, close winamp.
Then open winamp, select the main window, and open the ML. it will open behind the main window. Kinda annoying, but nothing big.
Also, his songticker bug happens for me too, I assume this will be fixed for final as the Winamp Beta message will be taken out.

Psst, hey Mr.Winamp-pro-feature-decider... is it just me, or can WMP do everything that Winamp pro can except for the high quality HE-AAC ripping?...
I'd LOVE to support you guys by buying it, but it goes totally against my financial sense to buy an expanded product whose expansion features I already have...
PLEASE find some more features (above and beyond other music players and the current betas) and put them in pro so I can justify its purchase. (Or just open a donations account, I'd be fine with giving y'all some cash)
Mecha25 is offline  
Old 7th October 2007, 23:03   #275
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
Quote:
With Winamp Pro you can:
-Rip CDs in MP3 (preferred)
-Burn and Rip Faster
-Support Winamp
Even though I still can't reproduce Kn0tte's bug, I will have to agree that there is something going wrong with the modern skin and ML. Winamp has just crashed on me about 4 times when trying to reproduce his bugs.

Winamp closes fine, when the EQ is shown, as long as the ML is snapped to the edge of the EQ. But if I drag the ML up and snap it to the bottom of the playlist (with the EQ still open), Winamp has a Runtime Error when I try to exit.
soulstace is offline  
Old 8th October 2007, 00:33   #276
Kn0tte
Major Dude
 
Join Date: Feb 2007
Posts: 585
Re: Overview and comments

Quote:
Originally posted by Mecha25

Kn0tte's ML behind bug DUPLICATED! From complete clean install, open modern skin, open media library, close media library, close winamp.
Then open winamp, select the main window, and open the ML. it will open behind the main window. Kinda annoying, but nothing big.
Also, his songticker bug happens for me too, I assume this will be fixed for final as the Winamp Beta message will be taken out.
Yeah! You`re the man! I knew/hoped it was not only me who are getting these bugs..
DJ EGG - ...... -> What are you saying? Do a complete, completely clean install and test it.. It is true - These bugs happens.

As for the songticker bug (when opening winamp, it displays beta message instead of the song, until you click another song. you have to have shuffle OFF to get this).. Maybe.. The Winamp Beta message will not be taken out, but will be replaced by "Winamp 5.5" (I think)..

Please, DJ Egg, and the God - Im begging you Please fix the Media Library bug and the songticker text bug for Winamp 5.5 Final..
You dont know how happy I will be if you do... I know you can do it
Kn0tte is offline  
Old 8th October 2007, 00:45   #277
HailandKill
Junior Member
 
Join Date: Oct 2007
Posts: 2
Should the 'on end of queue' option be working? Because mine isn't. Doesn't do a thing.

Oh.. and after turning off the main window, I couldn't get it back without a re-install.
HailandKill is offline  
Old 8th October 2007, 00:49   #278
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,822
@ soulstace & Mecha25 & Proove2613

Please post screenshots of the exact Winamp setup/window-docking procedure to reproduce this reported crash on exit.

Please upload the screenshot to stashbox.org
which will then give you two links, one for the full image and one for the thumbnail.

Post the thumbnail image here, and url link it to the full image,

eg. [ url=http://stashbox.org/123456/image.jpg][img ]http://stashbox.org/123456/image.jpg[/img][/url]

Naturally, remove the spaces in [ url= and [img ]
(I only included those so it didn't get posted as vb code)

___________________________________________________________


@ Kn0tte

Likewise for you. Screenshot of the exact setup please (for the ML problem).
Trust me, I can't reproduce either issue, and I've tried many times.
Maybe you could also attach a HJT log so we can what other processes are running concurrently?


@Mecha25

Re: Modern Skin scrollbars still don't change their bar size to match the size of the content being scrolled...

Winamp > Prefs > Media Library > Library Options tab:
Uncheck "Use freeform scrollbars when available"

Re: Scrollbars in modern skin for website browsing are really primitive looking...

Those are Internet Explorer scrollbars, and nothing to do with Winamp (ie. we're just using embedded IE pages for the browser).

Re: When album art below playlist is accidentally shrunk to zero, it takes going back to the menu to get it back

Alas, that is expected behaviour... for now.


@xamphear
Show Notifier global hotkey already exists
(Playback: Show Notification)


@ecereb
Neither have I. You're very lucky that it even works at all for newer iPods (because as of a couple of weeks ago, it didn't). I expect more iPod Classic/Touch etc tweaks to come throughout the 5.5x series.


@jph6t
I agree wholeheartedly. Fear not, we know all about it. It's just that we're almost out of time now, and I can't see it being implemented for this release.
Ideally, you should be able to specify somewhere things like:
Album Art saving: Containing Dir | %artist% - %album%
Album Art local lookup criteria/order: Containing Dir | Specify Folder | etc.
If only you knew just how much work has gone into getting us where we are now, then I'm sure you'd understand that the extra fine-tuning of things like that can also wait for next/forthcoming 5.5x releases.


@HailandKill

Hmm... which skin?
Right-click the Winamp taskbar (or system tray) icon, and select:
Winamp > Main Window.
It should then reappear.

I'm not sure about the "jtfe > on end of queue" thing.
Let me take a look....

[Edit]

Seems to be working fine here...

I queued up a couple of tracks (using Alt+click on two items in playlist)
then opened Jump To File dialog (J),
clicked the big button to switch to Queue Manager mode,
right-clicked in there and selected: On end of queue > Stop playback
and Winamp stopped playing after the two tracks in the queue were finished.

I didn't test any of the other 'on end of queue options' (power mode, log off, etc).
DJ Egg is offline  
Old 8th October 2007, 01:29   #279
Mecha25
Member
 
Join Date: May 2004
Posts: 55
oh brother

sorry to keep harping on compatibility with this one skin, but it's one of my favorites. Quadelic, by Takanory,
http://takanory.deviantart.com/art/Quadelic-36391651
no longer works with the Winamp 5.5 betas as of beta 3. The skin displays fine (thanks to the antialiasing="1" trick) but the config, dock, and mini windows simply don't show up in the right click menu, thus making those windows completely inaccessable. Quadelic was built with Wasabi V1.2. As of beta2, these were working beautifully, but now the best features of the skin have disappeared. Hopefully this is a fluke that will disappear for the final, but if someone could look in to duplicating it, or finding another skin that does this I'd appreciate it.
Mecha25 is offline  
Old 8th October 2007, 02:17   #280
soulstace
Senior Member
 
Join Date: Sep 2007
Posts: 116
DJ,

Not much need for screenshots in my case, because it happens with the default layout of Modern skin. For example,

[Winamp][Playlist]
[Media Library]

Everything neatly stacked (or snapped) together. Open EQ, and now you have

[Winamp][Playlist]
[EQ]
[Media Library]

The ML automatically snaps to the bottom of the EQ.

Move the Media Library vertical and let it snap to the bottom of the Playlist (The EQ will still be open, but hidden behind the ML)

Clicking the [x] in Winamp main window is what causes me to get a Runtime Error.
soulstace is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump