Old 6th October 2009, 21:37   #1
Wulf74
Junior Member
 
Join Date: Oct 2009
Posts: 2
Windows 7 - 32bit and Registration Keys

Hopefully I'm doing this right - posting a new topic and all.

I purchased the full version of Winamp several years ago, and have loved every minute of it. Over the years I've had to re-install Windows or upgrade to newer versions several times - and each time when I installed it took the old key flawlessly.

Which brings us to know - I've upgraded to Windows 7(x86) - and have been adapting to it slowly (I never went to Vista). Anyway, Winamp installed fine - but when I entered my registration information in - the same as it's been for years now - I'm being told it's an invalid license.

I've uninstalled and reinstalled Winamp a few times now - as well a multiple reboots - with the same result. Please help - I've gotten so accustomed to having Winamp I feel like I'm missing a limb, I've come to rely on it so much.

Thanks
Wulf74 is offline   Reply With Quote
Old 6th October 2009, 22:19   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,102
Hi

See here first:
http://blog.winamp.com/2009/07/21/winamp-answers-3/

Try the compatibility settings.

Note, as it's Windows 7 (which isn't officially yet supported in Winamp 5.56),
I recommend that you switch to the Classic skin before closing Winamp
and then adjusting the compat settings referenced in that post.

You can always switch back to the Bento or Modern skin later
(after you've got the reg key to take and you've undone the compat setting changes).

If the problem persists...

FAQ

I need to contact Winamp Pro Support!
http://forums.winamp.com/showthread....did=294846#pro

Send an email to the address in that post.
Be sure to include Cystomer Name, Customer Email address & Order Number, if possible.
DJ Egg is offline   Reply With Quote
Old 6th October 2009, 22:31   #3
Wulf74
Junior Member
 
Join Date: Oct 2009
Posts: 2
Terrific, thank you. I made the changes suggested in the Winamp Answers link, as well as changed it to the classic skin. I was able to enter the registration code without a hitch.

Strangely, when I tried to change it back to the modern skin - it errors out, and ends the program. But it runs fine with the classic skin - I'm ok with that.

Thanks much for your help and quick response!
Wulf74 is offline   Reply With Quote
Old 6th October 2009, 22:40   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,102
Marvellous.

Yes, you now need to UNDO the compatibility settings, i.e. uncheck them.

Windows 7 doesn't seem to like the Modern Skin Engine running under WinXP-compatibility mode.

You only needed to change those compatibility settings to get the reg key to work.

Note that this issue will hopefully be fixed for the next release,
which will be a lot more Windows 7 friendly :-)
DJ Egg is offline   Reply With Quote
Old 3rd November 2009, 11:43   #5
kilowattradio
Junior Member
 
Join Date: Nov 2009
Posts: 2
Win 7 32 Pro Error with WinAmp 5.56

I followed the FAQ #3 instructions to allow WinAmp to run under Win7 32 bit Pro. The following attached pic appears when I run the program.
Attached Images
File Type: jpg winamp_error.jpg (7.9 KB, 241 views)
kilowattradio is offline   Reply With Quote
Old 3rd November 2009, 13:46   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,102
You didn't follow my above instructions.
Read them again.

You need to temporarily switch to the Winamp Classic skin.
Close Winamp
Temporarily adjust those two compatibility settings (checkmark: run as admin & winxp sp3 mode)
Reopen Winamp
Enter the reg name & key
Then close Winamp and undo the two compatibilty settings (ie. uncheck them again).
Now you can reopen your Pro-registered Winamp and switch back to the Bento or Modern skin.

Also note that this issue will be fixed in the next Winamp release.
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump